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About the Author

In case you're reading this biography, wondering who wrote this book, the
answer is simple. I did.

If that simple statement doesn’t satisfy your curiosity, you might like to know
that I've written several dozen computer books, most of which are out of
print (unless someone still wants a book teaching them about the joys

of Turbo Pascal programming or how to write macros in WordPerfect 5.0

for DOS).

Besides writing books on obsolete computer topics, I've also written books
about the Macintosh, computer hackers, real estate investing, stock market
day trading, computer programming, the iPhone, the iPad, and breaking into
acting. I enjoy writing about different topics just to keep myself amused and
learn something new each time. Otherwise if | let my mind stagnate, I might
wind up believing what left and right wing extremists try to tell me.
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Remember, you're not alone in your suffering trying to master Microsoft
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Office user in the world.
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Introduction

Welcome to the most popular office productivity software in the world.
If you're already familiar with Microsoft Office 2007, you’ll find that

the new Microsoft Office 2010 is familiar enough to use right away with mini-
mal training, but comes jampacked with additional features to make Office
even more useful than ever before. If you've been using a much older version
of Office such as Office 2003 or earlier, you'll find Office 2010 to be a radical
leap forward in both features and its new user interface.

Like most software, the real challenge is figuring out where to find the com-
mands you need to do something useful. While this book won’t turn you into
a Microsoft Office 2010 expert overnight, it will give you just enough informa-
tion so you can feel confident using the new Office 2010 and get something
done quickly and easily.

In this book, you find out how to master the “Ribbon” user interface along
with discovering the dozens of new features that Microsoft added to Office
2010. More important, you find a host of shortcuts and tips to help you work
faster and more efficiently than ever before. Whether you rely on Word,
Excel, PowerPoint, Access, or Outlook, you're sure to glean something new
from this book to help you master Office 2010 on your own computer.

Who Should Buy This Book

This book is targeted toward three distinct groups. First, there are the people
already familiar with Microsoft Office 2007 who want to catch up with the
new features of Office 2010. For these people, this book can serve as a handy
reference to finding out how to use the latest features.

Second, there are people upgrading from an older version of Microsoft Office,
such as Office 2003 or Office XP. For these people, this book can serve as

a gentle guide to help you make the transition from traditional pull-down
menus to the new “Ribbon” user interface.

Finally, there might be people who may have rarely (if ever) used any version
of Microsoft Office at all. For those people, this book can serve as a guide
through word processing (Microsoft Word), number calculations (Microsoft
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Excel), presentations (Microsoft PowerPoint), database management
(Microsoft Access), and managing your personal resources like time, appoint-
ments, and e-mail (Microsoft Outlook).

No matter how much (or how little) you may know about Microsoft Office,
this book can show you how to use the most common and most useful fea-
tures of Office 2010 so you can start being productive right away.

How This Book Is Organized

To help you find what you need, this book is organized into parts where each
part covers a different program in Office 2010.

Part I: Getting to Know
Microsoft Office 2010

To use Microsoft Office 2010, you need to know how to find the commands
you need. This part of the book focuses on showing you how to use the
Ribbon user interface that appears in all Office 2010 programs. By the time
you finish this part of the book, you’ll feel comfortable using any program in
Office 2010.

Part 1I: Working with Word

Word processing is the most popular use for Office 2010, so this part of the
book explains the basics of using Word. Not only will you find out how to
create and save different types of documents, but you'll also master different
ways to alter text, such as using color, changing fonts, adding headers and
footers, checking spelling and grammar, and printing your written master-
piece so it looks perfect.

Part I11: Playing the Numbers with Excel

If you need to manipulate numbers, you need Microsoft Excel. This part of
the book explains the three basic parts of any spreadsheet, how to format
data, how to create formulas, and how to create different types of charts to
help you visualize what your spreadsheet numbers really mean. Not only will
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you discover how to calculate and “crunch” numbers, but you’ll also find
how to analyze the results and turn them into eye-catching charts to help you
understand trends that may be buried within your data. If you want to find
out how to use Microsoft Excel to create, format, and display spreadsheets,
this is the part of the book for you.

Part IU: Making Presentations
with PowerPoint

Throw away your overhead transparencies and clumsy whiteboard and
pads of paper. If you need to give a presentation to a large group, you need
to know how to create colorful and visually interesting presentations with
PowerPoint instead. With PowerPoint, you can organize a presentation into
slides that can display text, pictures, animation, and even video. By master-
ing PowerPoint, you can create presentations that grab an audience’s atten-
tion and emphasize the points you want to make while holding their interest
at the same time.

Part U: Getting Organized with Outlook

Almost nobody feels that they have enough time to stay organized, so this
part of the book explains why and how to use Microsoft Outlook. With
Outlook, you can read, sort, and write e-mail, keep track of appointments,
store names and addresses of your most important contacts, and even orga-
nize your daily to-do tasks. By using Outlook to manage your busy schedule,
you can turn your computer into a personal assistant to make you more pro-
ductive than ever before.

Part Ul: Storing Stuff in Access

If you need to store large amounts of information, such as tracking inven-
tories, organizing customer orders, or storing names and addresses of pro-
spective customers, you may need to use a database program like Microsoft
Access. In this part of the book, you see how to use Access to store, retrieve,
sort, and print your data in different ways. With Access able to slice and dice
your information, you can better analyze your data to understand how your
business really works.
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Part Vll: The Part of Tens

Almost every program offers multiple ways of accomplishing the same task,
and Office 2010 is no exception. After you get familiar with using Office, take
a peek in this part of the book to read about different types of shortcuts you
can use to work with Office even faster than before. By the time you get to
this part of the book, you’ll be much more comfortable using Office 2010 so
you can feel comfortable exploring and experimenting with different features
on your own.

How to Use This Book

Although you can just flip through this book to find the features you need,
browse through Part I for a quick refresher (or introduction) to the Office 2010
user interface Ribbon. After you understand the basics of using this new Ribbon
user interface, you'll be able to master any Office 2010 program in no time.

Conventions

To get the most from this book, you need to understand the following
conventions:

v The mouse pointer usually appears as an arrow and serves multiple pur-
poses. First, you use the mouse pointer to select data (text, numbers,
e-mail messages, and so on) to change. Second, you use the mouse
pointer to tell Office 2010 which commands you want to use to change
the data you selected. Finally, the appearance of the mouse pointer can
reveal the options available to you at that moment.

v Clicking means moving the mouse pointer over something on the screen
(such as a menu command or a button), pressing the left mouse button
once, and then letting go. Clicking tells the computer, “See what 'm
pointing at? That’s what I want to choose right now.”

v Double-clicking means pointing at something with the mouse pointer and
clicking the left mouse button twice in rapid succession.

v Dragging means holding down the left mouse button while moving
the mouse. Dragging typically moves something from one location to
another, such as moving a word from the top of a paragraph to the
bottom.

v Right-clicking means moving the mouse pointer over something and
clicking the right mouse button once. Right-clicking typically displays a
shortcut menu of additional options.
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In addition to understanding these terms to describe different mouse actions,
you also need to understand different keystroke conventions too. When you
see an instruction that reads Ctrl+P, that means to hold down the Ctrl key,
press the P key, and then let go of both the Ctrl and P key at the same time.

Finally, most computer mice offer a scroll wheel that lets you roll it up or
down, or press on it. This scroll wheel works to scroll windows up or down,
whether you’re using Office 2010 or nearly any other type of program as well.
In Office 2010, the scroll wheel doesn’t serve any unique purpose, but it can be
a handy tool for rapidly scrolling through windows in any Office 2010 program.

Icons Used in This Book

\\J
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Icons highlight important or useful information.

This icon highlights information that can save you time or make it easier for
you to do something.

This icon emphasizes information that can be helpful, although not crucial,
when using Office 2010.

Watch out! This icon highlights something that could hurt or wipe out impor-
tant data. Read this information before making a mistake that you might not
be able to recover from again.

This icon highlights interesting technical information that you can safely
ignore but which may answer some questions about why Office 2010 works a
certain way.

Getting Started

The best way to master anything is to jump right in and start fiddling with dif-
ferent commands just to see what they do and how they work. In case you're
afraid of breaking your computer or wiping out important data, play around
with Office 2010 on a “dummy” document filled with useless information you
can afford to lose (like your boss’s income tax returns).
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Here’s your first tip. Any time you do something in Office 2010, you can undo
or take back your last command by pressing Ctrl+Z. (Just hold down the Ctrl
key, press the Z key, and release both keys at the same time.) There, now
that you know about the powerful Undo command, you should have a surging
sense of invulnerability when using Office 2010, knowing that at any time you
make a mistake, you can turn back time by pressing Ctrl+Z to undo your last
command.

If you get nothing else from this book, always remember that the Ctrl+Z com-
mand can save you from yourself. See? Mastering Office 2010 is going to be
easier than you think.
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In this part . . .

f you're already familiar with an earlier version of

Microsoft Office, then staring at the bizarre appear-
ance of today’s Microsoft Office 2010 might feel foreign
and alienating. However, after you get over your initial
fear or hesitation about Microsoft Office 2010, you’ll soon
find that there’s actually an elegance behind its seemingly
chaotic appearance.

Since you can’t really use Microsoft Office 2010 without
knowing how to find the commands you need to make the
program do what you want, this part of the book gently
introduces you to the basics of using all of its programs.
You'll learn how to create, edit, add, and delete text and
pictures. More importantly, you'll also learn how to mod-
ify pictures within each program. If you have pictures cap-
tured from a digital camera, Microsoft Office 2010 makes it
easier than ever to add those pictures in your documents
and modify them for corrective or artistic purposes.

This part of the book also introduces you to the strange
new Ribbon user interface. If you're already familiar with
Microsoft Office 2007, you'll find that the Ribbon interface
has gone through minor modifications. However, if you're
more familiar with older versions of Microsoft Office
(2003/XP/2000/97), then you might wonder where all the
pull-down menus have gone.

Relax. This part of the book is where you can learn how to
decipher all icons and commands buried on the Ribbon
interface. You'll learn how to tell what various icons do
and what kind of information they can show you. Of
course, you'll also learn how to see all your options and
learn how to find the command you want and accomplish
a specific task in the shortest amount of time possible.

While this book can guide you into mastering Microsoft
Office 2010, it can’t provide all the answers. To get the
answers that you need, this part of the book will also
show you how to browse and search through Microsoft
Office’s own help system.

Before you know it, you’ll be well on your way to under-
standing and feeling comfortable using Microsoft Office
2010. At that point, you can start using your favorite pro-
gram and get something useful done.




Chapter 1

Introducing Microsoft Office 2010

In This Chapter
Starting an Office 2010 program

Learning the Microsoft Office Backstage View

Using the Quick Access toolbar

Learning the Ribbon

Customizing an Office 2010 program
Exiting from Office 2010

\\3

M icrosoft Office 2010 consists of five core programs: Word, Excel,
PowerPoint, Access, and Outlook. Each of these core programs spe-
cializes in manipulating different data. Word manipulates words, sentences,
and paragraphs; Excel manipulates numbers; PowerPoint manipulates

text and pictures to create a slide show; Access manipulates data, such as
inventories; and Outlook manipulates personal information, such as e-mail
addresses and phone numbers.

Although each Office 2010 program specializes in storing and manipulating
different types of data, they all work in similar ways. First, you have to enter
data into an Office 2010 program by typing on the keyboard or loading data
from an existing file. Second, you have to tell Office 2010 how to manipulate
your data, such as underlining, enlarging, coloring, or deleting it. Third, you
have to save your data as a file.

To help you understand this three-step process of entering, manipulating,
and saving data, Office 2010 offers similar commands among all its programs
so you can quickly jump from Word to PowerPoint to Excel without having to
learn entirely new commands to use each program. Even better, Office 2010
rearranges its numerous commands so finding the command you need is
faster and easier than ever before. (If you think this implies that previous ver-
sions of Microsoft Office were clumsy and hard to use, you're right.)

If you're already familiar with computers and previous editions of Microsoft
Office, you may want to browse through this chapter just to get acquainted
with how Office 2010 rearranges common program commands. If you've never
used a computer before or just don’t feel comfortable using Microsoft Office,
read this chapter first.
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Starting an Office 2010 Program

The most straightforward way to load any Office 2010 program is to choose
a program from the Start menu, and then create a new document or open an
existing one. To do this, follow these steps:
1. Click the Start button on the Windows taskbar.
A pop-up menu appears.
2. Choose All Programs.
Another pop-up menu appears.
3. Choose Microsoft Office.
A list of programs appears on the Start menu.

4. Choose the Office 2010 program you want to use, such as Microsoft
Word 2010 or Microsoft PowerPoint 2010.

Your chosen program appears on the screen. At this point, you can open
an existing file.

Starting an Office 2010 program from the Start menu is most useful when
you want to create a new document. If you just want to load an existing file,
loading a Microsoft Office 2010 program and then loading that file is a clumsy
two-step process. For a faster way to load a file and the Microsoft Office 2010
program that created it, follow these steps:
1. Click the Start button on the Windows taskbar.
A pop-up menu appears.
2. Choose Documents.
A dialog box appears.
3. Double-click the file you want to open.

You may need to open a different folder or drive to find the file that
you want.

Introducing the Microsoft
Office Backstage View

One major change in Office 2010 is the Microsoft Office Backstage View,
which replaces the traditional File menu in older versions of Office and the
Office Button in Office 2007.
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|
Figure 1-1:
The new
Microsoft
Office
Backstage
View.
|

The Microsoft Office Backstage View appears in all Office 2010 programs and
isolates common file commands on a single screen so you can see all your
options at once, as shown in Figure 1-1:

v The left pane of the Backstage View lists common commands for creat-
ing, saving, or printing your file.

v The middle pane typically displays additional options you can choose
for the command selected in the left pane.

v The right pane displays additional details about your file.

In Figure 1-1, the Info command is selected in the left pane, the middle pane
displays three options, and the right pane displays detailed information
about your document, such as how long you’'ve been working on it and how
many words it contains.

In Figure 1-2, the New command is selected in the left pane, the middle pane
displays different types of files you can create, and the right pane displays a
preview of a file type selected in the middle pane.

Home .'_-:-- Page Layuut References Mailing: Fevzw iew 9
i save . :
: Information aboul Document
B savens
£ Open = Permissions
o cisse Sud Arryone can wpen, copy, end change ary part of this document,

Protect
Dracurnent =

Rucnrit Froperties =
Prepare for Sharing
Mew Befare shaning this file, be aware thal it contains
=i Diacument proparies snd suther's name
Brint Check for
Tssiars =

Save & send

Versions

Help 3 Related Dates
)| 3 There are no presinus versions of this file

21 oetions Monage

Oen Version: -

Related Prople

i

11



Part I: Getting to Know Microsoft Office 2010

7] = o
Home  Bnset  Pageloyuul  References  Mailings  Peview  View (7]
i save
Available Templates Agenda
B swve s Bk e Tl
a 5 Diownbosd size: LOKD
* Hi » ! 5 "
i Dpen Cl Agendas Rabing: 32
- cioae Ciffice.com Templates arch Offrie.com for template +

i AGENDA
Inifa —

Recent

S

Print
Bgends Enfrmal meeting sgends Agenda wezard

Save & Send

Help

E— *] Optinns 3 Vi s
(R0 -
Figure 1-2: =
The = 3
Microsoft Meeting sgends  Agends {Caprules desgn)  Conference agends L_W:'M
Office
Backstage
View con-
sists of three
panes of

information.
© @

To use the Backstage View, follow these basic steps:

\J 1. Click the File tab to display the Backstage View.

You can also open the Backstage View by pressing Alt+F and using
either the keyboard or the mouse to choose additional commands.

2. Select a command in the left pane to view your options in the middle
pane.

3. Select an option in the middle pane.
4. View the information (or select a command) in the right pane.
égN\BEIf Sometimes when you select a command in the left pane (such as the Save
& command), you won'’t see any further options in the middle or right panes.

Likewise, sometimes when you select an option in the middle pane, you won’t
see any additional information displayed in the right pane.

To exit the Backstage View, click the File tab again.
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The File tab

The various commands available on the File tab include
v Save: Saves your file. If you haven’t named your file yet, the Save com-
mand is equivalent to the Save As command.

v Save As: Save the current file under a new name and/or in a different file
format.

v Open: Loads an existing file.

v Close: Closes an open file but keeps the Office 2010 program running.
v Recent: Displays a list of files that you recently loaded.

1 New: Creates a new file.

v Print: Prints the current file.

v~ Share: Sends a file as an e-mail attachment or fax along with saving the
file in different formats (similar to the Save As command).

v Options: Displays various options for customizing the way each Office
2010 program behaves.

v~ Exit: Closes any open files and exits the Office 2010 program.

In Word, a file is called a document. In Excel, a file is called a workbook. In
PowerPoint, a file is called a presentation. In Access, a file is called a database.

Creating a new file

Each time you create a new file, you have the option of choosing different
types of templates that are already formatted and designed for specific pur-
poses, such as a calendar, newsletter, sales report, or corporate slide show
presentation, as shown in Figure 1-3.

To create a new file, follow these steps:

1. Click the File tab.

The Backstage View appears.
2. Click New.

A list of templates appears (see Figure 1-3).
3. Double-click the template you want to use.

Office 2010 creates a new file based on your chosen template. For some
templates, you may need access to the Internet to download the tem-
plates from Microsoft’s Web site.

13
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Opening an existing file
When you load an Office 2010 program, you may want to edit a file that you
created and modified earlier. To open an existing file, you need to tell Office
2010 the location and name of the file you want to open. Just follow these
steps:
1. Click the File tab.
The Backstage View appears.
2. Click Open.
An Open dialog box appears, as shown in Figure 1-4.

3. (Optional) Click a folder, and then click Open to search for a file
inside a folder. Repeat this step as many times as necessary.

4. Click the file you want to open, and then click Open.

Your chosen file appears, ready for editing.
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Opening a recently used file

As a shortcut, Office 2010 keeps track of your most recently opened files and
stores them in a list so you can find them again. If you need to open a file that
you opened earlier, you may find it much faster by locating it through this list
of recently opened files.

To open through the recently used file list, follow these steps:

1. Click the File tab.

The Backstage View appears.
2. Click Recent.

The list of recently opened files appears, as shown in Figure 1-5.
3. Click a file.

Your chosen file appears.

Wl d Goldie Lecks - Microsoft
Home Insert Page Layuul References Mading: Revima Wiew
i save
Recant Documeants
B savess
r Galdie Lacks
T open | M Document
o Close | ] Treasure map to plutonium
Inta

tial file of rmisteesses
£ withaut saving:

B !_IJ Confidertial file of misresses
MNew ﬂ-' List of aur warst fpies
Priet E_] UFiD secrets
Save & Send o
Help
] Options
(=R

15



’ 6 Part I: Getting to Know Microsoft Office 2010

A\

a\\s

The list of recently opened files changes each time you open a different file. If
you want to keep a particular filename always displayed on this list, click the
Pin icon that appears to the right of the filename.

Saving files
Saving a file stores all your data on a hard disk or other storage device (such

as a USB flash drive). The first time you save a file, you need to specify three
items:

v The drive and folder to store your file
v The name of your file

v The format to save your file

The drive and folder where you store your files are completely arbitrary.
However, it’s a good idea to store similar files in a folder with a descrip-

tive name, such as Tax Evasion Information for 2011 or Extortion Letters to
Grandma. By default, Office 2010 stores all your files in the Documents folder.

The name of your file is also completely arbitrary, but it’s also a good idea
to give your file a descriptive name, such as Latest Resume to Escape My
Dead-End Job or Global Trade Presentation for World Domination Meeting on
September 9, 2012.

The format of your file defines how Office 2010 stores your data. The default
file format is simply called Word Document, Excel Workbook, PowerPoint
Presentation, or Access Database. Anyone using Office 2010 or Office 2007
can open these files.

Saving a file for Office 2010/2007
To save your files in the latest Office format, follow these steps:

1. Click the File tab.
The Backstage View appears.
2. Click Save.

If you have previously saved this file, you just need to complete Steps 1
and 2. If this is the first time you're saving the file, a Save As dialog box
appears and you need to complete Steps 3, 4, and 5.

For a quick way to save a file, click the Save icon that appears above the
File tab or press Ctrl+S.

3. Click in the File Name text box and type a descriptive name for
your file.

4. (Optional) Click on a different folder or location to store your file.
5. Click Save.
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After you save a file once, you have to go through only Steps 1 and 2 again.

Saving a file for older versions of Microsoft Office

If you need to share files with people using older versions of Microsoft Office,
you need to save your files in a different file format known as 97-2003, such as
Word 97-2003 Document or PowerPoint 97-2003 Presentation.

This special 97-2003 file format saves Office 2010 files so that previous ver-
sions of Microsoft Office 97/2000/XP/2003 can open and edit your files.

When you save files in the 97-2003 format, Microsoft Office 2010 saves your
files with a three-letter file extension, like . doc or .x1s. When you save files
in the Office 2010 format, Microsoft Office 2010 saves your files with a four- or
five-letter file extension, such as . docx or .pptx, as shown in Table 1-1.

Table 1-1 File Extension Names Used by Different
Versions of Microsoft Office

Program Microsoft Office 2010 Microsoft Office 97-2003
File Extension File Extension

Microsoft Word .docx .doc

Microsoft Excel .x1lsx .x1s

Microsoft PowerPoint .pptx .ppt

Microsoft Access .accdb .mdb

To save your Office 2010 files in the 97-2003 format, follow these steps:

1. Click the File tab.
The Backstage View appears.

2. Click Save & Send.
The middle pane displays different options.

3. Click Change File Type under the File Types category.
A list of different formats appears, as shown in Figure 1-6.

4. Click the 97-2003 format option, such as Word 97-2003 Document or
Excel 97-2003 Workbook.

The Save As dialog box appears.

If you want to share your file with different types of programs, you may
need to choose a different file format, such as Rich Text Format or Text.

17



18

Part I: Getting to Know Microsoft Office 2010

Xl d Dokl - Microsoft Excel = B
Home  Bet  Pagelayuul  Formulas Viewe %)
W sre Save & Send Change File Type -]
B save s
G open 9 Serd Using E-rsil Workbook File Types
¥] % Workhaak
I Clase '—_].:.._:—,_ Forms
o Save to Web
Inta v .
[ Excel 972003 Workbook
S i SharePaint _-I e Encel $1-2003 Spreadsiree
Recerl #
. il Types ( Openocument Sprssdabist
e &l changeFie Type - ¢
- <~ ik
] Create PDF/XPS Document
== (15 Macre-Ensbled Workbeost
I Help Lj ensbisd spreadshest
Fiqure 1-6: E37Pemo0 [&] ™ Bimary Warkbo
The Change
. Other File Types
File Type Tet (Tab delimited)
lets you 0 84 o i
choose from
. (&] ™ Farmatred Test (Space delimited)
common file | Eaimsiiiatinatl
formats. 5‘_{ Saue a3 nother File Type ‘
T,
Closing a file

5. (Optional) Click in the File Name text box and type a descriptive name

for your file.
6. Click Save.

When you’re done editing a file, you need to close it. Closing a file simply
removes the file from your screen but keeps your Office 2010 program run-
ning so you can edit or open another file. If you haven’t saved your file, clos-

ing a file will prompt you to save your changes.
To close a file, follow these steps:

1. Click the File tab.
The Backstage View appears.
2. Click Close.

If you haven’t saved your file, a dialog box appears asking whether you
want to save your changes.

<\® For a faster way to choose the Close command, press Ctrl+F4.

3. Click Yes to save your changes, No to discard any changes, or Cancel
to keep your file open.

If you click either Yes or No, Office 2010 closes your file.
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Using the Quick Access Toolbar
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The Quick Access toolbar appears in the upper-left corner of the screen, dis-
playing icons that represent commonly used commands such as Save, Undo,
and Redo, as shown in Figure 1-7.

Quick Access toolbar

hage Hfect s | b Select =

Using the Quick Access icons

If you click the Save icon in the Quick Access toolbar, Office 2010 saves your
current file. If you're saving a new file, a dialog box pops up, asking you to
choose a name for your file.

The Redo icon reverses the last Undo command you chose. For example, if
you delete a paragraph, Office 2010 makes that paragraph disappear. Then

if you immediately click the Undo icon, the paragraph magically reappears. If
you immediately click the Redo icon, the Redo command reverses the Undo
command and deletes the paragraph once more.

The Undo icon is unique in that it offers two ways to use it. First, you can
click the Undo icon to undo the last action you chose. Second, you can click
the downward-pointing arrow that appears to the right of the Undo icon to
display a list of one or more of your previous actions, as shown in Figure 1-8.

19
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The most recent action you chose appears at the top of this list, the second
most recent action appears second, and so on. To undo multiple commands,
follow these steps:

1. Click the downward-pointing arrow that appears to the right of the
Undo icon in the Quick Access toolbar.

2. Move the mouse pointer to highlight one or more actions you want to
undo.

3. Click the left mouse button.

Office 2010 undoes all the multiple actions you selected.

Adding icons

The Quick Access toolbar is designed to put your most commonly used com-
mands (such as the Save, Undo, and Redo commands) where you can find
them quickly. To add other icons to the Quick Access toolbar, follow these
steps:

1. Click the Customize Quick Access Toolbar arrow.

A pull-down menu appears, as shown in Figure 1-9.

Custamire Quick Access Toolbat

|
Figure 1-9: |, ...
The R
Customize
Quick
Access
Toolbar
menu. e Comsms
I ih Eelow the Fibion

\\J
You can add an icon to the toolbar by clicking on an icon name, such as
Quick Print or New, from the pull-down menu.
2. Click More Commands.

An Options window appears, as shown in Figure 1-10. The panel on the
right shows all the current icons on the Quick Access toolbar. The panel
on the left shows all the additional icons you can add.



Figure 1-10:
The Options
window lets
you select
the icons
you want

to add to
the Quick
Access
toolbar.
|

Chapter 1: Introducing Microsoft Office 2010

Excel Optinns
Generl
Fommules
Praating
Save
langunge
Advaniced

Customize Ribbon

Add.Tns

Trust Center

Quick Aeress Tonlnar

Fa| Customize the Quick Access Toolbar.

Shoase commands from;
Fapular Cammands (]

<5eparators
Barders

Cabuulate Nuw

Center

Canditional Farmatting

Cunnedion:

Copy

Create Chart

Custom Sork..,

cut

Catasheet Farmatting

Dewrease Fonit Size

Gelete Cells..

Delene Sneet Columng

Delete Sheet Rows

Eomail

Fill Cotor

Fitter

Famt I-

Font Color

Pt YRS~ kxEPcEEND

-

font size L=
F Enmat Painker

Freeze Pane:

26 Fant Size

S Quick Acress Toalnar belous the
Ribban

==

Customize Qubck Access Toolbar:
For all dooumerits (default) L=l

[ e
“1 unon
0 Redo

adir |

Custemmatians: | Bgtet

| imgonitpont =

oK Cancel |

3. Click in the Choose Commands From list box and choose a title, such
as Home Tab or Insert Tab.

The left panel displays a list of icons and commands.

4. Click an icon and then click the Add button.

5. (Optional) Repeat Steps 3 and 4 for each additional icon you want to
add to the Quick Access toolbar.

6. Click OK.

Your chosen icon (or icons) now appears on the Quick Access toolbar.

Removing icons

You can remove icons from the Quick Access toolbar at any time. To remove
an icon, follow these steps:

1. Right-click an icon on the Quick Access toolbar.

A pull-down menu appears.

2. Click Remove from Quick Access Toolbar.

Office 2010 removes your selected icon from the Quick Access toolbar.
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Moving the Quick Access toolbar

The Quick Access toolbar can appear in one of two places:

v Above the Ribbon (its default location)
v Below the Ribbon

To move the Quick Access toolbar, follow these steps:

1. Click the Customize Quick Access Toolbar arrow.
A pull-down menu appears.
2. Choose Place Quick Access Toolbar Below (or Above) the Ribbon.

If the Quick Access toolbar currently appears over the Ribbon, you’ll see
the Place Quick Access Toolbar Below the Ribbon command.

If the Quick Access toolbar appears under the Ribbon, you'll see the
Place Quick Access Toolbar Above the Ribbon command.

Using the Ribbon

With Office 2007, Microsoft abandoned the traditional pull-down menu bars
and replaced them with the Ribbon, which organizes commands into catego-
ries called contextual tabs. Office 2010 uses the same Ribbon interface but
with a slightly different look. If you're already familiar with Office 2007, you’ll
have no trouble learning Office 2010. If you've never used Office 2007, take
some time to get acquainted with the Ribbon interface. At first it might seem
strange, but over time, you’ll see how handy it can be.

Each tab displays a different group of commands. For example, the Page
Layout tab displays only those commands related to designing a page, and
the Insert tab displays only those commands related to inserting items into
a file, such as a page break or a picture, as shown in Figure 1-11. The Ribbon
usually shows the Home tab when you start.

Using the Ribbon is a two-step process. First, you must click the tab that con-
tains the command you want. Second, you click the actual command.

Tabs act exactly like traditional pull-down menus. Whereas a pull-down menu
simply displays a list of commands, tabs display a list of icons that represent
different commands.
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Deciphering Ribbon icons

Each Ribbon tab displays commands as buttons or icons, organized into
groups. There are four types of icons displayed on the Ribbon:

v One-click icons: These icons do something with a single click.

v Menu icons: These icons display a pull-down menu of options you can
choose.

1 Splitmenu icons: These icons consist of two halves. One half lets you
choose a command like a one-click icon, and the second half displays a
downward-pointing arrow, which displays additional options.

v Combo boxes: These display a text box where you can type a value in or
click on a downward-pointing arrow to choose from a menu of options.

Using one-click icons

One-click icons simply display an icon, or an icon with text. To use a one-
click icon, you select the data you want to manipulate, such as a paragraph
or a picture, and then click the icon. Figure 1-12 shows one-click icons that
display only an icon or both text and an icon.

The most common one-click icons are the Cut and Copy commands, which
appear on the Home tab of every Office 2010 program.

Using menu icons

A one-click icon represents a single command. However, there isn’t enough
room on the Ribbon to display every possible command as a single icon. As
a result, menu icons display a pull-down menu that stores multiple options

within a single icon, as shown in Figure 1-13.
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Using split-menu icons
Split-menu icons give you two choices:

v If you click the top or left half of a split-menu icon, you choose a default
value. For example, the left half of the Font Color icon lets you choose
the currently displayed color.

v If you click the bottom or right half of a split-menu icon, a pull-down
menu appears, letting you choose a new default option, as shown in
Figure 1-14.
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The Paste and Font Color icons, found on the Home tab of Word, Excel, and

e \\BER PowerPoint, are typical split-menu icons.
Y
&

You can identify split-menu icons because only half of the icon appears high-
lighted when you move the mouse pointer over that half.

Using combo boxes
A combo box gives you two ways to choose an option:

v Type directly into the combo box.

v Click the downward-pointing arrow to display a list of options, as shown
in Figure 1-15.

Figure 1-15:
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PowerPoint.
|

The Font and Font Size combo boxes, found on the Home tab of Word, Excel
and PowerPoint, are typical combo boxes:

v If you click the left side of the Font Size combo box, you can type your
own value in for a font size.

v If you click the downward-pointing arrow on the right side of the Font
Size combo box, you can choose a value from a pull-down menu.

Identifying Ribbon icons

While some icons include descriptive text (such as Format Painter or Paste),
most icons simply look like cryptic symbols from an alien language. To

get additional help deciphering icons on the Ribbon, just point the mouse
pointer over an icon and a short explanation appears, called a ScreenTip, as
shown in Figure 1-16.
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ScreenTips provide the following information:

v The official name of the command (which is Format Painter in Figure 1-16)

v The equivalent keystroke shortcut you can use to run the command
(which is Ctrl+Shift+C in the figure)

v A short explanation of what the command does

Farmal Painbes (Chil« Shifl £}

Q) Press il fon e el

To view the ScreenTip for any icon on the Ribbon, move the mouse pointer
over that icon and wait a few seconds for the ScreenTip to appear.

Shortcut keystrokes let you choose a command from the keyboard without
the hassle of clicking a tab and then clicking the icon buried inside that tab.
Most shortcut keystrokes consist of two or three keys, such as Ctrl+P or
Ctrl+Shift+C.

Displaying dialog boxes

On each tab, the Ribbon displays related commands in a group. For exam-
ple, the Home tab groups the Cut, Copy, and Paste commands within the
Clipboard group and the text alignment and line spacing commands within
the Paragraph group.

Although you can choose the most commonly used commands directly from
the Ribbon, Word often contains dozens of additional commands that don’t
appear on the Ribbon. To access these more obscure commands, you need
to open a dialog box.

In the bottom-right corner of a group of icons on the Ribbon, you’ll see the
Show Dialog Box icon, which looks like an arrow pointing diagonally down-
ward, as shown in Figure 1-17.

Not every group of icons on the Ribbon displays the Show Dialog Box icon.
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To open a dialog box that contains additional options, follow these steps:

1. Click on a tab on the Ribbon, such as the Home or Page Layout tab.

2. Click on the Show Dialog Box icon in the bottom-right corner of a
group such as the Font or Paragraph group found on the Home tab.

Office 2010 displays a dialog box, as shown in Figure 1-18.

3. Choose any options in the dialog box, and then click OK or Cancel
when you’re done.
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Using Live Preview

With earlier versions of Office, you had to select data and then choose a com-
mand without knowing exactly how that command would affect the appear-
ance of your data. If you didn’t like the way a command changed your data,
you had to choose the Undo command and start all over again.

To avoid this hassle of constant experimentation with different commands,
Office 2010 offers a feature called Live Preview. Live Preview lets you move
the mouse pointer over certain icons displayed in the Ribbon and then imme-
diately see the changes displayed in your current file.

v If you like the way your data looks, go ahead and choose the command.

v If you don’t like the way the data looks, just move the mouse away. Your
data returns to its original appearance without forcing you to choose
the Undo command.

To use Live Preview, follow these steps:
1. Move the cursor (or click the mouse) on an object (text, picture, table,
and so on) that you want to change.

2. Move the mouse pointer over any command.

Office 2010 shows you how your chosen object will look if you choose
the command, as shown in Figure 1-19.

3. Choose the command to change your object (or move the mouse
pointer away from the command so you don’t choose that command).

In Word, Live Preview will not work if you display your document in Draft
view.

Minimizing the Ribbon

Some people like the Ribbon displaying various icons at all times, but others
find that it makes the screen appear too cluttered. In case you want to tuck
the Ribbon out of sight (or display a Ribbon that is already tucked out of
sight) so icons only appear when you click on a tab, choose one of the follow-
ing methods as shown in Figure 1-20:

v Double-click on the current tab.
v Press Ctrl+F1.

v Click the Minimize Ribbon icon that appears on the far right next to the
Help (Question Mark) icon.
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To make the icons temporarily appear, click once on any tab. The moment
you click away from the Ribbon, the Ribbon will hide its icons again.

Customizing an Office 2010 Program

If you don’t like the default settings of your favorite Office 2010 program,
you can modify them. Some common ways to modify an Office 2010 program
include

v Changing the file format and location to save files

v Customizing the icons that appear on the Ribbon
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Figure 1-21:
The Options
dialog box
lets you
choose a
default file
format and
location.
|

Changing the file format and
default location

Every Office 2010 program is designed to share files easily with anyone who
uses Office 2010 or 2007. However, if you need to share files with people who
use earlier versions of Office or other programs altogether, you may need to
save your files in a different format.

To choose a default file format that each Office 2010 program will use every
time you choose the Save command, follow these steps:
1. Load an Office 2010 program.
2. Click the File tab.
The Backstage View appears.
3. Click the Options button in the left pane.
An Options dialog box appears.
4. Click Save.

The Options dialog box displays multiple options for defining a default
file format and file location, as shown in Figure 1-21.
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5. Choose a different file format and location.

6. Click OK when you’re done choosing different options.

Customizing the Ribbon icons

If you don’t use certain Ribbon icons, you can remove them and replace them
with icons that represent the commands you do use most often. To custom-
ize the Ribbon icons, follow these steps:
1. Load an Office 2010 program.
2. Click the File tab.
The Backstage View appears.
3. Click the Options button in the left pane.
An Options dialog box appears.
4. Click Customize Ribbon.

The Options dialog box displays multiple options for you to customize,
as shown in Figure 1-22.
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5. Click on different icons and click the Add or Remove buttons.

6. Click OK when you’re done choosing different options.

Exiting Office 2010

No matter how much you may love using Office 2010, eventually there will
come a time when you need to exit an Office 2010 program and do something
else with your life. To exit from any Office 2010 program, choose one of the
following:

v Click the Close box in the upper-right corner of the Office 2007 window.
v Click the File tab, and then click Exit.
v Press Alt+F4.

@“Q’ If you try to close an Office 2010 program before saving your file, a dialog

box pops up to give you a chance to save your file. If you don’t save your file
before exiting, you'll lose any changes you made to that file.
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Selecting and Editing Data

In This Chapter
Selecting data

Using the pop-up toolbar

Copying, cutting, and pasting

Copying and cutting with the mouse
Sharing data within Office 2010
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A Ithough you create a file only once, you can edit it many times. Editing
can add, rearrange, or delete data, such as text, numbers, or pictures.
All Office 2010 programs work in similar ways to edit data, so whether you
use Word, Excel, PowerPoint, or Access, you'll know the right commands to
edit data no matter which program you may be using.

Whenever you edit a file, save your file periodically by clicking the Save icon
in the Quick Access toolbar, pressing Ctrl+S, or clicking the File tab and choos-
ing Save. That way if your computer crashes or the power goes out, you won’t
lose all the editing changes you made.

Adding Data by Pointing

When you enter data into a file, your data appears wherever the cursor
appears on the screen. The cursor appears as a blinking vertical bar, which
basically says, “Anything you type now will appear right here!”

Because the cursor won’t always magically appear exactly where you want
to type data, you must move the cursor by using either the mouse or the key-
board. To move the cursor by using the mouse, follow these steps:

1. Move the mouse pointer where you want to move the cursor.

2. Click the left mouse button.

The cursor appears where you click the mouse pointer.
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To move the cursor by using the keyboard, you can use one of many cursor
movement keys:

v The (up/down/left/right) arrow keys
v The Home/End keys
v The Page Up/Page Down keys

Use the up/down/right/left arrow keys when you want to move the cursor
a small distance, such as up one line or right to the next cell in an Excel
spreadsheet.

To move the cursor faster, hold down the Ctrl key and then press the arrow
keys. If you hold down the Ctrl key, the up-arrow key moves the cursor up one
paragraph, the down-arrow key moves the cursor down one paragraph, the
left-arrow key moves the cursor left one word, and the right-arrow key moves
the cursor right one word.

Pressing the Home key moves the cursor to the beginning of a sentence (or a
row in a spreadsheet), and pressing the End key moves the cursor to the end
of a sentence (or a row in a spreadsheet).

Pressing the Page Up/Page Down keys moves the cursor up or down one
screen at a time.

Using any of the cursor movement keys moves the cursor to a new location.
Wherever the cursor appears will be where you can enter new data. Table 2-1
lists ways to move the cursor in each Office 2010 program.

Table 2-1 Moving the Cursor in Office 2010 Programs
Keystroke Word Excel PowerPoint Access
Home Beginning  Column A of Displays first slide;  First field of
ofthe line  the current beginning of the the current
row that the line (whentextbox  record
cursor appears is selected)
in; (Ctrl+Home
moves to
cell A1)
End End ofthe  NA; (Ctrl+End Displays last slide; Add New Field
line moves to last end of the line of current
cell) (when text box is record
selected)
Page Up Half a Up 27 rows Displays preceding  Up 25 records

page up slide
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Keystroke Word Excel PowerPoint Access
Page Half a Down 27 rows Displays nextslide ~ Down 25
Down page records
down
Up/Down Up/down Up/down one Next/previous Up/down one
arrow one line row slide; up/down one  record
line (when text box
is selected)
Left/Right Left/right Left/right one Next/preceding Left/right one
arrow one char- column slide; left/right field
acter one character
(when text box is
selected)

Selecting Data

MBER
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To modify data, you must tell Office 2010 what you want to change by select-
ing it. Then choose a command that changes your data, such as underlining
text or deleting a picture.

To select anything in Office 2010, you can use either the mouse or the key-
board. Generally, the mouse is faster but takes some time getting used to
coordinating the motion of the mouse with the movement of the mouse
pointer on the screen. The keyboard is slower but much simpler to use.

Selecting data with the mouse

The mouse provides two ways to select data. The first way involves pointing
and dragging the mouse, as shown in Figure 2-1.

1. Point the mouse pointer at the beginning or end of the data you want
to select.

2. Hold down the left mouse button and drag (move) the mouse pointer
over the data to select it.

When you drag the mouse, hold down the left mouse button. If you don’t hold
down the left mouse button as you move the mouse, you won’t select any data
when you move the mouse pointer across the screen.
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You can also select data by clicking the mouse. To select a picture, such as
a chart in Microsoft Excel or a photograph added to a Microsoft Word docu-
ment, just click the picture to select it. Office 2010 displays rectangles, called
handles, around the border of any selected picture, as shown in Figure 2-2.

To select text with the mouse, you can click the mouse in one of three ways:

v Single-click: Moves the cursor
+* Double-click: Selects the word that you click

v~ Triple-click: Selects the entire paragraph that contains the word you
click
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Figure 2-2:
To selecta
picture, just

click it once.

Office 2010 defines a paragraph as any chunk of text that begins on a separate
line and ends with a Return character (), created by pressing the Enter key.

Selecting data with the keyboard

To select data with the keyboard, you need to use the following keys:
v The cursor movement keys (up/down/left/right arrow keys, Home/End
keys, or Page Up/Page Down keys)
3 v~ The Shift key

To select all the data in a file, press Ctrl+A.

The cursor movement keys simply move the cursor. When moving the
cursor, you can also hold down the Shift key to tell Office 2010 what to select.
To select data, follow these steps:

1. Move the cursor to the beginning or end of the data you want to
select.
2. Hold down the Shift key. (Keep it pressed down.)

3. Move the cursor by using any of the cursor movement keys,
such as the up-arrow key or the End key.

4. Release the Shift key.
You may find it easier to place the cursor with the mouse and then hold down

the Shift key while pressing a cursor movement key to select data more pre-
cisely than you can by dragging the mouse.
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Selecting multiple chunks of data
with the mouse and keyboard

For greater flexibility in selecting data, you can use both the mouse and the
keyboard to select multiple chunks of data at the same time. To select two or
more chunks of data, follow these steps:

1. Select a picture or chunk of text, using either the keyboard or the
mouse.
2. Hold down the Ctrl key.

3. Select another picture or chunk of text, using either the keyboard or
the mouse.

4. Repeat Step 3 for each additional item you want to select.

5. Release the Ctrl key when you’re done selecting data.

Editing Text with the Pop-up Toolbar

MBER
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As soon as you select text with the mouse, Office 2010 displays a pop-up tool-
bar that displays the most commonly used commands (displayed as icons).
This pop-up toolbar appears to the upper right of the text you selected as a
faint image. The closer you move the mouse toward this pop-up toolbar, the
darker and sharper the toolbar appears, as shown in Figure 2-3. The farther
you move away from the toolbar, the fainter it appears.

The pop-up toolbar appears only if you select text by using the mouse. If you
select text by using the keyboard, this pop-up toolbar will not appear.

To use this pop-up toolbar, follow these steps:

1. Select data by using the mouse.
Selecting data with the keyboard will not display the pop-up toolbar.

2. Move the mouse pointer to the area to the upper right of the selected
data.

The pop-up toolbar appears.

The closer you move the mouse to the toolbar, the more visible the tool-
bar will appear.

3. Click a command (icon) on the pop-up toolbar.
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Deleting Data

The simplest way to edit a file is to delete your existing data. If you just need
to delete a single character, you can use one of two keys:
v~ Backspace: Deletes the character immediately to the left of the cursor

v Delete: Deletes the character immediately to the right of the cursor
If you need to delete large chunks of text, follow these steps:
1. Select the data you want to delete, using either the keyboard or the
mouse. (See the earlier section, “Selecting Data.”)

2. Press the Delete (or Backspace) key.
Office 2010 wipes away your data.

Cutting and Pasting (Moving) Data

Moving data in Office 2010 requires a two-step process: cut and paste. When
you cut data, you delete it but save a copy in a special area of the computer’s
memory known as the Clipboard. When you paste data to a new location, you
copy the data off the Clipboard and paste it in your file, as shown in Figure 2-4.

39
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To move data, follow these steps:
1. Select the data you want to move, using the keyboard or mouse as
explained in the earlier section, “Selecting Data.”
2. Choose one of the following:
e Click the Cut icon (from the Home tab).
¢ Right-click the mouse; when the pop-up menu appears, choose Cut.
¢ Press Ctrl+X.

3. Move the cursor to a new location.
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4. Choose one of the following:
¢ Click the Paste icon (from the Home tab).

¢ Right-click the mouse; when the pop-up menu appears, choose
Paste.

¢ Press Ctrl+V.
\\J

If you select data in Step 3, you can replace that selected data with the pasted
data you selected in Step 1.

Copying and Pasting Data

Unlike the Cut command, the Copy command leaves your selected data in its
original location but places a second copy of that data somewhere else. To
copy and paste data, follow these steps:

1. Select the data you want to copy, using the keyboard or mouse, as
explained in the earlier section, “Selecting Data.”
2. Choose one of the following:
e Click the Copy icon.

¢ Right-click the mouse; when the pop-up menu appears, choose
Copy.

¢ Press Ctrl+C.
3. Move the cursor to a new location.
4. Choose one of the following:

¢ Click the Paste icon.

¢ Right-click the mouse; when the pop-up menu appears, choose
Paste.

¢ Press Ctrl+V.

Using Paste Options

Cutting, copying, and pasting text from one location to another is easy.
However, a problem can occur when you paste formatted text from one loca-
tion to another. When you paste formatted text, you have several choices,
depending on the Office 2010 program you're using. Three common choices
include:
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v Paste the text with the original formatting of the copied or cut text.
v Merge the pasted data with the formatting of the current text.
é&N\BEﬂ v Paste the text but strip away the formatting.
&
&

Each Office 2010 program displays slightly different options for Paste Options.
To use the Paste Options feature, follow these steps:

1. Select text.

You can select text by either dragging the mouse over text or holding
down the Shift key and pressing an arrow key.

2. Click the Home tab and click the Cut or Copy icon.
If you select the Cut icon, your selected text disappears.
3. Move the cursor to where you want to paste your cut or copied text.

4. Click the Home tab, and then click the downward-pointing arrow at
the bottom of the Paste icon.

The Paste Options menu appears, displaying the different Paste Option
options, as shown in Figure 2-5.

|
Figure 2-5:
The Paste
Options
menu
appears |™*
when you
click the
bottom half
of the Paste
icon.
|

5. Move the mouse pointer over each Paste Options icon to see how your
pasted text will look in the file.

Each time you move the mouse pointer over a different Paste Option
icon, the appearance of the pasted text will change.

* 6. Click the Paste Options icon that you want to use.
;\

If you right-click in Step 3, a pop-up menu appears with the Paste Options dis-
played, as shown in Figure 2-6.
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Dragging with the Mouse to
Cut, Copy, and Paste

The mouse can also cut/copy and paste data. To move data with the mouse,
follow these steps:

1.

Select the data you want to move by using the methods described in
the earlier section, “Selecting Data.”

2. Move the mouse pointer over the highlighted data.

. Hold down the left mouse button and drag (move) the mouse.

The mouse pointer displays an arrow and a box while the cursor turns
into a dotted vertical line.

Alternatively, to copy data, hold down the Ctrl key while holding down
the left mouse button and dragging (moving) the mouse. The mouse
pointer displays an arrow and a box with a plus sign while the cursor
turns into a dotted vertical line.

. Move the dotted vertical line cursor where you want to place the data

you selected in Step 1.

. Release the left mouse button.

Your data appears in its new location.

Undo and Redo

To protect you from mistakes, Office 2010 offers a special Undo command,
which essentially tells the computer, “Remember that last command I just
gave? Pretend I never chose it.”

43
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You can use the Undo command any time you edit data and want to reverse
your changes. The two ways to choose the Undo command are

+” Click the Undo icon on the Quick Access toolbar (see Figure 2-7).
v Press Ctrl+Z.

Sometimes you may make many changes to your file and suddenly realize
that the last five or ten changes you made messed up your data by mistake.
To undo multiple commands, follow these steps:

1. Click the downward-pointing arrow that appears to the right of the
Undo icon.

A list of your previously chosen commands appears.

2. Move the mouse pointer to highlight all the commands that you want
to undo, as shown in Figure 2-7.

|
Figure 2-7:
The
downward-
pointing
arrow to the
right of the
Undoicon
lets you
view a list
of your last
commands.

3. Click the left mouse button.

Office 2010 undoes your chosen commands.

Until you choose the Undo command at least once, the Redo icon appears
dimmed. The Redo command lets you reapply the last command you chose
to undo. The two ways to choose the Redo command are

+ Click the Redo icon (refer to Figure 2-7).
» Press Ctrl+Y.

WMBER
‘3“" Each time you choose the Redo command, you reverse the effect of the last
Undo command. For example, if you use the Undo command four times, you

can choose the Redo command only up to four times.
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Sharing Data with Other
Office 2010 Programs

Cutting, copying, and pasting data may be handy within the same file, but
Office 2010 also gives you the ability to cut, copy, and paste data between
different programs, such as copying a chart from Excel and pasting it into a
PowerPoint presentation.

Using the Office Clipboard

When you cut or copy any data, Windows stores it in a special part of
memory called the Clipboard. This Windows Clipboard can only hold one
item at a time, so Office 2010 comes with its own Clipboard called the Office
Clipboard, which can store up to 24 items.

Whereas the Windows Clipboard works with any Windows program (such
as Microsoft Paint or Internet Explorer), the Office Clipboard works only
with Office 2010 programs (such as Word, Excel, PowerPoint, Access, and
Outlook). To store data on the Office Clipboard, you just need to use the Cut
or Copy command, and Office 2010 automatically stores your data on the
Office Clipboard.

The two big advantages of the Office Clipboard are

+ You can store up to 24 items.
The Windows Clipboard can store only one item.
+* You can select what you want to paste from the Clipboard.

The Windows Clipboard lets you paste only the last item cut or copied.

Viewing and pasting items
off the Office Clipboard

After you use the Cut or Copy command at least once, your data gets stored
on the Office Clipboard. You can then view the Office Clipboard and choose
which data you want to paste from the Clipboard into your file.

To view the Office Clipboard and paste items from it, follow these steps:

1. Move the cursor to the spot where you want to paste an item from the
Office Clipboard.

2. Click the Home tab.
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|
Figure 2-8:
The Office
Clipboard
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you view
the current
contents of
the Office
Clipboard.
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3. Click the Show Dialog Box icon in the bottom-right corner of the
Clipboard group.

The Office Clipboard pane appears on the left side of the screen, as
shown in Figure 2-8. The Office Clipboard also displays an icon that
shows you the program where the data came from, such as Word or
PowerPoint.
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4. Click the item you want to paste.

Office 2010 pastes your chosen item into the file where you moved the
cursor in Step 1.

5. Click the Close box of the Office Clipboard window to tuck it out of sight.

If you click the Paste All button, you can paste every item on the Office
Clipboard into your file.

Deleting items from the Office Clipboard

You can add up to 24 items to the Office Clipboard. The moment you add a
25th item, Office 2010 deletes the oldest item from the Office Clipboard to
make room for the new cut or copied item.

You can also manually delete items from the Office Clipboard as well, by
following these steps:
1. Click the Home tab.

2. Click the Show Dialog Box icon in the bottom-right corner of the
Clipboard group.

The Office Clipboard appears.
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3. Move the mouse pointer over an item on the Office Clipboard.
A downward-pointing arrow appears to the right.
4. Click the downward-pointing arrow to the right of an item.

A pop-up menu appears, as shown in Figure 2-9.

5. Click Delete.
Office 2010 deletes your chosen item.

6. Click the Close box to tuck the Office Clipboard out of sight.

If you click the Clear All button, you can delete every item currently stored on
the Office Clipboard.

Make sure that you really want to delete an item from the Office Clipboard
because after you delete it, you can'’t retrieve it.

b7
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Chapter 3
Modifying Pictures

In This Chapter
Adding (and deleting) pictures
Modifying pictures
Altering the appearance of pictures

One way to spice up your Word documents, Excel spreadsheets, or
PowerPoint presentations is to add photographs that you've captured
through a digital camera. Adding photographs is simple enough, but Office
2010 also includes different ways to manipulate your picture by using special
visual effects.

One common problem with photographs is that they may appear too light or
too dark. In the past, the only way to correct these types of problems was to
edit the picture in a photo-editing program like Adobe Photoshop. Because
not many people have Photoshop or know how to use it, Office 2010 now con-
tains simple photo-editing tools that anyone can use to correct minor flaws.

After you've corrected any flaws, Office 2010 also lets you turn your photo-
graphs into art by adding frames, tilting the picture sideways, or adding a
visual effect that makes the picture look more like a painting.

With Office 2010, you can add photographs, correct them, and modify them

to give all your Word, Excel, or PowerPoint files that extra bit of color and
showmanship.

Adding (And Deleting) Pictures

To add a picture to a file, follow these steps:

1. Click the Insert tab.
2. Click the Picture icon.

The Insert Picture dialog box appears.
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3. Select the picture file you want to insert.

You may need to select a different folder or drive that contains the pic-
ture you want to insert.

4. Click the Insert button.
¢ In Word, your picture appears wherever the cursor appears.

¢ In Excel, the upper-left corner of your picture appears in the cell
where the cursor appears.

¢ In PowerPoint, your picture appears in the center of the currently
displayed slide.

To delete a picture in a file, follow these steps:

1. Select the picture that you want to delete.
Handles appear around your selected picture.

2. Press the Delete or Backspace key.

Manipulating Pictures

After you add a picture to a file, it may not be in the correct position or be
the right size. As a result, you may want to move, resize, or rotate it.

Moving a picture
To move a picture, follow these steps:

1. Select the picture that you want to move.
Handles appear around your selected picture, as shown in Figure 3-1.
2. Move the picture, using one of the following methods:
¢ Move the mouse pointer over the picture and drag the mouse.

¢ Press the up/down or left/right arrow keys.



Chapter 3: Modifying Pictures 5 1

|
Figure 3-1:
Handles
appear

to show
that you
selected a
picture.
|

\\J

Resizing a picture
To resize a picture, follow these steps:

1. Select the picture that you want to move.
Handles appear around your selected picture.
2. Move the mouse pointer over a handle and drag the mouse.

If you drag a corner handle, you can change the height and width of a picture
at the same time.

If you click the Format tab, you can type a precise width and height for your
picture in the Height and Width text box displayed in the Size group.

Rotating a picture

To create an interesting effect, you may want to rotate a picture in a file. To
rotate a picture, follow these steps:
1. Select the picture that you want to rotate.

Handles appear around your selected picture. Note that the rotate han-
dles appear separate from the resizing handles.

2. Move the mouse pointer over the rotate handle and drag the mouse.

The mouse pointer turns into a circular arrow icon when you move it
over the rotate handle.
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Enhancing Pictures

Sometimes a picture might look almost perfect, but needs some minor cor-
rections. Other times a picture might look plain, but by adding some visual
effects, you can turn a plain picture into a work of art.

To help you make your pictures look prettier and more visually engaging,
Office 2010 lets you choose different effects, colors, frames, and styles.

Choosing visual effects

Office 2010 offers several different ways to alter a picture’s visual appearance:
v Corrections: Sharpens or softens a picture, or adjusts the brightness or
contrast

v Color: Adjusts the tone or saturation of a picture’s color, or lets you
change the color of a picture altogether

v~ Artistic Effects: Makes a picture appear as different styles, such as a
mosaic or watercolor painting

v+~ Picture Effects: Lets you add visual effects to a picture, such as shad-
ows, glows, or rotation

To choose a visual effect for a picture, follow these steps:

1. Select the picture that you want to modify.
The Format tab appears on the Ribbon.
2. Click the Corrections icon.

When you click the Corrections icon, a menu of different correction
options appears, as shown in Figure 3-2.
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3. Select a Corrections option from the menu.
4. Click the Color icon.

A menu of different color options appears, as shown in Figure 3-3.
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5. Select a Color option from the menu.
6. Click the Artistic Effects icon.

A menu of different visual effects options appears, as shown in Figure 3-4.
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7. Select an Artistic Effects option from the menu.
8. Click the Picture Effects icon.

A menu of different color options appears. You may need to click on a
submenu to display additional options, as shown in Figure 3-5.

9. Click on a Picture Effects submenu, and then select an option.
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Choosing a picture style

Rather than force you to make individual changes to a picture, Office 2010
provides a collection of predefined picture styles that you can apply to any
picture added to a file. To choose a picture style, follow these steps:

1. Select the picture that you want to modify.

The Format tab appears on the Ribbon.

M 2. Click on a style displayed in the Picture Styles group.
The Picture Styles group contains multiple options:
¢ To view these options one row at a time, click the up/down arrows
in the Picture Styles group, as shown in Figure 3-6.
e To view all picture styles at once, click the More button, which dis-
plays all picture styles, as shown in Figure 3-7.
|
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Adding a border around a picture

To help make your picture stand out, you may want to add a border. A
border can appear in different colors, thicknesses, and styles (such as a solid
line or a dotted line).

To add or modify a border around a picture, follow these steps:

1. Select the picture that you want to modify.
The Format tab appears on the Ribbon.
2. Click the Picture Border icon.

A pull-down menu of different colors and options appears, as shown in
Figure 3-8.
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3. Choose a color that you want for your border.

4. Click on the Weight submenu and choose a weight (thickness), as
shown in Figure 3-9.
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5. Click on the Dashes submenu and choose the type of line to use as the
border, as shown in Figure 3-10.
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Chapter 4

Getting Help from Office 2010

In This Chapter

Opening and browsing the Help window

Searching the Help window

Changing the appearance of the Help window

Microsoft did its best to make Office 2010 the easiest version of Office
ever. No matter much or how little you may know about Office, you
may still have a question about using the features buried in one of the many
Office programs.

To answer any questions, Office 2010 provides a Help system, which lets you
browse through different help topics until you (hopefully) find the answer
you need. There are two ways to use the Help system. One, you can browse
through the various topics displayed until you find the answer you want. This
can take time to search but can also show you related help that you might
find useful.

A second way to use the Help system is to type a query such as Page mar-
gins or Font size. The Help system will then display all topics related to your
query. This can be a fast way to search for help, but if you don’t type the
right terms that the Help system recognizes, this method may not find the
exact help you need.

To view the latest help information about Office 2010, make sure that your
computer is connected to the Internet.
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Browsing the Help Window

Each Office 2010 program comes with its own help files that you can access
at any time. To browse through the Help system, follow these steps:

1. Choose one of the following to display the Help window, as shown in
Figure 4-1:
e Click the Help icon.
¢ Press F1.
2. Click a topic.
The Help window displays a list of Help topics as shown in Figure 4-2.
3. Click a Help topic.

The Help window displays information about your chosen topic. You
may need to click on multiple Help topics until you get the answer that
you want.

4. Click the Close box when you’re done, to make the Help window go away.
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If you click the Back icon, you can view the previous text displayed in the Help
window. If you click the Forward icon (after clicking the Back icon at least
once), you can return forward to the text that you were looking at before you
clicked the Back icon. If you click the Home icon, you can view the Help win-
dow’s list of topics that appear every time you open the Help window.

Searching in the Help Window

MBER
@&
&

Rather than browse through one or more subcategories to find help, you may
want to search for help by typing in one or more keywords. Such keywords
can identify a specific topic, such as Printing or Editing charts.

If you misspell a topic, the Help system may not understand what you want to
find, so check your spelling.

To search the Help window by typing in a keyword or two, follow these steps:
1. Choose one of the following methods to display the Help window
(refer to Figure 4-1):
e Click the Help icon.
¢ Press F1.

2. Click in the Search list box and type one or more keywords, such as
Formatting or Aligning text.
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Type as few words as possible. So rather than type “I want to find help
on printing,” just type “Printing.” Not only will this make it easier for you
to search for help, but it will also keep Office 2010 from looking up extra
words that have nothing to do with your topic such as “I want to find
help on...”

3. Click Search.

The Help window displays a list of topics, as shown in Figure 4-3.
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4. Click a Help topic.

The Help window displays information for your chosen topic. You may
need to click on additional topics to get the answer you want.

5. Click the Close box when you’re done, to make the Help window
go away.

Making the Help Window Easier to Read

One problem with the Help window is that it may appear too small to read
comfortably. To get around this problem, you have two choices:

v Resize the Help window.
v Expand the size of the text inside the Help window.
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Figure 4-4:
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Resizing the Help window

You can resize the Help window just like any other window by clicking one of
the following icons in the upper-right corner:
v Minimize: Shrinks the Help window to an icon on the Windows taskbar
v Maximize: Expands the Help window to fill the entire screen
* Restore Down: Shrinks a maximized window to a smaller window that

you can move and resize

You can also resize a window by moving the mouse pointer over one edge or

bottom corner, holding down the left mouse button, and dragging (moving)
the mouse.

Enlarging the text in the Help window

In addition to, or as an alternative to, resizing the Help window, you can
enlarge the text inside the Help window to make it larger (or smaller) so you
can read it easier or so you can cram more text within the limited confines
of the Help window. To change the size of the text inside the Help window,
follow these steps:

1. Click the Help icon or press F1 to open the Help window.
2. Click the Change Font Size icon.

A pull-down menu appears, as shown in Figure 4-4.
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3. Choose an option, such as Smaller or Largest.

The Help window text changes in size.

Keeping the Help window
vVisible at all times

When you open the Help window, Office 2010 keeps that window displayed
on the screen while letting you use the Office 2010 program underneath. That
way, you can read and follow the instructions in the Help window while using
your program at the same time.

If you turn the Keep on Top feature off, the Help window will appear; but the
moment you click in your Office 2010 program underneath, the Help window
disappears from sight.

To turn the Keep on Top feature on (or off), click the Keep on Top (or Not on
Top) icon in the Help window (refer to Figure 4-4).

Printing the text in the Help window

Sometimes you may find the step-by-step instructions in the Help window
so useful that you may want to reference them again. Rather than open the
Help window each time, you can print the step-by-step instructions so you’ll
always have them at your fingertips when you need them.

To print the text displayed in the Help window, follow these steps:

1. Click the Help icon or press F1 to open the Help window.
2. Make sure that your printer is connected to your computer and turned on.
3. Click the Print icon (refer to Figure 4-4).

The Print dialog box appears.

4. Choose any options in the Print dialog box (such as choosing a printer to
use), and then click OK to print the current contents of the Help window.

Viewing the Table of Contents

One problem with searching through the Help window is that you can easily
lose track of which subcategory or category led you to view the current con-
tents of the Help window. To avoid this confusion, you can expand the Help
window to display two panes. The left pane displays a table of contents while
the right pane displays additional information, as shown in Figure 4-5.
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To view the Table of Contents, follow these steps:

1. Click the Help icon or press F1 to open the Help window.
. Click the Show Table of Contents icon.

The Help window expands into two panes.

. Click a Help topic (which appears with a closed book icon in the left

margin).

A list of subcategories (closed book icon) or Help topics (question mark
icon) appears. You may need to click one or more additional subcat-
egory icons until you see a list of Help topics.

. Click a Help topic.

The right pane of the Help window displays step-by-step instructions.

. (Optional) Click the Hide Table of Contents icon.

If you leave the Table of Contents pane visible, the next time you open
the Help window, you'll see the table of contents in the left pane.

. Click the Close box to make the Help window go away.
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In this part . . .

A Imost everyone needs to use a word processor to
write a letter, jot down some notes from a meeting
or class, or create a report. Although this latest incarna-
tion of Word may look and feel familiar to anyone who has
used a word processor, you'll find that Word 2010 con-
tains dozens of useful features that this part of the book
will help you discover and use for your everyday life.

You'll learn simple tasks such as formatting text quickly
and checking your spelling and grammar. Then you’ll
learn about Word’s page design features for creating
headers and footers (to display page numbers or titles),
dividing a page into multiple columns, and using tables to
organize and display data.

You'll find that you can use Word as a simple word pro-
cessor or as a more complicated page layout program.
Whatever you want to create that involves words and pic-
tures, you’ll find that Word can help you turn your ideas
into a printed page faster and easier than ever.




Chapter 5
Typing Text in Word

In This Chapter

Moving the cursor with the mouse and keyboard
Viewing a document

Navigating through a document

Checking spelling and grammar

Typing unusual symbols

rle whole purpose of Microsoft Word is to let you type in text and make
it look pretty so you can print or send it for other people to read. So the
first step in using Microsoft Word is finding how to enter text in a Word file,
called a document.

In every document, Word displays a blinking cursor that points to where
your text will appear if you type anything. To move the cursor, you can use
the keyboard or the mouse.

Moving the Cursor with the Mouse

When you move the mouse, Word turns the mouse pointer into an I-beam
pointer. If you move the mouse over an area where you cannot type any text,
the mouse pointer turns back into the traditional arrow, pointing up to the left.

To move the cursor with the mouse, just point and click the left mouse
button once. The blinking cursor appears where you clicked the mouse.

If you have a blank page or a blank area at the end of your document, you can
move the cursor anywhere within this blank area by following these steps:
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1. Move the mouse pointer over any blank area past the end of a document.

Word defines the end of a document as the spot where no more text
appears. To find the end of a document, press Ctrl+End.

e In a new document: The end of the document is in the upper-left
corner where the cursor appears.

¢ In a document with existing text: The end of the document is the last
area where text appears (including spaces or tabs).

Notice that a Left, Left Indent, Center, or Right Justification icon appears
to the right or bottom of the I-beam mouse pointer, as shown in Figure 5-1.

. Make sure that the correct justification icon appears next to the mouse

pointer.

For example, if you want to center-justify your text, make sure that the
Center Justification icon appears at the bottom of the I-beam pointer.

Getting the Left, Center, or Right Justification icon to appear in Step 2
can be tricky. The Left Justification icon appears most of the time. If
you move the mouse pointer slightly indented from the left margin of
the page, the Left Indent icon appears. To make the Center Justification
icon appear, move the mouse pointer to the center of the page. To make
the Right Justification icon appear, move the mouse pointer to the right
edge of the page.

. Double-click the mouse pointer.

Word displays your cursor in the area you clicked. Any text you type
now will appear justified according to the justification icon displayed in
Step 3.

= Left lustification

1= Left Indent

= Conter lustification

1 Right Justification
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Moving the Cursor with the Keyboard

Moving the cursor with the mouse can be fast and easy. However, touch-
typists often find that moving the cursor with the keyboard is more conve-
nient and sometimes faster too. Table 5-1 lists different keystroke combina-

&&N‘Bfﬁ tions you can use to move the cursor.

You can move the cursor with both the keyboard and the mouse.

Table 5-1 Keystroke Shortcuts for Moving the Cursor in Word
Keystroke What It Does

T Moves the cursor up one line

l Moves the cursor down one line

- Moves the cursor right one character

«— Moves the cursor left one character

Ctrl+T Moves the cursor up to the beginning of the preceding paragraph
Ctri+l Moves the cursor down to the beginning of the next paragraph
Ctrl+— Moves the cursor right one word

Ctrl+« Moves the cursor left one word

Home Moves the cursor to the beginning of the line

End Moves the cursor to the end of the line

Ctrl+Home Moves the cursor to the beginning of a document

Ctrl+End Moves the cursor to the end of a document

Page Up Moves the cursor up one screen

Page Down Moves the cursor down one screen

Ctrl+Page Up Moves the cursor to the top of the preceding page

Ctrl+Page Moves the cursor to the top of the next page

Down

Viewing a Document

Word can display your document in one of five views, which can help you
better understand the layout, margins, and page breaks in your document:

v~ Print Layout: Displays page breaks as thick, dark horizontal bars so you
can clearly see where a page ends and begins. (This is the default view.)

v~ Full Screen Reading: Displays pages side by side so you see how adja-
cent pages appear next to each other.
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v Web Layout: Displays your document exactly as it would appear if you
saved it as a Web page.

v Outline: Displays your document as outline headings and subheadings.

v Draft: Displays the document without top or bottom page margins
where page breaks appear as dotted lines.

Switching between views

Microsoft Word gives you two ways to switch between different document
views, as shown in Figure 5-2:

v Click the view icons in the bottom of your document window.

v Click the View tab and then click the view you want to use, such as Print

Layout view.

Print Layout view can help you edit and create the design of your pages. If
you just want to focus on writing and not see your page margins or headers
and footers, you might be happier switching to Draft view instead. The two
most unusual views are Full Screen Reading and Outline views.

View icons

W id 9~ » o Microzaft Word
Mome  dniet  Pagelmout  Refersnces Mailing
i !
L& o
L

JEo

View icons



Chapter 5: Typing Text in Word 7 ’

Using Full Screen Reading view

Full Screen Reading view makes documents appear side by side like the
pages of a book, as shown in Figure 5-3. To “turn the pages” of a document
displayed in Full Screen Reading view, choose one of the following:

v Click the Previous Screen or Next Screen button.

v Click the Jump to a Page icon.
To exit Full Screen Reading view, choose one of the following:

v Press Esc.
v Click the Close button in the upper-right corner of the screen.
v Click the Print Layout button.
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Using Outline view

Outline view divides a document into sections defined by headings and text.
A heading represents a main idea. Text contains one or more paragraphs that
are “attached” to a particular heading. A subheading lets you divide a main
idea (heading) into multiple parts. A typical outline might look like Figure 5-4.

Within Outline view you can
v~ Collapse headings to hide parts (subheadings and text) temporarily
from view.
v Rearrange headings to move subheadings and text easily within a large

document.

Moving a heading automatically moves all subheadings and text. Instead of
cutting and pasting multiple paragraphs, Outline view lets you rearrange a
document by just moving headings around.

To switch to Outline view, click the Outline View icon at the bottom of the
document window (or click the View tab and then click the Outline icon).
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Defining a heading
Outline view considers each line as either a heading or text. To define a line
as either a heading style (Level 1 to Level 9) or text, follow these steps:

1. Move the cursor on the line that you want to define as a heading
or text.

2. Click in the Outline Level list box and choose a heading level, such as
Level 2.

Word displays Level 1 headings in large type to the far left margin. Level 2
headings appear in smaller type that’s slightly indented to the right, Level 3
headings appear in even smaller type that’s indented farther to the right, and
so on, as shown in Figure 5-5.

To create a heading quickly, move the cursor to the end of an existing head-
ing and press Enter to create an identical heading. For example, if you put the
cursor at the end of a Level 3 heading and press Enter, Word creates a new
blank Level 3 heading.
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Promoting and demoting a heading

After you define a heading (such as a Level 1 or Level 3 heading), you can
always change its level, such as changing a Level 1 heading to a Level 2
heading or vice versa. When you raise a heading from one level to another
(such as from Level 3 to Level 2), that’s promoting. When you lower a heading
(such as from Level 4 to Level 5), that’s demoting.

A Level 1 heading cannot be promoted because Level 1 is the highest heading.
Likewise, a Level 9 heading cannot be demoted because Level 9 is the lowest
heading.

To promote or demote a heading to a different level, follow these steps:
1. Using either the mouse or the keyboard, move the cursor to the head-
ing you want to promote or demote.
2. Choose one of the following methods:
¢ Click the Outline Level list box and click a level (such as Level 2).
* Press Tab (to promote) or Shift+Tab (to demote) the heading.
¢ Click the Promote or Demote arrow.

e Move the mouse pointer over the circle that appears to the left
of the heading, hold down the left mouse button, drag the mouse
right or left, and then release the left mouse button.

You can convert a heading to a Level 1 heading quickly by just clicking the
Promote to Heading 1 arrow.

Promoting or demoting a heading moves any subheadings or text attached to
the promoted or demoted heading.

Moving headings
You can move headings up or down within a document. To move a heading,
follow these steps:

1. Using either the mouse or the keyboard, move the cursor to the head-
ing you want to promote or demote.
2. Choose one of the following methods:
e Click the Move Up or Move Down arrow.
e Press Alt+Shift+T or Alt+Shift+!.

¢ Move the mouse pointer over the circle that appears to the left of
the heading, hold down the left mouse button, drag the mouse up
or down, and then release the left mouse button.
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If you collapse a heading before moving it, you can move any subheadings or
text underneath that heading.

Creating text
Text can consist of a single sentence, multiple sentences, or several para-
graphs. Text always appears indented underneath a heading (or subheading).
To create text, follow these steps:

1. Move the cursor to the end of a heading or subheading.

This is the heading (or subheading) that your text will be attached to if
you move the heading (or subheading).

2. Press Enter.
Word creates a blank heading.

3. Click the Demote to Body Text button (or click in the Outline Level list
box and choose Body Text).

Word displays a bullet indented underneath the heading you chose in
Step 1.

4. Type your text.

Collapsing and expanding headings and subheadings

If a heading or subheading contains any subheadings or text underneath, you
can collapse that heading. Collapsing a heading simply hides any indented
subheadings or text from view temporarily. Expanding a heading displays any
previously hidden subheadings or text.

To collapse a heading along with all subheadings or body text underneath it,
double-click the plus icon that appears to the left of the heading.

If you just want to collapse the subheading or body text immediately under-
neath a heading, choose one of the following:

v Move the cursor anywhere in the heading you want to collapse, and then
click the Collapse button.
1 Press Alt+Shift++ (plus sign key).

To expand a collapsed heading to reveal all subheadings and body text, dou-
ble-click the plus icon that appears to the left of the heading.

If you just want to expand the subheading or body text immediately under-
neath a collapsed heading, choose one of the following:
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v Move the cursor anywhere in the heading you want to expand, and then
click the Expand button.

v Press Alt+Shift+— (minus sign key).

Navigating through a Document

If you have a large document that consists of many pages, you won’t be able
to see all the pages at the same time. Instead, you’ll have to scroll through
your document by using either the mouse or the keyboard.

Navigating with the mouse

To scroll through a document with the mouse, you have two choices:

v Use the vertical scroll bar that appears on the right side of every docu-
ment window.

v Use the scroll wheel of your mouse (assuming that your mouse has a
scroll wheel).

Using the scroll bar

The scroll bar gives you multiple ways to navigate through a document, as
shown in Figure 5-6:

1+~ Up arrow (T): Moves up one line at a time.
1+ Down arrow (1): Moves down one line at a time.

v Scroll box: Dragging the scroll box up displays different pages. Moving
the scroll box up moves closer to the beginning; moving the scroll box
down moves closer to the end.

v Scroll area: Clicking above the scroll box moves the document one
screen up; clicking below the scroll box moves the document one
screen down.

v Previous Page (Ctrl+PgUp): Moves the cursor to the top of the preced-
ing page.

1 Next Page (Ctrl+PgDn): Moves the cursor to the top of the next page.

v Select Browse Object (Alt+Ctrl+Home): Gives you a variety of ways

to move to another part of a document, such as by page, section, or
heading.
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Using a mouse scroll wheel

If your mouse has a scroll wheel, you can use that to scroll through a docu-
ment in one of two ways:

v Move the mouse pointer over your document and roll the scroll wheel
up or down.

v Move the mouse pointer over your document and click the scroll wheel;
then move the mouse up or down. (The scrolling speeds up the farther
up or down you move the mouse from the position where you clicked
the scroll wheel.) Click the left mouse button or the scroll wheel to turn
off automatic scrolling when you’re done.

Using the Go To command

If you know the specific page number of your document that you want to
scroll to, you can jump to that page right away by using the Go To command.
To use the Go To command, follow these steps:
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Figure 5-7:
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1. Click the Home tab.
2. Choose one of the following:

e Click the downward-pointing arrow to the right of the Find icon
and click Go To.

e Click the Page button in the bottom-left corner.
¢ Click the Select Browse Object icon, and then click the Go To icon.
¢ Press Ctrl+G.

The Find and Replace dialog box appears with the Go To tab selected, as
shown in Figure 5-7.

Find and Replace 7=
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Coiment
Festrote

Frevious | et | s

3. Click in the Enter Page Number text box and type a page number.

If you type a plus sign (+) or a minus sign (-) in front of a number, you
can scroll that many pages forward or backward from the currently dis-
played page. For example, if the displayed page is 5, typing -2 displays
page 3 and typing +12 displays page 17.

4. Click the Go To button.
Word displays your chosen page.
5. Click Close to make the Find and Replace dialog box disappear.

Finding and Replacing Text

To help you find text, Word offers a handy Find feature. Not only can this
Find feature search for a word or phrase, but it also offers a Replace option
so you can make Word find certain words and automatically replace them
with other words.
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Using the Find command

The Find command can search for a single character, word, or a group of
words. To make searching faster, you can either search an entire document
or just a specific part of a document. To make searching a document more
flexible, Word lets you search for specific words or phrases, headings, or

pages.

Searching for text

To search for words or phrases by using the Find command, follow these
steps:

1. Click the Home tab.

2. Click the Find icon in the Editing group.

The Navigation Pane appears in the left side of the screen, as shown in
Figure 5-8.

If you click the downward-pointing arrow to the right of the Find icon, a
menu appears that lets you choose the Find or Go To command.

Navigation v x

3. Click in the Search Document text box, type a word or phrase to find,
and press Enter.

The Navigation Pane lists all matching text, as shown in Figure 5-9.
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All matching
text appears
in the
Navigation
Pane.
|

\\3

Nimgation ]

Gallsitr % -

a0t matchies
4l | oo & ol

GULLIVER S TRAVLLY

Although b, GUEIWER was borm in Mottinghamshire, wherehistather
dwelt, yet | have heard hirn say his family came from Oxfordshire to
confirm wehichy, | have obsseryed in the churchyard at Banbupy in that

county, several tombs and monuments of the Gullivers.

Betore he quitted Redritt, helett the custody ot the following papers in

my hands, withthe liberty to dispose of them asi shouldthink fit. 1

cnunty, several tambs and

monuments af the Culliver b carelully perused thesn three times, The style s very plainand
simple; andthe only tault | find is, that the author, afterthe manner

Mr, Guilliwes Tred spoken il

of travellers, iz alittletoo creumstantial. Thereis anair of truth
apgiment through the whal e ard indieed e suthor wirs so distinguishied

tor his veracity, thatit becsme a sort of proverb amonghis neighbours

&t Rednff, when any one affirmed athing to say, it was as true asif

Wr. BRATINRR had spoken it

As you type, Word displays all matching text. So if you start typing he,
Word will find all text that matches “he,” such as “hello,” “helicopter,”
or “help.”

4. Click on any of the text displayed in the Navigation Pane.
Word highlights your chosen text in your document.

5. Click on the X icon that appears in the Search Document text box in
the Navigation pane.

Word clears the text you typed in Step 3.

Customizing text searching

If you just want to find a word or phrase, the ordinary Find command works,
but if Word finds too much irrelevant text, you might want to take time to
customize how Word searches for text. Follow these steps:

1. Click the Home tab.
2. Click the Find icon in the Editing group.

The Navigation Pane appears in the left side of the screen (refer to
Figure 5-8).

3. Click the Magnifying Glass icon in the Search Document text box in
the Navigation pane.

A pull-down menu appears, as shown in Figure 5-10.
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4. Click Options.

A Find Options dialog box appears, as shown in Figure 5-11.

Mavigation - X
Feges
__ E] Cplions..
2 Ena.
Tou can search for leslin | “ae  Beplace.
your document by typing o £o 700
the search box above, 5o
Tind:
Click the Magnifying Glas: =
button to find commands (8 Graphics
search for objects, such ac
Graphics, [anles, Fouatior 3 1ables
or Revlewers. Enuatinns
AR Footnotes/Endnotes
= Comments
Find Optlons 7Ea
March case Match prefi
Find whols words only Magch suffic
L vabde ards Igrure purtuation charactery
Soursds e (Englih) Ignure while-space characbers
Fired all grord furess {Engish)
¥ Highihi. o
o] Icremental fied
Sek o Defak ol

5. Select one or more options in the Find Options dialog box.

® Match case: Finds text that exactly matches the upper- and lower-
case letters you type

e Find whole words only: Finds text that is not part of another word.
Searching for on will not find words like onion
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¢ Use wildcards: Lets you use the single character (?) or multiple
character (*) wildcards, such as searching for d?g, which will find
dog or dig; or b*t, which will find but, butt, or boost

e Sounds like: Searches for words based on their phonetic pronun-
ciation, such as finding elephant when searching for elefant

e Find all word forms: Finds all variations of a word, such as finding
run, ran, and running

e Match prefix: Searches for the prefix of words, such as finding
words like “interact” just by searching for “inter”

e Match suffix: Searches for the suffix of words, such as finding words

like “runner” or “keeper” just by searching for “er”

e Ignore punctuation characters: Ignores punctuation characters in
text, such as finding the phrase “Hello, there” when you searched
for “Hello there” in the Navigation Pane

e Jgnore white-space characters: Ignores spaces when searching, such

as finding the phrase “BotheCat” when you searched for “Bo the
Cat” in the Navigation Pane

6. Click OK to make the Find Options dialog box disappear.

The next time you search for text, Word will use the options you chose.

Searching by headings

Rather than search for a word or phrase, you might want to browse a long
document by headings. After you find the heading you want, then you can
edit or read the text underneath that heading.

To search by headings, follow these steps:

1. Click the Home tab.
2. Click the Find icon in the Editing group.

The Navigation Pane appears in the left side of the screen (refer to
Figure 5-8).

3. Click the Headings tab (underneath the Search Document text box) in

the Navigation Pane.

Alist of headings appears in the Navigation Pane, as shown in Figure 5-12.

4. Click on a heading in the Navigation Pane.

Word displays the heading in your document.
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CHAPTERIV. The Rabbit Sends ina Litte Bill

It was the Wnike RAbBIE, trobting alowly hack again, and laoking
anxiously about az it went, &= if it had lost =omething: and she heard

it muttering to itself ‘The Duchess! The Duchess! Oh my dear paws! Oh
my fur and whiskera' She'll ger me exesuted, As sure As fereeca are
fecpets! Whece CAN I have dropped them, I wondee?' klice guessed in a
moment that it was loocking for the fan and the pair of white kid gloves,
and she very good-naturedly began hunting about for them, but they were
nO¥here to bR Seen--fUATYLhing seemed to have changed Since her awim in

Browsing through pages

In a long document, you often have to scroll or flip through multiple pages to
find specific text. To simplify this task, Word can display all pages as thumb-
nail images. You can browse through these thumbnail images and click on
the page that you want to view in more detail.

To browse through multiple pages, follow these steps:

1. Click the Home tab.
2. Click the Find icon in the Editing group.

The Navigation Pane appears in the left side of the screen (refer to
Figure 5-8).

3. Click the Pages tab (the middle tab) in the Navigation Pane.
Word displays thumbnail images of all your pages, as shown in Figure 5-13.
4. Click on the thumbnail image of the page that you want to view.

Word displays your chosen page.
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Using the Find and Replace command

Rather than just find a word or phrase, you may want to find that text and
replace it with something else. To use the Find and Replace command, follow
these steps:

1. Click the Home tab.

2. Click the Replace icon in the Editing group. (You can also press

Ctrl+H.)

The Find and Replace dialog box appears, as shown in Figure 5-14.
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3. Click in the Find What text box and type a word or phrase to find.

4. Click in the Replace With text box and type a word or phrase to
replace the text you typed in Step 3.

5. (Optional) Click the More button and choose any additional options,
as shown in Figure 5-15.
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6. Click one of the following buttons:

¢ Replace All: Searches and replaces text throughout the entire

document

® Replace: Replaces the currently highlighted text

¢ Find Next: Searches from the current cursor location to the end of
the document

7. Click Find Next to search for additional occurrences of the text you

typed in Step 3.

8. Click Cancel to make the Find and Replace dialog box disappear.

Checking Vour Spelling

As you type, Word tries to correct your spelling automatically. (Try it! Type
tjihe, and Word will automatically change it to the in the blink of an eye.) If
you type something that Word doesn’t recognize, it underlines it with a red

squiggly line.
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‘;5‘" Just because Word underlines a word doesn’t necessarily mean that the word
< . ; .
is spelled wrong. It could be a proper name, a foreign word, or just a word that
Word isn’t smart enough to recognize.
To correct any words that Word underlines with a red squiggly line, follow
these steps:
1. Right-click any word underlined with a red squiggly line.
A pop-up menu appears, as shown in Figure 5-16.
2. Choose one of the following:
e The word you want: Click the correct spelling of the word that
appears in bold in the pop-up menu.
e Ignore: This tells Word to ignore this word but flag this same word
anywhere else in your document.
e Ignore All: This tells Word to ignore this word throughout your
document.
e Add to Dictionary: This tells Word to remember this word and
never flag it again as a misspelled word.
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Checking Vour Grammar

Sometimes Word may underline one or more words with a green squiggly line
to highlight possible grammar errors. To correct any grammar errors, follow
these steps:
1. Right-click any text underlined with a green squiggly line.
A pop-up menu appears.
2. Choose one of the following:

e What you want: Click the correct grammar that appears in bold in
the pop-up menu.

e Ignore Once: This tells Word to ignore the sentence.

e About This Sentence: This displays a help window that provides
examples of correct grammar, as shown in Figure 5-17.
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¥ Rather than right-click on each possible grammatical error, you may find

it easier to click the Proofing icon (which looks like an open book) in the
bottom-left corner of the screen.

Although Word’s spell and grammar checker can catch most errors, it prob-
ably won’t catch all of them and it may even highlight words and sentences
that are actually correct. Use Word’s spell and grammar checker as a tool,
but don’t rely on it to do all your proofing for you.
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Chapter 6
Formatting Text

In This Chapter
Changing fonts
Changing the font size
Using text styles
Coloring text
Justifying text
Creating lists

Clearing formatting

A fter you type text into a document, edit it, and check it for spelling

and grammatical errors, you're ready to make it look pretty; a process
known as formatting text. A properly formatted document can make your text
easy to read, while a poorly formatted document can make even the best
writing difficult or confusing to read.

The Home tab groups Word’s formatting tools into three categories:
v~ Font: Defines the font, font size, color, highlighting, and style (bold,

italic, underline, strikethrough, superscript, subscript, and case)

v~ Paragraph: Defines justification (left, center, or right), line spacing,
shading, borders, indentation, formatting symbols, and list style (bul-
lets, numbered, and outline)

v~ Styles: Displays predefined formatting that you can apply to your text
To format any text, follow these steps:

1. Select the text you want to format.

o WBER 2. Choose a formatting tool.
<
&

When you choose most formatting commands, that command stays on until
you turn it off by choosing the same command again.
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As soon as you select text by dragging the mouse, Word displays the most
commonly used formatting tools in a floating toolbar. You can click any icon
on this floating toolbar rather than click the same icon stored on the Ribbon.

Changing the Font

|
Figure 6-1:
The Font list
box displays
the appear-
ance of
each font.
|

The most common way to format text is to change the font. The font defines
the uniform style and appearance of letters such as Baskerville, Courier,
OLD ENGLISH, or STENCIL.

To change the font, follow these steps:

1. Click the Home tab.
2. Select the text you want to change.
3. Click the Font list box.
A list of available fonts on your computer appears, as shown in Figure 6-1.
4. Move the mouse pointer over each font.

Word temporarily changes your selected text (from Step 2) so you can
see how the currently highlighted font will look.

5. Click the font you want to use.

Word changes your text to appear in your chosen font.
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As a general rule, try not to use more than three fonts in a document. If you use
too many fonts, the overall appearance can be snnoying and DISTRACTING.

Not all computers have the same lists of fonts, so if you plan on sharing
documents with others, stick with common fonts that everybody’s computer
can display.

Changing the Font Size

SMBER

|
Figure 6-2:
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appears.
|

The font changes the appearance of text, but the font size defines how big (or
small) the text may look. To change the font size, you have two choices:

v Select a numeric size from the Font Size list box.

v Choose the Grow Font/Shrink Font commands.
You can use both methods to change the font size of text. For example, you

may use the Font Size list box to choose an approximate size for your text, and
then use the Grow Font/Shrink Font commands to fine-tune the font size.

To change the font size, follow these steps:

1. Click the Home tab.
2. Select the text you want to change.
3. Choose one of the following:

¢ Click the Font Size list box and then click a number, such as 12 or
24, as shown in Figure 6-2.

¢ Click the Grow Font or Shrink Font icon.
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91



92  Partii: Working with Word

Changing the Text Style

The text style defines the appearance of text in one or more of the following
ways:

v Bold: Press Ctrl+B.

v Italic: Press Ctrl+l.

v Underline: Press Ctrl+U.

v Strikethrotgh: This formatting draws a line through text.

v Subscript: Use this to create text that falls below the text line, as in the 2
in H,0.
2

v Superscript: Use this to create text that sits higher than the top of the
text line, as in the 2 in E = mc2.

To change the style of text, follow these steps:

1. Click the Home tab.
2. Select the text you want to change.
3. Click a Style icon, such as Bold or Underline.

4. Repeat Step 3 for each additional style you want to apply to your text
(such as italic and underlining).

If you select any style change without selecting any text, Word applies your
style changes to any new text you type from the cursor’s current position.

Changing Colors

Color can emphasize text. There are two ways to use color:

v Change the color of the text (Font color).
v~ Highlight the text with a different color (Text Highlight color).

Changing the color of text

When you change the color of text, you're physically displaying a different
color for each letter. Normally, Word displays text in black, but you can
change the color to anything you want, such as bright red or dark green.
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< If you choose a light color for your text, it may be hard to read against a white
background.
To change the color of text, follow these steps:
1. Click the Home tab.
2. Select the text you want to color.
3. Click the downward-pointing arrow to the right of the Font Color icon.
A color palette appears, as shown in Figure 6-3.
4. Click a color.
Word displays your selected text (from Step 2) in your chosen color.
Home
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After you choose a color, that color appears directly on the Font Color icon.
Now you can select text and click directly on the Font Color icon (not the
downward-pointing arrow) to color your text.

Highlighting text with color

Highlighting text mimics coloring chunks of text with a highlighting marker
that students often use to emphasize passages in a book. To highlight text,
follow these steps:

1. Click the Home tab.

2. Select the text you want to highlight.

3. Click the downward-pointing arrow to the right of the Text Highlight
Color icon.

A color palette appears, as shown in Figure 6-4.
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4. Click a color.
Word highlights your selected text (from Step 2) in your chosen color.
5. Press Esc (or click the Text Highlight Color icon again) to turn off the
Text Highlight Color command.
To remove a highlight, select the text and choose the same color again.
<P If no text is selected and the Text Highlight Color currently displays a color

you want to use (such as yellow), you can click the Text Highlight Color
icon (not its downward-pointing arrow). This turns the mouse pointer into a
marker icon. Now you can select and highlight text in one step.

Using Text Effects

If you want a fast way to format text that appears colorful like a neon sign,
then you can use Text Effects by following these steps:
1. Click the Home tab.
2. Select the text you want to modify.
3. Click the Text Effects icon.
A menu of different effects appears, as shown in Figure 6-5.
4. Click an effect.

Word changes your selected text (from Step 2) in your chosen visual
effect.
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Text Effects are a unique feature of Office 2010. If you save your document in
an older Word file format (such as Word 97-2003), you won’t be able to use
Text Effects.

Justifying Text Alignment

Word can align text in one of four ways, as shown in Figure 6-6:
1~ Left: Text appears flush against the left margin but ragged on the right
margin.
v Center: Every line appears centered within the left and right margins.

v~ Right: Text appears flush against the right margin but ragged on the left
margin.

v~ Justified: Text appears flush against both the left and right margins.
To align text, follow these steps:

1. Click the Home tab.
2. Move the cursor anywhere in the text you want to align.

3. Click one of the alignment icons, such as Center or Justify.
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Rather than click an alignment icon, you can use one of the alignment key-
stroke shortcuts as follows: Align Left (Ctrl+L), Center (Ctrl+E), Align Right
(Ctrl+R), or Justify (Ctrl+J).

Adjusting Line Spacing
Line spacing defines how close lines appear stacked on top of each other. To
change the line spacing of text, follow these steps:
1. Click the Home tab.
2. Select the text where you want to adjust the line spacing.
3. Click the Line Spacing icon.
A pull-down menu appears, as shown in Figure 6-7.

4. Click the line spacing you want, such as 1 (single spacing) or 3 (triple
spacing).
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If you click the More option in the pull-down menu, you can precisely define
your own line spacing, such as 2.75 or 3.13.

By default, Word automatically adds a blank line between paragraphs regard-
less of the line spacing you choose. To get rid of this extra space between
paragraphs, click the Page Layout tab, click in the After text box in the
Paragraph group, and type 0. (The default value is 10 pt.)

Making Lists

Word can organize and arrange text in three types of lists:

v~ Bullets (like this list)
v Numbering
v Multilevel list
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You can create a list from scratch or convert existing text into a list. To
create a list from scratch, follow these steps:

1. Click the Home tab.

2. Move the cursor where you want to create a list.

3. Click the Bullets, Numbering, or Multilevel List icon.

Word creates your list (bulleted or numbered).
4. Type your text and press Enter to create another blank item in your list.
5. Repeat Step 4 for each additional bullet or numbered item you want

to make.

If you have existing text, you can convert it into a list by following these
steps:

1. Click the Home tab.

2. Select the text you want to convert into a list.

3. Click the Bullets, Numbering, or Outline Numbering icon.

Word converts your selected text into your chosen list where each para-
graph appears as a separate item in the list.

Indenting list items

After you create a list, you may want to indent one list item underneath
another one. To indent an item in a list, follow these steps:

1. Move the cursor anywhere in the text in the list item you want to
indent.
2. Press the Home key to move the cursor to the front of the line.

3. Press the Tab key to indent an item to the right (or press the Shift+Tab
keystroke combination to indent an item to the left).

When you indent a list, Word changes the number or bullet style to set
the line apart from the rest of your list.

Converting list items back into text

If you have a list, you may want to convert one or more items back into ordi-
nary text. To convert a list item into plain text, follow these steps:

1. Click the Home tab.

2. Select the list items you want to convert into plain text.
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3. Click the appropriate Bullets, Numbering, or Outline Numbering icon.

If you want to convert a bullet list item into text, click the Bullets icon.

Customizing a list

When you create a bullet or numbered list, you can choose from a variety of
different styles. To choose a numbering style, follow these steps:

1. Click the downward-pointing arrow to the right of a list icon, such as
the Bullet or Numbering icon.
Make sure that you don’t click the Numbering icon itself.

A pull-down menu appears, listing all the different numbering styles
available, as shown in Figure 6-8.
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2. Click the numbering style you want.
The next time you click the Numbering icon, Word will use the number-
ing style you chose.

The changes you make to the numbering or bullet style will apply only to your
current document.

Renumbering numbered lists

Number lists can cause special problems when dividing or copying them
because the numbering may get out of sequence, or you may want to start
numbering from a number other than one.
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To change the starting number of a numbered list, follow these steps:

1. Right-click the item that you want to renumber.

If you want to renumber your entire list, right-click the first item at the
top of the numbered list.

A pop-up menu appears, as shown in Figure 6-9.
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2. Choose one of the following:
¢ Restart at 1: Changes the numbering of the current list item to 1,
the list item directly below to 2, and so on. (This option does not
appear if you right-click the first item in a number list.)
¢ Continue Numbering: Changes the number of the current list item to
one greater than the last numbered list item earlier in the
document.
e Set Numbering Value: Displays the Set Numbering Value dialog box,
shown in Figure 6-10, so you can change the current list item to a
specific number such as 34 or 89.
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Using the Ruler

When you create a document, Word creates page margins automatically.
However, if you want to adjust the left and right page margins, or define how
far the Tab key indents text, you need to use the Ruler.

By default, Word hides the Ruler to avoid cluttering up the screen. To display
(or hide) the Ruler, follow these steps:

1. Click the View tab.
2. Select (or clear) the Ruler check box in the Show group.

The ruler appears at the top and left margin of your document, as shown
in Figure 6-11.

Documentl - Microsoft Word =

Figure 6-11:
The Ruler
defines the
margins and
indentation
for your
document.

— L1002 words: 18] | < | @ 3 W% (=)— ¥

Ruler
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Adjusting left and right
paragraph margins
The Ruler defines the left and right margins for your paragraphs. To change
these paragraph margins, follow these steps:
1. Make sure that the Ruler appears visible.

2. Select any text.

3. Move the mouse pointer over the Left Indent icon on the Ruler, hold
down the left mouse button, and drag (move) the mouse to the right to
adjust the left paragraph margin.

Word displays a dotted vertical line to show you where the new left
paragraph margin will be, as shown in Figure 6-12.

Left Indent Right Indent

1 e =
W

reorm ally the ruler stays hidden, butif yournake it visible, youcan usethe rulerto adjustthe margins of
your paragraphs. Then again, rmost people arejust happy whentheir computer even works so adjusting
the marging of individual paragraphs is just s bonus if they can getthelr computerto work reliably,

4. Release the left mouse button when you’re happy with the position of
the left paragraph margin.

5. Move the mouse pointer over the Right Indent icon on the Ruler, hold
down the left mouse button, and drag (move) the mouse to the left to
adjust the right paragraph margin.

Word displays a dotted vertical line to show you where the new right
paragraph margin will be.

6. Release the left mouse button when you’re happy with the position of
the right paragraph margin.
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Defining indentation with the Ruler

The two icons on the Ruler that define indentation are the First Line Indent
and the Hanging Indent icons. The First Line Indent icon defines the position
of (what else?) the first line of every paragraph. The Hanging Indent icon
defines the position of every line of text except for the first line, as shown in
Figure 6-13.
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To define the first line and hanging indent, follow these steps:

1. Make sure that the Ruler appears visible.
2. Select any text.

3. Move the mouse pointer over the Left Indent icon on the Ruler, hold
down the left mouse button, and drag (move) the mouse to the right.

Word displays a dotted vertical line to show you where the new indenta-
tion margin will be.

4. Release the left mouse button when you’re happy with the position of
the left indentation of your text.

5. Move the mouse pointer over the First Line Indent icon on the Ruler,
hold down the left mouse button, and drag (move) the mouse to the
right (or left).

Word displays a dotted vertical line to show you where the new first line
indentation will be.

6. Release the left mouse button when you’re happy with the position of
the first line indent position.

Using Format Painter

Formatting can be simple, such as underlining text, or fairly complicated,
such as underlining text while also changing its font and font size. After you
format one chunk of text a certain way, you may want to format other parts
of your document the exact same way.
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Although you could take time to format text manually, it’s much easier to use
Format Painter instead. Format Painter tells Word, “See the way I formatted that
chunk of text over there? Apply that same formatting to a new chunk of text.”

To use Format Painter, follow these steps:

1. Click the Home tab.
2. Select the text that contains the formatting you want to copy.

3. Click the Format Painter icon, as shown in Figure 6-14.
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4. Select the text that you want to format. (Move the mouse pointer
over the beginning of the text you want to format, hold down the left
mouse button, and drag the mouse until you reach the end of the text
you want to format.)

Word applies your formatting to your selected text.

Using Styles

As an alternative to choosing fonts, font sizes, and text styles (like bold) indi-
vidually, Word offers several predefined formatting styles. To apply a style to
your text, follow these steps:

1. Click the Home tab.

2. Select the text that you want to format.

3. Click the up/down arrows of the Styles scroll bar to scroll through the
different styles available. Or click the More button to display a pull-
down menu of all the Quick Formatting styles, as shown in Figure 6-15.
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4. Move the mouse pointer over a style.
Word displays what your text will look like if you choose this style.
5. Click the style you want to use, such as Heading 1, Title, or Quote.

Word formats your text.
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Using Templates

In case you need to format an entire document a certain way, you may want
to use templates instead. Templates act like preformatted documents. Word
comes with several templates, but Microsoft offers several through its Web
site as well.

To create a new document from a template, follow these steps:

1. Click the File tab and then choose New.
An Available Templates window appears, as shown in Figure 6-16.
2. Double-click on a template.

Word creates a blank document with “dummy” text to show you how the
formatting looks.

Qg\‘l\BEﬂ 3. Type new text into your newly created document.
&
&

You may need to be connected to the Internet to download some of the
available templates.
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Removing Formatting from Text

After you format text, you can always remove that formatting. The simplest
way to do this is to apply the same formatting you want to remove. For exam-
ple, if you underline text, you can remove the underlining by highlighting all
the underlined text and choosing the underline command (by pressing Ctrl+U
or by clicking the Underline icon).

If you want to remove multiple formatting from text, you could remove

each formatting style one by one, but it’s much easier just to use the Clear
Formatting command instead, which removes all formatting on text no matter
how much formatting there may be.

To use the Clear Formatting command, follow these steps:

1. Click the Home tab.

2. Select the text that contains the formatting you want to remove.

3. Click the Clear Formatting icon, as shown in Figure 6-17.

Word removes all formatting from your selected text.
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The Clear Formatting command will not remove any highlighting you

may have applied over text.
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Chapter 7
Designing Your Pages

In This Chapter
Inserting pages
Organizing text in tables
Displaying text as WordArt
Creating text boxes
Dividing text into columns
Adding pictures
Printing

rle Insert and Page Layout tabs contain the most frequently used com-
mands for designing the layout and appearance of your pages. You can
add columns or headers and footers that display titles or page numbers, or
add colors and pictures to your pages.

The Insert tab provides commands for inserting items into a document, such
as new pages, tables, pictures, and headers and footers.

The Page Layout tab provides commands for defining how your pages look,
such as creating columns; defining top, bottom, left, and right page margins;
as well as defining how text wraps around pictures or other objects you place
in the middle of a page.

Inserting New Pages

Word automatically adds new pages to your document as you write.
However, Word also gives you the option of adding a new page anywhere in
your document, such as in the middle or the beginning.
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To insert a new, blank page in your document, follow these steps:

1. Click the Insert tab.
2. Move the cursor where you want to insert the new page.
3. Click the Blank Page icon in the Pages group.

Word adds a blank page to your document where the cursor appears.
So if you put the cursor between two sentences and insert a blank page,
the first sentence will appear on one page, a blank page will appear next,
and the second sentence will appear after the blank page.

“&N\BEI: )
& You don’t need to add a page to the end of a document. Just move the cursor
to the end of your document (Ctrl+End), start typing, and Word automatically
adds new pages at the end of your document.

Adding (And Deleting) a Cover Page

Rather than add more pages to type text, you may just need a cover page that
is the first page that anyone can read. A cover page typically displays a title
and any additional information such as your company name and a date.

To create a cover page, follow these steps:

1. Click the Insert tab.
2. Click the Cover Page icon in the Pages group.

Word displays a list of cover page designs, as shown in Figure 7-1.
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3. Click a cover page design.
Word adds your chosen cover page as the first page of your document.
‘3“" A document can have only one cover page at a time. If you choose another

cover page, Word deletes your current cover page and replaces it with the
new one you chose.

After you add a cover page, you may want to delete it later. To delete a cover
page, follow these steps:
1. Click the Insert tab.
2. Click Cover Page in the Pages group.
A pull-down menu appears (refer to Figure 7-1).
3. Choose Remove Current Cover Page.

Word deletes your cover page.

Inserting Page Breaks

Rather than insert a new page, you may want to break text on an existing
page into two pages. To insert a page break in your document, follow these
steps:

1. Move the cursor where you want to break your document into two
pages.

2. Click the Insert tab.

3. Click the Page Break icon in the Pages group.

e BER Word breaks your document into two pages.
&
<

To delete a page break, move the cursor to the top of the page directly follow-
ing the page break you want to delete. Then press Backspace.

As an alternative to following Steps 2 and 3 in the preceding step list, you can
just press Ctrl+Enter to create a page break at the cursor’s current location.

Inserting Headers and Footers

Headers and footers appear at the top (headers) and bottom (footers) on one
or more pages of your document. Headers and footers can display informa-
tion such as titles, chapter names, dates, and page numbers.
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Creating a header (or footer)

To create a header or footer, follow these steps:

1. Click the Insert tab.

2. Click the Header or Footer icon in the Header & Footer group.
A pull-down menu appears.

3. Click Edit Header (or Edit Footer).
Word displays your header or footer.

You can click on a predefined header (or footer) that’s already format-
ted to look pretty so you don’t have to spend time formatting it yourself.

Headers and footers are visible only when you display a document in
Print Layout view.

4. Type, edit, or delete any text you want to change.

5. (Optional) Click the Date & Time or Page Number icons of the
Design contextual tools to insert the date and time or page numbers,
respectively.

6. Click the Close Header and Footer icon.

Word dims your header and footer text.

Defining which pages to display
a header (or footer)

Usually when you define a header or footer, Word displays that header or
footer on every page of your document. However, Word gives you the option
of displaying a different header and footer for your first page only, or display-
ing different headers and footers for odd and even pages.

Creating a unique header or footer for your first page

Often, you want a header or footer to display page numbers and document
or chapter titles — just not on the first page of your document. To create a
unique header or footer that appears only on your first page, follow these
steps:

1. Click the Insert tab, click the Header icon in the Header & Footer
group, and choose Edit Header.

The Design tab appears, as shown in Figure 7-2.
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2. Select the Different First Page check box in the Options group.

Word displays a header or footer with the name First Page Header
or First Page Footer.

3. Click the Close Header and Footer icon.

Word dims your header and footer text.

Creating unique headers and footers for odd and even pages

Sometimes you may want different headers or footers to appear on even or
odd pages. In most books, even page numbers (headers) appear in the upper-
left corner while odd page numbers (headers) appear in the upper-right
corner. To create this effect in your own documents, you need to create dif-
ferent headers to appear on odd and even pages.

To create a different header or footer for even and odd numbered pages,
follow these steps:

1. Click the Insert tab, click the Header icon in the Header & Footer
group, and choose Edit Header.

The Design tab appears.
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2. Select the Different Odd & Even Pages check box in the Options
group.

Word displays a header or footer with the name 0dd Page Header or
Even Page Footer.

3. Click the Close Header and Footer icon.
4. Switch to another page.
5. Repeat Steps 2 through 4 to define the other odd or even header.

If an odd page number originally appeared in Step 2, switch to an even
page number (or vice versa) for Step 5.

Deleting a header (or footer)

In case you want to get rid of a header or footer, you can always delete it by
following these steps:
1. Click the Insert tab.
2. Click the Header or Footer icon in the Header & Footer group.
A pull-down menu appears.
3. Click Remove Header (or Remove Footer).

Word removes your header or footer.

Organizing Text in Tables

Tables organize text into rows and columns, which can make it easy to type,
edit, and format text while spacing it correctly in your document. Tables
organize text in cells, where a cell is the intersection of a row and a column.

Word provides four ways to create a table:

v Click the Insert tab, click the Table icon, and then highlight the number
of rows and columns for your table (up to a maximum of eight rows and
ten columns).

v Use the Insert Table dialog box.
v Draw the size and position of the table with the mouse.

v Convert existing text (divided by a delimiter character such as a Tab
or comma).
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Creating a table by highlighting
rows and columns

Creating a table by highlighting rows and columns can be fast, but it limits
the size of your table to a maximum of eight rows and ten columns. To create
a table by highlighting rows and columns, follow these steps:

1. Click the Insert tab.

2. Move the cursor where you want to insert a table in your document.

3. Click the Table icon.

A pull-down menu appears, as shown in Figure 7-3.
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4. Move the mouse pointer to highlight the number of rows and columns
you want to create for your table.

When you highlight rows and columns, Word displays your table
directly in your document so you can see exactly what your table will
look like.

5. Click the left mouse button when you’re happy with the size of
your table.

Creating a table with the
Insert Table dialog box

Creating a table by highlighting the number of rows and columns can be fast,
but it limits the size of your table to a maximum of eight rows and ten col-
umns. To create a table by defining a specific number of rows and columns
(up to a maximum of 63 columns), follow these steps:
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|
Figure 7-4:
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1. Click the Insert tab.
2. Move the cursor where you want to insert a table.
3. Click the Table icon.
A pull-down menu appears (refer to Figure 7-3).
4. Click Insert Table.

The Insert Table dialog box appears, as shown in Figure 7-4.
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5. Click in the Number of Columns text box and type a number between 1
and 63, or click the up/down arrows to define the number of columns.

6. Click in the Number of Rows text box and type a number or click the
up/down arrows to define the number of rows.

7. Select one of the following radio buttons in the AutoFit Behavior
group:

¢ Fixed Column Width: Defines a fixed size for the column widths,
such as 0.3 inches

e AutoFit to Contents: Defines the width of a column based on the
width of the largest item stored in that column

e AutoFit to Window: Expands (or shrinks) the table to fit within the
current size of the document window

8. Click OK.

Word draws the table in your document.

Creating a table with the mouse

Drawing a table can be especially useful when you want to place a table in the
middle of a page and create rows and columns of different sizes, as shown in
Figure 7-5.
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To draw a table in your document, follow these steps:

1.
2.

Click the Insert tab.
Click the Table icon.

A pull-down menu appears.

. Click Draw Table.

The mouse pointer turns into a pencil icon.

. Move the mouse pointer where you want to draw your table, hold down

the left mouse button, and drag (move) the mouse to draw your table.

Word draws a rectangular dotted box to show you where your table will
appear.

. Release the left mouse button when you’re happy with the size and

position of your table.

. Move the mouse pointer to the top/bottom or left/right side of the

table, hold down the left mouse button, and drag (move) the mouse up
and down (or right and left) to draw the boundaries for your table’s
rows and columns.

. Press Esc or double-click to turn the mouse pointer from a pencil icon

back to an I-beam pointer.
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|
Figure 7-6:
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If you need to draw new lines on a table later, click anywhere inside that
table and the Design tab appears. Then click the Draw Table icon to turn
the mouse pointer into a pencil icon. Now you can draw new lines in
your table.

Creating a table from existing text

If you have existing text that you'd like to turn into a table, you need to first
separate text into chunks so Word knows how to place the text into indi-
vidual cells in a table. To separate text, you need to use a unique character
such as

v~ Paragraphs: The invisible Return character separates text.

v~ Tabs: The invisible Tab character separates text.

v Commas: Commas separates text.

v Other: You can define other characters to separate text, such as the #

or @ characters.

By dividing text with the same unique character, you can define how you
want Word to define how much text to display in each individual cell of a
table, as shown in Figure 7-6.
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To convert existing text into a table, follow these steps:

1. Click the Insert tab.

2. Select the text that you want to convert into a table.
3. Click the Table icon.

A pull-down menu appears (refer to Figure 7-3).
4. Click the Convert Text to Table command.

The Convert Text to Table dialog box appears, as shown in Figure 7-7.
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5. (Optional) Select a radio button in the Separate Text At group, such as
Paragraphs, Tabs, or Commas.

You must choose the option that corresponds to the way you divided

your text. So if you divided your text by tabs, you would click the Tabs
radio button.

6. Click OK.

Word converts your text into a table.

You can also convert a table into text. To convert a table into text, follow
these steps:
1. Click anywhere inside the table you want to convert into text.
The Layout tab appears.
2. Click the Layout tab.
3. Click Convert to Text.

The Convert Table to Text dialog box appears, as shown in Figure 7-8.
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Figure 7-8:
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Figure 7-9:
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4. Select a radio button to define how you want to divide your table into
text, such as by Commas, Tabs, Paragraph Marks, or other symbol, as

shown in Figure 7-9.
5. Click OK.
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Formatting and Coloring a Table

Figure 7-10: _

The Select
icon
displays a
pull-down
menu.
|

After you create a table, you can format individual cells (the intersection of a
row and column) or entire rows and columns by aligning text in cells, resizing
columns and rows, and adding borders, shading, or colors, all of which can
make the text inside easier to read.

Selecting all or part of a table

To format and color a table, you must first select the table, row, column,
or cell that you want to modify. To select all or part of a table, follow these
steps:
1. Click in the table, row, column, or cell you want to modify.
The Table Tools tab appears.
2. Click the Layout tab.
3. Click Select in the Table group.

A pull-down menu appears, as shown in Figure 7-10.
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4. Choose an option, such as Select Row or Select Column.

Word highlights your chosen item in the table.

Aligning text in a table cell

You can align text in a table cell in nine different ways: Top Left (the default
alignment), Top Center, Top Right, Center Left, Center, Center Right, Bottom
Left, Bottom Center, and Bottom Right, as shown in Figure 7-11.
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Figure 7-11:
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To align one or more cells, follow these steps:

1. Click in the cell that contains text you want to align.
The Table Tools tab appears.
2. Click the Layout tab.

3. Click an alignment icon in the Alignment group (refer to Figure 7-11)
such as Top Right or Bottom Center.

Word aligns your text. If you changed the alignment of blank cells, any
new text you type in those blank cells will appear according to the align-
ment you chose.

Picking a table style

By coloring rows or columns and adding borders, you can customize the
appearance of your tables. However, it can be much faster to use a prede-
signed table style instead, which can automatically format your text, color
rows, and add borders to your tables.

To choose a table style, follow these steps:

1. Move the cursor inside the table you want to modify.
2. Click the Design tab.

3. (Optional) Click or clear check boxes under the Table Style Options
group, such as the Header Row or Last Column check box.
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4. Click the More button on the Table Styles group.

A pull-down menu of all available styles appears, as shown in Figure 7-12.
As you move the mouse pointer over a table style, Word displays a live
preview of how your table will look.
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5. Click a table style.

Word formats your table according to the style you chose.

Resizing columns and rows

You may need to resize a column or row in your table to expand or shrink it
so your text doesn’t appear crowded or surrounded by empty space. You can
resize a column or row by using the mouse or by defining row heights and
column widths.

To resize a row or column with the mouse, follow these steps:

1. Move the mouse over the row or column border that you want to
resize.

The mouse pointer turns into a two-way pointing arrow.
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2. Hold the left mouse button down and drag (move) the mouse to resize
the row or column.

3. Release the left mouse button when you’re happy with the size of the
row or column.

Using the mouse to resize a row or column can be fast, but if you want to
resize a row or column to a specific height or width, you can type in the spe-
cific dimensions by following these steps:

1. Select the row, column, or table that you want to modify. (If you select
the entire table, you can adjust the width or height of rows and col-
umns for your entire table.)

<® 2. Click the Layout tab and look in the Cell Size group.

If you want to define the width or height of multiple rows or columns
equally, either

¢ Click the Distribute Columns or Distribute Rows icon in the Cell
Size group.

¢ Click the Show Table Properties icon in the bottom-right corner of
the Cell Size group to display the Table Properties dialog box, as
shown in Figure 7-13.
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3. To precisely define a column’s width, click the Width list box and type
a value (or click the up/down arrows to choose a value).
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4. To precisely define a row’s height, click the Height list box and type a
value (or click the up/down arrows to choose a value).

5. (Optional) Click AutoFit and choose one of the following:
¢ AutoFit Contents: Shrinks your columns or rows to largest cell

e AutoFit Window: Expands the table to fit the width of the current
document window

Sorting a Table

Tables not only can organize data, but they can also sort your data alpha-
betically. To sort a table, you need to specify a single column of data to sort.
When Word sorts the data in this column, it automatically sorts every row in
the table as well, as shown in Figure 7-14.
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To sort a table, follow these steps:

1. Select the column that contains the data you want to sort.
2. Click the Layout tab under the Table Tools tab.
3. Click the Sort icon in the Data group.

The Sort dialog box appears, as shown in Figure 7-15.
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4. Click in the top Type list box and choose the type of data you want to
sort: Text, Number, or Date.

5. Select either the Ascending or Descending radio button.
6. Click OK.

Word sorts your entire table based on the data in the column you
selected.

Deleting Tables

After you create a table, you can delete the entire table, delete one or more
rows or columns, or just delete individual cells along with their data.

Deleting an entire table

Word gives you two choices in deleting a table. First, you can wipe out just
the data inside the table while leaving the table itself intact. Second, you can
wipe out both the data and the table at the same time.
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To delete just the data in a table, follow these steps:

1. Select every row and column in the table.
2. Press Delete.

Word wipes out all your data and leaves an empty table.

To delete both your table and all the data stored in it at the same time, follow
these steps:

1. Move the cursor into the table you want to wipe out.

2. Click the Layout tab under the Table Tools tab.

3. Click the Delete icon in the Rows & Columns group.
A pull-down menu appears, as shown in Figure 7-16.

4. Choose Delete Table.

Word wipes out your table and all the data stored in it.
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Deleting rows and columns

Rather than delete an entire table, you can also delete rows and columns.
When you delete a row or column, you wipe out any data stored inside that
row or column.

To delete a row or column, follow these steps:

1. Move the cursor into the row or column you want to delete.
2. Click the Layout tab under the Table Tools tab.
3. Click the Delete icon.
A pull-down menu appears (refer to Figure 7-16).
4. Choose Delete Columns or Delete Rows.

Word deletes your chosen column or row.
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Deleting cells

You can delete data in cells just by selecting the data and pressing the Delete
key. If you want to delete data and the cell itself, you have two options:

 Delete a cell and shift adjacent rows or columns. This creates an odd-
shaped table.

v Delete the data and cell borders. This keeps the table symmetrical but
often merges cells.

To delete a cell and change the physical layout of a table, follow these steps:

1. Select the cell or cells you want to delete.
2. Click the Layout tab under the Table Tools tab.
3. Click the Delete icon in the Rows & Columns group.
A pull-down menu appears (refer to Figure 7-16).
4. Choose Delete Cells.
The Delete Cells dialog box appears.
5. Select the radio button for Shift Cells Left or Shift Cells Up.
6. Click OK.

Word deletes your chosen cells and shifts cells left or up, creating an
odd-shaped table with missing cells, as shown in Figure 7-17.
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Deleting cell borders

Word also lets you delete individual cell lines by using the mouse. By using the
mouse, you can delete borders and merge adjacent cells at the same time.
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To use the mouse to delete cell lines, follow these steps:

1. Move the cursor into the table you want to modify.
2. Click the Design tab under the Table Tools tab.
3. Click the Eraser icon in the Draw Borders group.
The mouse pointer turns into an eraser icon.
4. Choose one of the following:
e Click a cell border to delete it.
or

a. Move the mouse pointer near a cell line to delete, hold down the left
mouse button, and drag (move) the mouse to highlight one or more
cell lines.

Word highlights any cell lines you select.
b. Release the left mouse button.

Word deletes the selected cell lines and any data stored in adja-
cent cells.

5. Press Esc or double-click the mouse to turn off the Eraser and convert
the mouse pointer back into an I-beam cursor.

Making Text Look Artistic

To spice up the appearance of individual paragraphs, Word lets you add drop
caps, text boxes, or WordArt. Drop caps make the first letter of a paragraph
appear huge. WordArt displays text as graphical images. Text boxes let you
display chunks of text in separate boxes that you can arrange anywhere in
your document.

Creating drop caps
To create a drop cap, follow these steps:

1. Click the Insert tab.

2. Move the cursor anywhere inside the paragraph where you want to
create a drop cap.

3. Click Drop Cap.

The Drop Cap menu appears, as shown in Figure 7-18.
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4. Move the mouse pointer over the drop cap style you want to use.

Word shows you what your drop cap will look like.

5. Click the drop cap style you want to use.

Creating WordArt

WordArt is Microsoft’s fancy term for displaying text in different graphical
styles that you can stretch or resize on a page. You can create WordArt from

scratch or from existing text.
To create WordArt, follow these steps:

1. (Optional) Select the text you want to convert into WordArt.
If you skip this step, you have to type in text later.

2. Click the Insert tab.

3. Click WordArt.

The WordArt menu appears, as shown in Figure 7-19.
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4. Click a WordArt style.

A WordArt text box appears in your document, as shown in Figure 7-20.
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5. (Optional) To resize your WordArt, move the mouse pointer over a
WordArt handle (on the edge or the corner), hold down the left mouse
button, and drag (move) the mouse.

6. Type or edit text, and then click outside of the WordArt text box.
Word displays your text as WordArt.

To edit your WordArt text, just click on that text.

You can delete WordArt by clicking on its border and then pressing Delete.
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Dividing Text into Columns

When you type, Word normally displays your text to fill the area defined by
the left and right margins. However, you can also divide a page into two or
three columns, which can be especially handy for printing newsletters.

To divide a document into columns, follow these steps:

1. Click the Page Layout tab.

2. Select the text that you want to divide into columns. (Press Ctrl+A to
select your entire document.)

3. Click the Columns icon.

A pull-down menu appears that lists different column styles, as shown in

Figure 7-21.
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4. Click a column style.

Word changes your document to display columns.

Editing columns

After you create two or three columns in your document, you may want

to modify their widths, modify the spacing between columns, and choose
whether to display a vertical line between columns. To edit columns, follow
these steps:

1. Move the cursor to the text divided into columns that you want to
modify.
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2. Click the Page Layout tab.
3. Click the Columns icon.

A pull-down menu appears (refer to Figure 7-21).
4. Click More Columns.

The Columns dialog box appears, as shown in Figure 7-22.
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5. (Optional) Click in the Number of Columns text box and click the up/
down arrows to define how many columns you want (from 1 to 9).

6. (Optional) Click in the Width Text box and type a value or click the
up/down arrows to define a width for column 1.

7. (Optional) Click in the Spacing Text box and type a value or click the
up/down arrows to define the spacing width to the right of column 1.

8. (Optional) Repeat Steps 6 and 7 for each additional column you want
to modify.

9. (Optional) Select the Line Between check box to display a vertical line
between your columns.

10. (Optional) Click the Apply To list box and choose Whole Document or
This Point Forward (to define how columns appear from the current
cursor position to the end of the document).

11. Click OK.

Word displays the changes for your columns.
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Removing columns

If you decide you don’t want to display text in columns any more, you can
remove columns throughout your entire document or just from the current
cursor position to the end of the document.

To remove columns, follow these steps:
1. Move the cursor to the page where you want to remove columns from
this page to the end of a document.
2. Click the Page Layout tab.
3. Click the Columns icon.
A pull-down menu appears (refer to Figure 7-21).
4. Click One.

Word removes columns from the current cursor position to the end of
the document.

Previewing a Document before Printing

Before you print your document, you may want to preview how it will look
so you don’t waste paper printing something you can’t use anyway. After
you see that your pages will look perfect, then you can finally print out your
document for everyone to read.

Defining page size and orientation

If you need to print your document on different sizes of paper, you may need
to define the page size and paper orientation. By doing this, Word can accu-
rately show you what your text may look like when printed on an 8.5" x 11"
page compared with an 8.27" x 11.69" page.

To define the Page Size, follow these steps:

1. Click the Page Layout tab.
2. Click the Size icon in the Page Setup group.

A pull-down menu appears, as shown in Figure 7-23.
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Figure 7-23:
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3. Click the page size you want.

Word displays your document based on the new page size.

Normally, Word assumes that you want to print in portrait orientation, where
the height of the paper is larger than its width. However, you may want to
print in landscape orientation, where the height of the paper is smaller than

its width.

To define the orientation, follow these steps:

1. Click the Page Layout tab.

2. Click the Orientation icon in the Page Setup group.

A pull-down menu appears, as shown in Figure 7-24.
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3. Click either Portrait or Landscape orientation.

Word displays your document based on the new paper orientation.
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Figure 7-25:
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Using Print Preview

Print Preview lets you browse through your document so you can see how
every page will look, including any headers and footers, cover pages, and
pictures you may have added. To use Print Preview, follow these steps:

1.

Click the File tab.
The Backstage View appears.

. Click Print.

The Backstage View displays various print settings in the middle
pane and a preview of your document in the right pane, as shown in
Figure 7-25.

. (Optional) Click on the various options in the middle pane, such as

choosing a printer to use or how many copies to print.

. (Optional) Click Next Page/Previous Page or use the vertical scroll bar

to browse through all the pages of your document.

If you drag the Magnifier slider in the bottom-right corner, you can zoom
in or zoom out so you can examine the details of your document.

. Press Esc to return to your document, or click Print to start printing.

You can also start printing by just pressing Ctrl+P.
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In this part . . .

f you need to manipulate numbers for business, scien-

tific, or financial reasons, you can use the most popu-
lar spreadsheet program in the world — Microsoft Excel.
Anyone who has used another version of Excel in the past
will find that Excel 2010 simply provides easier access to
the complicated features buried within Excel’s silicon
brain.

For anyone not familiar with Excel or spreadsheet pro-
grams at all, this part of the book starts with the basics by
explaining what a spreadsheet does, how they work, and
the parts you’ll need to create your own spreadsheet
within Excel.

After you get comfortable with Excel, additional chapters
show you how to create formulas to make Excel do all its
fancy (and accurate) calculations and convert your rows
and columns of numbers into easy to understand pie, line,
and bar charts.

Think of Excel as your personal calculating machine. Just
feed it numbers, define formulas, and Excel cranks
through your numbers to spit out different results so you
can forecast trends, analyze past results, or play “What
if?” games with your numbers such as asking, “What if [
gave myself a 25 percent raise and laid off 3,000 employ-
ees? How would that affect my stock options by increas-
ing profits in the short-term?”

Calculating numbers can be fun, especially when those
numbers represent profits and losses. With the help of
Excel, you can maximize your profits and minimize your
losses, or at least have fun fantasizing about different
results by playing around with Excel.




Chapter 8

The Basics of Spreadsheets:
Numbers, Labels, and Formulas

In This Chapter
Typing and formatting data

Moving around a spreadsheet

Searching a spreadsheet

Editing a spreadsheet

Printing

<MBER

Everyone needs to perform simple math. Businesses need to keep track
of sales and profits, and individuals need to keep track of budgets. In the
old days, people not only had to write down numbers on paper, but they also
had to do all their calculations by hand (or with the aid of a calculator).

That’s why people use Excel. Instead of writing numbers on paper, they can
type numbers on the computer. Instead of adding or subtracting columns or
rows of numbers by hand, Excel can do it for you automatically. Basically,
Excel makes it easy to type and modify numbers and then calculate new
results accurately and quickly.

Besides calculating numbers, spreadsheets can also store lists of data orga-
nized in rows and columns.

Understanding Spreadsheets

Excel organizes numbers in rows and columns. An entire page of rows and
columns is called a spreadsheet or a worksheet. (A collection of one or more
worksheets is stored in a file called a workbook.) Each row is identified by a
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number such as 1 or 249; and each column is identified by letters, such as A,
G, or BF. The intersection of each row and column defines a cell, which con-
tains one of three items:

v Numbers
v Text (labels)

v Formulas

Numbers provide the data, and formulas calculate that data to produce a
useful result, such as adding sales results for the week. Of course, just dis-
playing numbers on the screen may be confusing if you don’t know what
those numbers mean, so labels simply identify what numbers represent.
Figure 8-1 shows the parts of a typical spreadsheet.

Formulas usually appear as numbers, so at first glance, it may be difficult to
tell the difference between ordinary numbers and numbers that represent a
calculation by a formula.

The strength of spreadsheets comes by playing “What-if?” games with your
data, such as “What if [ gave myself a $20-per-hour raise and cut everyone
else’s salary by 25%? How much money would that save the company every
month?” Because spreadsheets can rapidly calculate new results, you can
experiment with different numbers to see how they create different answers.
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Storing Stuff in a Spreadsheet

Every cell can contain a number, a label, or a formula. To type anything into a
spreadsheet, you must first select or click in the cell (or cells) and then type
a number or text.

Typing data into a single cell

To type data in a single cell, follow these steps:

1. Choose one of the following to select a single cell:
e Click a cell.
¢ Press the up/down/right/left arrow keys to highlight a cell.

2. Type a number (such as 34.29 or 198), a label (such as Tax Returns), or
a formula.

You can see how to create formulas in Chapter 9.

Typing data in multiple cells

After you type data in a cell, you can press one of the following four key-
strokes to select a different cell:

v~ Enter: Selects the cell below in the same column

v~ Tab: Selects the cell to the right in the same row

v~ Shift+Enter: Selects the cell above in the same column

v~ Shift+Tab: Selects the cell to the left in the same row
If you type data in cell Al and press Enter, Excel selects the next cell below,

which is A2. If you type data in A2 and press Tab, Excel selects the cell to the
right, which is B2.

However, what if you want to type data in a cell such as Al and then have
Excel select the next cell to the right (B1)? Or what if you want to type data in
cells Al and A2 but then jump back to type additional data in cells B1 and B2?

To make this easy, Excel lets you select a range of cells, which essentially
tells Excel, “See all the cells I just highlighted? I only want to type data in
those cells.” After you select multiple cells, you can type data and press
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Enter. Excel selects the next cell down in that same column. When Excel
reaches the last cell in the column, it selects the top cell of the column to the
right.

To select multiple cells for typing data in, follow these steps:

1. Highlight multiple cells by choosing one of the following:

e Move the mouse pointer over a cell, hold down the left mouse
button, and drag (move) the mouse to highlight multiple cells.
Release the left mouse button when you've selected enough cells.

¢ Hold down the Shift key and press the up/down/right/left arrow
keys to highlight multiple cells. Release the Shift key when you’'ve
selected enough cells.

Excel selects the cell that appears in the upper-left corner of your
selected cells.

2. Type a number, label, or formula.
3. Press Enter.

Excel selects the cell directly below the preceding cell. If the preceding
cell appeared at the bottom of the selected column, Excel highlights the
top cell in the column that appears to the right.

4. Repeat Steps 2 and 3 until you fill your selected cells with data.

5. Click outside the selected cells or press an arrow key to tell Excel not
to select the cells any more.

Typing in sequences with AutoFill

If you need to type the names of successive months or days in a row or
column (such as January, February, March, and so on), Excel offers a short-
cut to save you from typing all the day or month names yourself. With this
shortcut, you just type one month or day and then drag the mouse to high-
light all the adjacent cells. Then Excel types the rest of the month or day
names in those cells automatically.

To use this shortcut, follow these steps:

1. Click a cell and type a month (like January or just Jan) or a day (like
Monday or just Mon).

The Fill Handle, a block box, appears in the bottom-right corner of the
cell.



Chapter 8: The Basics of Spreadsheets: Numbers, Labels, and Formulas ’43

<P You can also type in a sequence of numbers in Step 1. So if you typed
the numbers 2, 4, and 6 in adjacent cells, highlighted all these adjacent
cells, and grabbed the Fill Handle, Excel is smart enough to detect the
pattern and display the numbers 8, 10, and 12 in the next three adjacent
cells.

2. Move the mouse pointer over the Fill Handle until the mouse pointer
turns into a black crosshair icon.

3. Hold down the left mouse button and drag (move) the mouse down a
column or across the row.

As you drag the mouse, Excel automatically types in the remaining
month or day names, as shown in Figure 8-2.

|
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Formatting Numbers and Labels

When you first create a spreadsheet, numbers and labels appear as plain
text. Plain labels might look boring, but plain numbers (such as 8495 or 0.39)
can be difficult to read and understand if the numbers are supposed to repre-
sent currency amounts ($8,495) or percentages (39%).
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To make labels visually interesting and numbers appear more descriptive of
what they actually represent, you need to format your data after you type it
into a spreadsheet.

You can format a cell or range of cells after you've already typed in data or
before you type in any data. If you format cells before typing any data, any
data you type in will appear in your chosen format.

Formatting numbers

To format the appearance of numbers, follow these steps:

1. Select one or more cells by using the mouse or keyboard.

To select multiple cells, drag the mouse or hold the Shift key while
pressing the arrow keys.

2. Click the Home tab.
3. Click the Number Format list box in the Number group.

A pull-down menu appears, as shown in Figure 8-3.
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The Number group also displays three icons that let you format num-
bers as Currency, Percentage, or with Commas in one click, as shown

in Figure 8-4. If you click the downward-pointing arrow to the right of
the Accounting Number Format icon, you can choose different currency
symbols to use, such as $, §, or €.
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4. Click a number format style, such as Percentage or Scientific.

Excel displays your numbers in your chosen format.
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Displaying negative numbers
Because many people use spreadsheets for business, they often want nega-
tive numbers to appear highlighted so they can see them easier. Excel can

display negative numbers in parentheses (-23) or in red so you can’t miss
them.

To define how negative numbers appear in your spreadsheet, follow these
steps:
1. Select the cell or range of cells that you want to modify.
2. Click the Home tab.
3. Click the Format icon in the Cells group.
A menu appears, as shown in Figure 8-5.
4. Choose Format Cells.
The Format Cells dialog box appears, as shown in Figure 8-6.
5. Choose Currency or Number from the Category list.

&,N\BEH You can choose how to format negative numbers only if you format your
& numbers by using the Currency or Number category.

6. Click a negative number format and then click OK.

If any of your numbers become negative in the cell or cells you selected
in Step 1, Excel automatically displays those negative numbers in the
negative number format you chose.
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Figure 8-5:
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If you format cells to display numbers with decimal places, such as 23.09 or
23.09185, you can modify how many decimal places appear. To define the
number of decimal places, follow these steps:

1. Select the cell or cells that contain the numbers you want to format.

2. Click the Home tab.
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3. Click in the Number Format list box (refer to Figure 8-3) and choose a
format that displays decimal places, such as Number or Percentage.

Excel formats the numbers in your chosen cells.
<P You can click the Increase Decimal (increases the number of decimal places

displayed) or Decrease Decimal icon (decreases the number of decimal places
displayed) in the Number group on the Home tab, as shown in Figure 8-7.
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Formatting cells

To make your data look prettier, Excel can format the appearance of cells
to change the font, background color, text color, or font size used to display
data in a cell.

Excel provides two ways to format cells: You can use Excel’s built-in format-
ting styles, or you can apply different types of formatting individually. Some
of the individual formatting styles you can choose include

v Font and font size

v Text styles (underlining, italic, and bold)

v Text and background color

v Borders

v Alignment

v Text wrapping and orientation
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Formatting cells with built-in styles
Excel provides a variety of predesigned formatting styles that you can apply

to one or more cells. To format cells with a built-in style, follow these steps:
1. Select the cell or cells that you want to format with a built-in style.
2. Click the Home tab.
3. Click the Cell Styles icon in the Styles group.

A pull-down menu appears listing all the different styles you can choose,
as shown in Figure 8-8.

4. Move the mouse pointer over a style.

Excel displays a Live Preview of how your selected cells will look with
that particular style.

5. Click the style you want.

Excel applies your chosen style to the selected cells.
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Formatting fonts and text styles

Different fonts can emphasize parts of your spreadsheet, such as using one
font to label columns and rows and another font or font size to display the
actual data. Text styles (bold, underline, and italic) can also emphasize data
that appears in the same font or font size.

To change the font, font size, and text style of one or more cells, follow these
steps:
1. Select the cell or cells that you want to change the font and font size.
2. Click the Home tab.
3. Click the Font list box.

A pull-down menu of different fonts appears.
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4. Click the font you want to use.
5. Choose one of the following methods to change the font size:

¢ Click the Font Size list box and then choose a font size, such as 12
or 16.

¢ Click the Font Size list box and type a value such as 7 or 15.

¢ Click the Increase Font Size or Decrease Font Size icon until your
data appears in the size you want.

6. Click one or more text style icons (Bold, Italic, Underline).

Formatting with color

Each cell displays data in a Font color and a Fill color. The Font color defines
the color of the numbers and letters that appear inside a cell. (The default
Font color is black.) The Fill color defines the color that fills the background
of the cell. (The default Fill color is white.)

To change the Font and Fill colors of cells, follow these steps:

1. Select the cell or cells that you want to color.
2. Click the Home tab.

3. Click the downward-pointing arrow that appears to the right of the
Font Color icon.

A color palette appears, as shown in Figure 8-9.
4. Click the color you want to use for your text.

<P The color you select appears directly on the Font Color icon. The next
time you want to apply this same color to a cell, you can click the Font
Color icon directly instead of the downward-pointing arrow to the right
of the Font Color icon.
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Figure 8-10:
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Click the downward-pointing arrow that appears to the right of the Fill
Color icon.

A color palette appears.

. Click a color to use to fill the background of your cell.

The color you select appears directly on the Fill Color icon. The next
time you want to apply this same color to a cell, you can click the Fill
Color icon directly instead of the downward-pointing arrow to the right
of the Fill Color icon.

Adding borders

For another way to highlight one or more cells, you can add borders. Borders
can surround the entire cell or just the top, bottom, left, or right side of a

cell.

To add borders to a cell, follow these steps:

1. Select one or more cells.
2. Click the Home tab.

3. Click the downward-pointing arrow to the right of the Border icon.

A pull-down menu appears, as shown in Figure 8-10.

. Click a border style.

Excel displays your chosen borders around the cells you selected in
Step 1.
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Navigating a Spreadsheet

If you have a large spreadsheet, chances are good that information may be
hidden by the limitations of your computer screen. To help you view and
select cells in different parts of your spreadsheet, Excel offers various ways
to navigate a spreadsheet by using the mouse and keyboard.

Using the mouse to move
around in a spreadsheet

To navigate a spreadsheet with the mouse, you can click the scroll bars or
use the scroll wheel, on your mouse, if you have one. To use the scroll bars,
you have three choices:

v Click the up/down or right/left arrows on the horizontal or vertical
scroll bars.

This moves the spreadsheet one row (up or down) or column (right or
left) at a time.

v~ Drag the scroll box of a scroll bar.

v Click the scroll area (any area to the left/right or above/below the
scroll box on the scroll bar).

This moves the spreadsheet one screen left/right or up/down.

If your mouse has a scroll wheel, you can use this wheel to move through a
spreadsheet by two methods:

+* Roll the mouse’s scroll wheel up or down to scroll your spreadsheet up
or down.

v Press the scroll wheel to display a four-way pointing arrow, and then
move the mouse up, down, right, or left. (When you’re done, click the
scroll wheel again.)

Using the keyboard to move
around a spreadsheet

Using the mouse can be faster to jump from one place in a spreadsheet to
another, but sometimes using the mouse can be frustrating, trying to line it
up just right. For that reason, you can also use the keyboard to move around
a spreadsheet. Some of the common ways to move around a spreadsheet are
shown in Table 8-1.
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Table 8-1

Using the Keyboard to Navigate a Spreadsheet

Pressing This

Does This

Up arrow (T)

Moves up one row

Down arrow ({)

Moves down one row

Left arrow (<)

Moves left one column

Right arrow (—)

Moves right one column

Ctrl+T

Jumps up to the top of a column that contains data

Ctrl+d Jumps down to the bottom of a column that contains data
Ctrl+<— Jumps to the left of a row that contains data

Ctrl+— Jumps to the right of a row that contains data

Page Up Moves up one screen

Page Down Moves down one screen

Ctrl+Page Up Displays the previous worksheet

Ctrl+Page Down

Displays the next worksheet

Home Moves to the A column of the current row
Ctrl+Home Moves to the A1 cell
Ctrl+End Moves to the bottom-right cell of your spreadsheet

If you know the specific cell you want to move to, you can jump to that cell
by using the Go To command. To use the Go To command, follow these
steps:
1. Click the Home tab.
2. Click the Find & Select icon in the Editing group.
A pull-down menu appears.
3. Click Go To.
W The Go To dialog box appears, as shown in Figure 8-11.
You can also choose the Go To command by pressing Ctrl+G.

4. Click in the Reference text box and type the cell you want to move to,
such as C13 or F4.

5. Click OK.
Excel highlights the cell you typed in Step 4.
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Naming cells

One problem with the Go To command is that most people won’t know which
cell contains the data they want to find. For example, if you want to view the
cell that contains the total amount of money you owe for your income taxes,
you probably don’t want to memorize that this cell is G68.

To help you identify certain cells, Excel lets you give them descriptive names.
To name a cell or range of cells, follow these steps:
1. Select the cell or cells that you want to name.

2. Click in the Name box, which appears directly above the A column
heading, as shown in Figure 8-12.

3. Type a descriptive name without any spaces and then press Enter.
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After you name a cell, you can jump to it quickly by following these steps:

1. Click the downward-pointing arrow to the right of the Name box.
A list of named cells appears.
2. Click the named cell you want to view.
Excel displays your chosen cell.
Eventually, you may want to edit or delete a name for your cells. To delete or
edit a name, follow these steps:
1. Click the Formulas tab.
2. Click the Name Manager icon.
The Name Manager dialog box appears, as shown in Figure 8-13.
3. Edit or delete the named cell as follows:

¢ To edit the name, click the cell name you want to edit and then
click the Edit button. An Edit Name dialog box appears, where you
can change the name or the cell reference.

¢ To delete the name, click the cell name you want to delete and
then click the Delete button.

4. Click Close.

Name Manager [TIE=
T ) [ ] (oo Coe)
Mame Value Refers To Scope Comment
T A
|
Figure 8-13:
The Name
Manager
dialog box
lets you
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dE|Ete Rehers bo:
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Searching a Spreadsheet

Rather than search for a specific cell, you may want to search for a particular
label or number in a spreadsheet. Excel lets you search for the following:

v Specific text or numbers

v~ All cells that contain formulas

v All cells that contain conditional formatting

Searching for text

You can search for a specific label or number anywhere in your spreadsheet.
To search for text or numbers, follow these steps:

1. Click the Home tab.
2. Click the Find & Select icon in the Editing group.
A pull-down menu appears.
3. Click Find.
A3 The Find and Replace dialog box appears, as shown in Figure 8-14.

If you click the Replace tab, you can define the text or number to find
and new text or numbers to replace it.

4. Click in the Find What text box and type the text or number you want

to find.
|
Figure 8-14: | Find and Replace =
The Find Frd | Reglsce
and Replace | | Fodwhat: | =
dialog box
lets you Options >>
search your : —
worksheet. | Fidal | Firnd et L‘
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If you click the Options button, the Find and Replace dialog box expands
to provide additional options for searching, such as searching in the dis-
played sheet or the entire workbook.

5. Click one of the following:

e Find Next: Finds and selects the first cell, starting from the cur-
rently selected cell that contains the text you typed in Step 4

¢ Find All: Finds and lists all cells that contain the text you typed in
Step 4, as shown in Figure 8-15

6. Click Close to make the Find and Replace dialog box go away.
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Searching for formulas

Formulas appear just like numbers; to help you find which cells contain for-
mulas, Excel gives you two choices:

v Display formulas in your cells (instead of numbers)

v~ Highlight the cells that contain formulas
To display formulas in a spreadsheet, press Ctrl+* (an accent grave charac-
ter, which appears on the same key as the ~ sign and often appears to the left

of the number 1 key near the top of a keyboard). Figure 8-16 shows what a
spreadsheet looks like when formulas appear inside of cells.

To highlight all cells that contain formulas, follow these steps:

1. Click the Home tab.
2. Click the Find & Select icon in the Editing group.
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Figure 8-16:
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A pull-down menu appears.
3. Click Formulas.

Excel highlights all the cells that contain formulas.

A B C o]
1 1st Quarter Sal¢
2 Jan Feb Tl
3 Mike Daum 70.9 46,92 G271
4 Leo Fontaine 83.86 102.7 65.39
5 Matalie Smith 53.04 68,47 100,98
& LK williame 100.45 1l a1 54
7 Darrall Inyre AR 48 A5.37 7h.39
& BukKale 77.43 63,48 38.6
9 Douglames 40,90 59.65 00,05
10 Total = =SUR(B3:89) =SUM(C3:C9) =SUM(D2D3) |
11 ‘

Formulas

Editing a Spreadsheet

SMBER
o

The two ways to edit a spreadsheet are
v Edit the data itself, such as the labels, numbers, and formulas that make
up a spreadsheet.

v~ Edit the physical layout of the spreadsheet, such as adding or deleting
rows and columns, or widening or shrinking the width or height of rows
and columns.

Editing data in a cell

To edit data in a single cell, follow these steps:

1. Double-click the cell that contains the data you want to edit.
Excel displays a cursor in your selected cell.

2. Edit your data by using the Backspace or Delete key, or by typing new
data.

If you click a cell, Excel displays the contents of that cell in the Formula bar.
You can click and edit data directly in the Formula bar, which can be more
convenient for editing large amounts of data such as a formula.
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Changing the size of rows and
columns with the mouse

Using the mouse can be a quick way to modify the sizes of rows and columns.
To change the height of a row or the width of a column, follow these steps:

1. Move the mouse pointer over the bottom line of a row heading, such
as the 2 or 18 heading. (Or move the mouse pointer over the right line
of the column heading, such as A or D.)

The mouse pointer turns into a two-way pointing arrow.
2. Hold down the left mouse button and drag (move) the mouse.
Excel resizes your row or column.

3. Release the left mouse button when you’re happy with the size of your
row or column.

Typing the size of rows and columns

If you need to resize a row or column to a precise value, it’s easier to type
a specific value into the Row Height or Column Width dialog box instead.
To type a value into a Row Height or Column Width dialog box, follow these
steps:
1. Click the Home tab.
2. Click the row or column heading that you want to resize.
Excel highlights your entire row or column.
3. Click the Format icon that appears in the Cells group.
A pull-down menu appears, as shown in Figure 8-17.

4. Click Height (if you selected a row) or Width (if you selected a
column).

The Row Height or Column Width dialog box appears.
5. Type a value and then click OK.
Excel resizes your row or column.
Excel measures column width in characters. (A cell defined as 1 character

width can display a single letter or number.) Excel measures row height by
points where 1 point equals 1’72 inch.
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Adding and deleting rows and columns

After you type in labels, numbers, and formulas, you may suddenly real-
ize that you need to add or delete extra rows or columns. To add a row or
column, follow these steps:

1. Click the Home tab.

2. Click the row or column heading where you want to add another row
or column.

Excel highlights the entire row or column.

3. Click the Insert icon in the Cells group.
Inserting a row adds a new row above the selected row. Inserting a
column adds a new column to the left of the selected column.

To delete a row or column, follow these steps:

1. Click the Home tab.
2. Click the row or column heading that you want to delete.

3. Click the Delete icon in the Cells group.

Deleting a row or column deletes any data stored in that row or column.
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Adding sheets

For greater flexibility, Excel lets you create individual spreadsheets that you
can save in a single workbook (file). When you load Excel, it automatically
provides you with three sheets, but you can add more if you need them.

To add a new sheet, choose one of the following:

1 Click the Insert Worksheet icon that appears to the right of your exist-
ing tabs (or press Shift+F11).

v Click the Home tab, click the downward-pointing arrow next to the
Insert icon in the Cells group, and then choose Insert Sheet, as shown
in Figure 8-18.
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Renaming sheets

By default, Excel gives each sheet a generic name such as Sheetl. To give
your sheets a more descriptive name, follow these steps:
1. Choose one of the following:
e Double-click the sheet tab that you want to rename.
Excel highlights the entire sheet name.

e Click the sheet tab you want to rename, click the Home tab, click the
Format icon in the Cells group, and choose Rename Sheet.

® Right-click the sheet tab you want to rename; when a pop-up menu
appears, choose Rename.

2. Type a new name for your sheet and press Enter when you’re done.

Your new name appears on the sheet tab.

Rearranging sheets

You can rearrange the order that your sheets appear in your workbook. To
rearrange a sheet, follow these steps:
1. Move the mouse pointer over the sheet tab that you want to move.
2. Hold down the left mouse button and drag (move) the mouse.

The downward-pointing black arrow points where Excel will place your
sheet.

3. Release the left mouse button to place your sheet in a new order.

Deleting a sheet

Using multiple sheets may be handy, but you may want to delete a sheet if
you don’t need it.

If you delete a sheet, you also delete all the data stored on that sheet.
To delete a sheet, follow these steps:

1. Click on the sheet that you want to delete.
2. Choose one of the following:

® Right-click the tab of the sheet you want to delete. When a pop-up
menu appears, click Delete.

101
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e Click the Home tab, click the downward-pointing arrow that appears
to the right of the Delete icon in the Cells group, and choose Delete
Sheet.

If your sheet is empty, Excel deletes the sheet right away. If your sheet
contains data, a dialog box appears to warn you that you’ll lose any data
stored on that sheet.

3. Click Delete.

Excel deletes your sheet along with any data on it.

Clearing Data

After you create a spreadsheet, you may need to delete data, formulas, or
just the formatting that defines the appearance of your data. To clear out one
or more cells of data, formatting, or both data and formatting, follow these
steps:

1. Click the Home tab.
2. Select the cell or cells that contain the data you want to clear.

3. Click the downward-pointing arrow to the right of the Clear icon in
the Editing group.

A pull-down menu appears, as shown in Figure 8-19.
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4. Choose one of the following:

e Clear All: Deletes the data and any formatting applied to that cell
or cells

e Clear Formats: Leaves the data in the cell but strips away any for-
matting
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e Clear Contents: Leaves the formatting in the cell but deletes the
data

e Clear Comments: Leaves data and formatting but deletes any com-
ments added to the cell

e Clear Hyperlinks: Leaves data and formatting but deletes any
hyperlinks connecting one cell to another cell

Printing Workbooks

After you create a spreadsheet, you can print it out for others to see. When
printing spreadsheets, you need to take special care how your spreadsheet
appears on a page because a large spreadsheet will likely get printed on two
or more sheets of paper.

This can cause problems if an entire spreadsheet prints on a one page but a
single row of numbers appears on a second page, which can make reading

and understanding your spreadsheet data confusing. When printing spread-
sheets, take time to align your data so that it prints correctly on every page.

Using Page Layout view

Excel can display your spreadsheets in two ways: Normal view and Page
Layout view. Normal view is the default appearance, which simply fills your
screen with rows and columns so you can see as much of your spreadsheet
as possible.

Page Layout view displays your spreadsheet exactly as it will appear if you
print it. Not only can you see where your page breaks occur, but you can also
add any headers to the top of your spreadsheet.

To switch back and forth from Normal view to Page Layout view, follow these
steps:

1. Click the View tab.

2. Click the Normal or Page Layout View icon in the Workbook Views

" group, as shown in Figure 8-20.

o‘
You can also click the Normal or Page Layout View icons in the bottom-right
corner of the Excel window.
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Adding a header (or footer)

Headers and footers are useful when printing out your spreadsheet. A header
may explain the information in the spreadsheet, such as 2012 Tax Return
Information, and a footer may display page numbers. To create a header or
footer, follow these steps:

1. Click the Insert tab.
2. Click the Header & Footer icon in the Text group.

Excel displays the Design tab and creates a text box for your header and
footer, as shown in Figure 8-21.
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3. Type your header text in the header text box.
4. Click the Go To Footer icon in the Navigation group.
Excel displays your footer text box.

" 5. Type your footer text in the footer text box.
h\

If you switch to Page Layout view, you can click directly in the header or
footer box at the top or bottom of the page.

Printing gridlines

Gridlines appear on the screen to help you align data in rows and columns.
However, when you print your worksheet, you can choose to omit gridlines
or print them to make your data easier to understand.

To print gridlines and/or row and column headings, follow these steps:

1. Click the Page Layout tab.
2. (Optional) Select the Print check box under the Gridlines category.
3. (Optional) Select the Print check box under the Heading category.

Defining a print area

Sometimes you may not want to print your entire spreadsheet but just a
certain part of it, called the print area. To define the print area, follow these
steps:

1. Select the cells that you want to print.
2. Click the Page Layout tab.
3. Click the Print Area icon in the Page Setup group.

A pull-down menu appears, as shown in Figure 8-22.
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4. Choose Set Print Area.
Excel displays a dotted line around your print area.
5. Click the File tab and then click Print.
A print preview image of your chosen print area appears.
6. Click Print.
After you define a print area, you can see which cells are part of your print

area by clicking the downward-pointing arrow of the Name box and choosing
Print_Area.

After you define a print area, you can always add to it by following these steps:

1. Select the cells adjacent to the print area.
2. Click the Page Layout tab.
3. Click the Print Area icon in the Page Setup group.

A pull-down menu appears.

4. Choose Add to Print Area.

Excel displays a dotted line around your newly defined print area.
After you define the print area, you can always remove it by following these
steps:

1. Click the Page Layout tab.
2. Click Print Area.
A pull-down menu appears (refer to Figure 8-22).

3. Choose Clear Print Area.

Inserting (and removing) page breaks

One problem with large spreadsheets is that when you print them out, parts
may get cut off when printed on separate pages. To correct this problem, you
can tell Excel exactly where page breaks should occur.

To insert page breaks, follow these steps:
1. Move the cursor in the cell to define where the vertical and horizontal
page breaks will appear.
2. Click the Page Layout tab.
3. Click the Breaks icon in the Page Setup group.

A pull-down menu appears, as shown in Figure 8-23.
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4. Choose Insert Page Break.

Excel inserts a horizontal page directly above the cell you selected in
Step 1 and a vertical page break to the left of that cell, too.

To remove a page break, follow these steps:

1. Choose one of the following:

e To remove a horizontal page break: Click in any cell that appears
directly below that horizontal page break.

e To remove a vertical page break: Click in any cell that appears
directly to the right of that horizontal page break.

¢ To remove both a vertical and horizontal page break: Click in the
cell that appears to the right of the vertical page break and directly
underneath the horizontal page break.

2. Click the Page Layout tab.

3. Click the Breaks icon in the Page Setup group.
A pull-down menu appears (refer to Figure 8-23).

4. Choose Remove Page Break.

Excel removes your chosen page break.

Printing row and column headings

If you have a large spreadsheet that fills two or more pages, Excel may print
your spreadsheet data on separate pages. Although the first page may print
your labels to identify what each row and column may represent, any addi-
tional pages that Excel prints won’t bear those same identifying labels. As a
result, you may wind up printing rows and columns of numbers without any
labels that identify what those numbers mean.

167
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To fix this problem, you can define labels to print on every page by following
these steps:
1. Click the Page Layout tab.
2. Click the Print Titles icon in the Page Setup group.
The Page Setup dialog box appears, as shown in Figure 8-24.
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3. Click the Collapse/Expand button that appears to the far right of the
Rows to Repeat at Top text box.

The Page Setup dialog box shrinks.

4. Click in the row that contains the labels you want to print at the top of
every page.

5. Click the Collapse/Expand button again.
The Page Setup dialog box reappears.

6. Click the Collapse/Expand button that appears to the far right of the
Columns to Repeat at Left text box.

The Page Setup dialog box shrinks.

7. Click in the column that contains the labels you want to print on the
left of every page.

8. Click the Collapse/Expand button again.
The Page Setup dialog box reappears.
9. Click OK.
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Def g prin tmq marqgins
To help you squeeze or expand your spreadsheet to fill a printed page, you
can define different margins for each printed page. To define margins, follow
these steps:
1. Click the Page Layout tab.
2. Click the Margins icon in the Page Setup group.
A pull-down menu appears, as shown in Figure 8-25.

MLSTy, 3. Choose a page margin style you want to use.
D %

If you choose Custom Margins in Step 3, you can define your own margins for
a printed page.
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Defining paper ovientation and size

Paper orientation can be either landscape (the paper width is greater than its
height) or portrait mode (the paper width is less than its height). Paper size
defines the physical dimensions of the page.

To change the paper orientation and size, follow these steps:

1. Click the Page Layout tab.

2. Click the Orientation icon in the Page Setup group.
A pull-down menu appears.

3. Choose Portrait or Landscape.

4. Click the Size icon in the Page Setup group.
A pull-down menu appears, as shown in Figure 8-26.

5. Click a paper size.
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Printing in Excel

When you finish defining how to print your spreadsheet, you’ll probably want
to print it eventually. To print a worksheet, follow these steps:

1. Click the File tab.
The Backstage View appears.
2. Click Print.
The Print Preview appears in the right pane.

3. Click the Print icon near the top of the middle pane.



Chapter 9
Playing with Formulas

In This Chapter
Creating formulas
Using functions
Editing formulas
Conditional formatting
Manipulating data with goal seeking
Creating multiple scenarios
Auditing formulas
Validating data

mat makes Excel useful is its ability to manipulate data by using for-
mulas. Formulas can be as simple as adding two or more numbers

together or as complicated as calculating a second-order differential equation.

Formulas use data, stored in other cells, to calculate a new result that
appears in another cell. To create even more complicated spreadsheets, you
can even make a formula use data from other formulas so that changes in a
single cell can ripple throughout an entire spreadsheet.

Creating a Formula

Formulas consist of three crucial bits of information:

»* An equal sign (=)

v One or more cell references

v The type of calculation to do on the data (addition, subtraction, and so on)
A cell reference is simply the unique row and column heading that identifies
a single cell, such as A4 or D9. The four common calculations that a formula

can use are addition (+), subtraction (-), multiplication (*), and division (/).
Table 9-1 lists other mathematical operators you can use in a formula.
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Table 9-1 Common Mathematical Operators

Used to Create Formulas
Operator What It Does Example Result
+ Addition =5+3.4 8.4
- Subtraction =54.2-2.1 52.1
* Multiplication =1.2*4 48
/ Division =25/5 5
% Percentage =42% 0.42
A Exponentiation =473 64
= Equal =6=7 False
> Greater than =7>2 True
< Less than =9<8 False
>= Greater than or equal to =45>=3 True
<= Less than or equal to =40<=2 False
<> Not equal to =5<>7 True
& Text concatenation ="Bo the “& Bo the Cat

“Cat”

A simple formula uses a single mathematical operator and two cell references
such as:

=A4+C7
This formula consists of three parts:

v The = sign: This identifies your formula. If you type just A4+C7 into a
cell, Excel treats it as ordinary text.
v+ Two cell references: In this example, A4 and C7.

v+ The addition (+) mathematical operator.
To type a formula in a cell, follow these steps:

1. Click in the cell where you want to store the formula.
You can also select a cell by pressing the arrow keys.

Excel highlights your selected cell.
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2. Type the equal sign (=).
This tells Excel that you are creating a formula.

3. Type your formula that includes one or more cell references that iden-
tify cells that contain data, such as A4 or ES.

For example, if you want to add the numbers stored in cells A4 and E8,
you would type =A4+ES8.

4. Press Enter.
Typing cell references can get cumbersome because you have to match the
row and column headings of a cell correctly. As a faster alternative, you can

use the mouse to click any cell that contains data; then Excel types that cell
reference into your formula automatically.

To use the mouse to click cell references when creating a formula, follow
these steps:

1. Click in the cell where you want to store the formula. (You can also
select the cell by pressing the arrow keys.)
Excel highlights your selected cell.

2. Type the equal sign (=).

This tells Excel that anything you type after the equal sign is part of your
formula.

3. Type any mathematical operators and click any cells that contain
data, such as A4 or ES.

If you want to create the formula =A4+E8, you would do the following:
a. Type =.
This tells Excel that you're creating a formula.
b. Click cell A4.
Excel types the A4 cell reference in your formula automatically.
c. Type +.
d. Click cell ES.
Excel types in the E8 cell reference in your formula automatically.
4. Press Enter.

After you finish creating a formula, you can type data into the cell references
used in your formula to calculate a new result.
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Organizing formulas with parentheses

Formulas can be as simple as a single mathematical operator such as =D3*E4.
However, you can also use multiple mathematical operators, such as

=A4+A5*C7/F4+D9

There are two problems with using multiple mathematical operators. First,
they make a formula harder to read and understand. Second, Excel calcu-
lates mathematical operators from left to right, based on precedence, which
means a formula may calculate results differently than you intended.

Precedence tells Excel which mathematical operators to calculate first, as
listed in Table 9-2. For example, Excel calculates multiplication before it cal-
culates addition. If you had a formula like

=A3+A4*B4+B5

Excel first multiplies A4*B4 and then adds this result to A3 and B5.

Table 9-2 Operator Precedence in Excel
Mathematical Operator Description

:(colon) Reference operators
(single space)

, (comma)

- Negation

% Percent

A Exponentiation

* Multiplication and division
/

+ Addition and subtraction
& Text concatenation
=<><=>=< Comparison

Typing parentheses around cell references and mathematical operators not
only organizes your formulas, but also tells Excel specifically how you want to
calculate a formula. In the example =A3+A4*B4+B5, Excel multiplies A4 and B4
first. If you want Excel to first add A3 and A4, then add B4 and B5, and finally
multiply the two results together, you have to use parentheses, like this:

=(A3+A4)*(B4+B5)
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Copying formulas

In many spreadsheets, you may need to create similar formulas that use dif-
ferent data. For example, you may have a spreadsheet that needs to add the
same number of cells in adjacent columns.

You could type nearly identical formulas in multiple cells, but that’s tedious
and error-prone. For a faster way, you can copy a formula and paste it in
another cell; then Excel automatically changes the cell references, as shown
in Figure 9-1.
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Home = Inset  Pagelmwoat  Formulas  Dala  Review  View @ =@ B

A - = : - ) E- 3
4 L
B 1 \ | EE S $ . Find %
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a B c [ E F G H | ' K l M N =

1st Quarter Sales Results
Jari Fieh Mar
Mike Baum 0.9 4693 GLTL
i leoFortaine | B3g8] 1047 6439
Natalic Smith _5_31:1 68.47  100.98
Darrell Inyor BE.43) 8537 A9
B0 Katz 7743 69.40 0.6
Douglames | amgg] 5965 BLES

Tatal =|..‘z+!\ﬁ+R'.:|

wle el s wae

il

From Figure 9-1, you can see that cell B9 contains the formula
=B3+B4+B5+B6+B7+B8, which simply adds the numbers stored in the six
cells directly above the cell that contains the formula (B9). If you copy this
formula to another cell, that new formula will also add the six cells directly
above it. Copy and paste this formula to cell C9, and Excel changes the for-
mula to =C3+C4+C5+C6+C7+C8.

To copy and paste a formula so that each formula changes cell references
automatically, follow these steps:

1. Select the cell that contains the formula you want to copy.

2. Press Ctrl+C (or click the Copy icon under the Home tab).

Excel displays a dotted line around your selected cell.
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A\ 3. Select the cell (or cells) where you want to paste your formula.

If you select multiple cells, Excel pastes a copy of your formula in each
of those cells.

4. Press Ctrl+V (or click the Paste icon under the Home tab).
Excel pastes your formula and automatically changes the cell references.

5. Press Esc or double-click away from the cell with the dotted line to
make the dotted line go away.

Using Functions

Creating simple formulas is easy, but creating complex formulas is hard. To
make complex formulas easier to create, Excel comes with prebuilt formulas
called functions. Table 9-3 lists some of the many functions available.

Table 9-3 Common Excel Functions

Function What It Does

Name

AVERAGE Calculates the average value of numbers stored in two or more cells
COUNT Counts how many cells contain a number instead of a label (text)
MAX Finds the largest number stored in two or more cells

MIN Finds the smallest number stored in two or more cells

ROUND Rounds a decimal number to a specific number of digits

SQRT Calculates the square root of a number

SUM Adds the values stored in two or more cells

Excel literally provides hundreds of functions that you can use by themselves
or as part of your own formulas. A function typically uses one or more cell
references:

v~ Single cell references, such as =ROUND(C4,2), which rounds the
number found in cell C4 to two decimal places

v Contiguous (adjacent) cell ranges, such as =SUM(A4:A9), which adds all
the numbers found in cells A4, A5, A6, A7, A8, and A9

+ Noncontiguous cell ranges, such as =SUM(A4,B7,C11), which adds all
the numbers found in cells A4, B7, and C11
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To use a function, follow these steps:

1. Click in the cell where you want to create a formula using a function.

2. Click the Formulas tab.

3. Click one of the following function icons in the Function Library

group:

e Financial: Calculates business-related equations, such as the
amount of interest earned over a specified time period

¢ Logical: Provides logical operators to manipulate True and False
(also known as Boolean) values

e Text: Searches and manipulates text

¢ Date & Time: Provides date and time information

e Lookup & Reference: Provides information about cells, such as

their row headings

® Math & Trig: Offers mathematical equations

* More Functions: Provides access to statistical and engineering

functions

4. Click a function category, such as Financial or Math & Trig.

A pull-down menu appears, as shown in Figure 9-2.

Zid o~ T

P

Home Inset

Ingest

Tunction i Fmands = [0 vate o time - I More Tunctions -

ALCKINT
ACCRINTM
BMORDLGRL
AMOREING
COUPDAYES
COUPDAKS
COUPDAYSNG
COUPNCD
COUPNUM
COURRCD
CUNMIPMT
CUMPRING
oR

oo

nise
DOLARDE
DOLLARS R
DURATION

LT

S Insemundtion..,

Fage Layout
E mutosum + [ Logial -

[ Recenty Used = [ Tt -

Testsheet - Microsoft Excel o @ R
Feview  View s @@
0 Define Hame - S Trave Precedents ) Show Formulas 1 - 3
7 Wse in Farmuls = o({ Trace Dependents ¥ Dmor Checking = ©°
Mame 4 watcn | Calaulation [

Manaqer B Creste from Selection | 74 Remowe Amows + (5] Dvaluste FOrMUIE  wwingaw  Options -

Furmuls Auditing Cabeulativn

177



’ 78 Part lll: Playing the Numbers with Excel

|
Figure 9-3:
Specify
which cell
references
contain the
data your
function
needs to
calculate a
result.
|

5. Click a function.
The Function Arguments dialog box appears, as shown in Figure 9-3.
6. Click the cell references you want to use.
7. Repeat Step 6 as many times as necessary.
8. Click OK.

Excel displays the calculation of your function in the cell you selected in

Step 1.
Function Arguments v IEE
AMORDEGR.C
Lost | | =
Date_purchased Tl -
First_period E| -
Salvaye 1| =
Pernd ?| = =
Returns the prorabed linear depreciation ot an asset For each accounting period.
Cost s the cost of the asset.
Formula resul =
ledp on this function OK | Cancel

Using the AutoSum command

One of the most useful and commonly used command is the AutoSum com-

mand. The AutoSum command uses the SUM function to add two or more cell
references without making you type those cell references yourself. The most
common use for the AutoSum function is to add a column or row of numbers.

To add a column or row of numbers with the AutoSum function, follow these
steps:

1. Create a column or row of numbers that you want to add.

2. Click at the bottom of the column or the right of the row.

3. Click the Formulas tab.

4. Click the AutoSum icon in the Function Library group.

Excel automatically creates a SUM function in the cell you chose in Step
2 and highlights all the cells where it will retrieve data to add, as shown
in Figure 9-4. (If you accidentally click the downward-pointing arrow

under the AutoSum icon, a pull-down menu appears. Just choose Sum.)
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5. Press Enter.

Excel automatically sums all the cell references.

The AutoSum icon also appears on the Home tab in the Editing group.

Using recently used functions

Digging through all the different function library menus can be cumbersome,
so Excel tries to make your life easier by creating a special Recently Used
list that contains (what else?) a list of the functions you've used most often.
From this menu, you can see just a list of your favorite functions and ignore
the other hundred functions that you may never need in a million years.

To use the list of recently used functions, follow these steps:

1. Click the cell where you want to store a function.

2. Click the Formulas tab.

3. Click the Recently Used icon in the Function Library group.
A pull-down menu appears, as shown in Figure 9-5.

4. Choose a function.

The more functions you use, the more your list will vary from what you see in
Figure 9-5.
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Editing a Formula

After you create a formula, you can always edit it later. You can edit a for-
mula in two places:
v In the Formula bar

v In the cell itself
To edit a formula in the Formula bar, follow these steps:

1. Select the cell that contains the formula you want to edit.
Excel displays the formula in the Formula bar.

2. Click in the Formula bar and edit your formula by using the
Backspace and Delete keys.

To edit a formula in the cell itself, follow these steps:

1. Double-click in the cell that contains the formula you want to edit.
Excel displays a cursor in the cell you selected.
2. Edit your formula by using the Backspace and Delete keys.
<P Because formulas display their calculations in a cell, it can be hard to tell the
difference between cells that contain numbers and cells that contain formu-

las. To make formulas visible, press Ctrl+™ (an accent grave character, which
appears on the same key as the ~ symbol).
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A formula in a cell can display a variety of values, depending on the data that
the formula receives. Because a formula can display any type of a number,
you might want to use conditional formatting as a way to highlight certain
types of values.

Suppose you have a formula that calculates your monthly profits. You can
change the formatting to emphasize the results:

v If your result is zero or a loss, display that value in red.

v If you make a profit under $1,000, display that value in yellow.

v~ If the profit is at least $100,000, display that value in green.

Conditional formatting simply displays data in a formula in various ways,
depending on the value that the formula calculates.

Comparing data values

The simplest type of conditional formatting displays different colors or icons
based on adjacent values, which makes it easy to compare, at a glance, differ-
ent numbers.

Excel offers three types of conditional formatting for identifying values, as
shown in Figure 9-6:

v~ Data Bars: Higher values display more color while lower values display
less color.
v Color Scales: Different colors identify different ranges of values.

v~ Icon Sets: Different icons identify different ranges of values.
To apply conditional formatting, follow these steps:

1. Select the cells that you want to apply conditional formatting.

2. Click the Home tab and then click the Conditional Formatting icon in
the Styles group.

A menu appears (refer to Figure 9-6).
3. Move the mouse over Data Bars, Color Scales, or Icon Sets.

A menu appears.
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4. Click on the type of conditional formatting you want.

Excel applies your conditional formatting over the cells you chose in
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Creating conditional formatting rules

Using colors or icons to identify ranges of values might be nice, but you may
want to define your own rules for how conditional formatting should work,
such as displaying all negative values in red and all values above 1,000 in
green.

To define your own rules for formatting values, follow these steps:

1. Select the cells that you want to apply conditional formatting.

2. Click the Home tab and then click the Conditional Formatting icon in
the Styles group.

A menu appears (refer to Figure 9-6).
3. Move the mouse over Highlight Cells Rules.
A menu appears, as shown in Figure 9-7.
4. Click on an option such as Greater Than or Between.

A dialog box appears, which lets you define one or more values and
choose a color for formatting your selected cells, as shown in Figure 9-8.
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5. Type a value, choose a color for formatting, and click OK.

Excel displays conditional formatting only to those selected cells that
meet the criteria you defined.
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If you click the Conditional Formatting icon on the Home tab and choose Top/
Bottom Rules, Excel can apply conditional formatting to your top (or bottom)
ten values or those values above or below the average, as shown in Figure 9-9.
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Validation

Because formulas are only as accurate as the data they receive, it’s impor-
tant that your spreadsheet contains only valid data. Examples of invalid data
might be a negative number (such as -9) for a price or a decimal number
(such as 4.39) for the number of items a customer bought.

To keep your spreadsheet from accepting invalid data, you can define a cell
to accept only certain types of data, such as numbers that fall between 30
and 100. The moment someone tries to type invalid data into a cell, Excel
immediately warns you, as shown in Figure 9-10.

To define valid types of data for a cell, follow these steps:

1. Click a cell that contains data used by a formula.
2. Click the Data tab.
3. Click the Data Validation icon in the Data Tools group.

The Data Validation dialog box appears, as shown in Figure 9-11.
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4. Click the Allow list box and choose one of the following:

e Any Value: The default value accepts anything the user types

e Whole Number: Accepts only whole numbers, such as 47 and 903

e Decimal: Accepts whole and decimal numbers, such as 48.01 or

1.00

e List: Allows you to define a list of valid data

e Date: Accepts only dates

e Time: Accepts only times

185



’ 86 Part lll: Playing the Numbers with Excel

Figure 9-12:
The Input
Message

tab lets you
display a
message
explaining

the type of
valid data
acell can
hold.
|

Figure 9-13:
Define

an error
message to
show if the
user types
invalid data
into the cell.
|

e Text length: Defines a minimum and maximum length for text
e Custom: Allows you to define a formula to specify valid data

Depending on the option you choose, you may need to define Minimum
and Maximum values and whether you want the data to be equal to, less
than, or greater than a defined limit.

5. Click the Input Message tab in the Data Validation dialog box, as
shown in Figure 9-12.
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‘what are you, stupld? Type a valid value or collect vour stuff and
yuur pink sy s make room Fur seeone more compelenl L du
your job!|

| Clear Al | Ok

6. Click in the Title text box and type a title.

7. Click in the Input Message text box and type a message you want to
display when someone selects this particular cell.

8. Click the Error Alert tab in the Data Validation dialog box, as shown
in Figure 9-13.

Data Validation 7=

Input Message | ; En

Setlings |
J | Shows error alert atter imealid data ic enbered

when user enters invald data, show this error alert:
Style: Tiths:

Stop
Error messago:

Q.

| Cloar all | oK
\——I

Canced
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9. Click the Style list box and choose an alert icon, such as Stop or
Warning.

10. Click in the Title text box and type a title for your error message.

11. Click in the Error Message text box and type the message to appear if
the user types invalid data into the cell.

12. Click OK.

After you define data validation for a cell, you can always remove it later. To
remove validation for a cell, follow these steps:

1. Click in the cell that contains data validation.
2. Click the Data tab.
3. Click the Data Validation icon in the Data Tools group.
The Data Validation dialog box appears (refer to Figure 9-11).
4. Click Clear All and then click OK.

Excel clears all your data validation rules for your chosen cell.

Goal Seeking

When you create a formula, you can type in data to see how the formula
calculates a new result. However, Excel also offers a feature known as Goal
Seeking. With Goal Seeking, you specify the value you want a formula to cal-
culate, and then Excel changes the data in the formula’s cell references to tell
you what values you need to achieve that goal.

For example, suppose you have a formula that calculates how much money
you make every month by selling a product such as cars. Change the number
of cars you sell, and Excel calculates your monthly commission. But if you
use Goal Seeking, you can specify you want to earn $5,000 for your monthly
commission, and Excel will work backward to tell you how many cars you
need to sell. As its name implies, Goal Seeking lets you specify a goal and see
what number, in a specific cell, needs to change to help you reach your goal.

To use Goal Seeking, follow these steps:

1. Click in a cell that contains a formula.
2. Click the Data tab.
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|
Figure 9-14:
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. Click the What-If Analysis icon in the Data Tools group.

A pull-down menu appears, as shown in Figure 9-14.

. Click Goal Seek.

The Goal Seek dialog box appears, as shown in Figure 9-15.

. Click in the To Value text box and type a number that you want

to appear in the formula stored in the cell that you clicked in
Step 1.

. Click in the By Changing Cell text box and click one cell that contains

data used by the formula you chose in Step 1.

Excel displays your cell reference, such as B5, in the Goal Seek
dialog box.

. Click OK.

The Goal Seek Status dialog box changes the data in the cell you chose
in Step 6, as shown in Figure 9-16.

. Click OK (to keep the changes) or click Cancel (to display the
original values your spreadsheet had before you chose the Goal
Seek command).

Testsheet - Microsoft Cxcel

Review Wiew

T wahn:

Goal Seak >
E3)
By changing cell: z|
OK Cancel
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Figure 9-16:
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Creating Multiple Scenarios

Spreadsheets show you what happened in the past. However, you can also
use a spreadsheet to help predict the future by typing in data that represents
your best guess of what might happen.

When you use a spreadsheet as a prediction tool, you may create a best-case
scenario (where customers flood you with orders) and a worst-case scenario
(where hardly anybody buys anything). You could type in different data to
represent multiple possibilities, but then you’d wipe out your old data. For

a quick way to plug different data in the same spreadsheet, Excel offers
scenarios.

A scenario lets you define different data for multiple cells. That way, you can
choose a scenario to plug in one set of data, and then switch back to your
original data without retyping all your original data and formulas all over
again.

Creating a scenario

Before you can create a scenario, you must first create a spreadsheet with
data and formulas. Then you can create a scenario to define the data to plug
into one or more cells.

189
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Figure 9-17:
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To create a scenario, follow these steps:

1. Click the Data tab.

2. Click the What-If Analysis icon in the Data Tools group.
A pull-down menu appears.

3. Click Scenario Manager.
The Scenario Manager dialog box appears.

4. Click Add.

The Add Scenario dialog box appears, as shown in Figure 9-17.

Add Scenario
SCENario name:
Pusizi sclieme
Changing cells:
By
Ctri4-click cefls to sefect non-adjacent changing cells.
Comment:
i reated by H. Madnff nn 2f1yfann

E]

Protection
4| Prevent changes
Hide

oK Cancel

5. Click in the Scenario Name text box and type a descriptive name for
your scenario, such as Worst-case or Best-case.

6. Click in the Changing Cells text box.

7. Click a cell in your spreadsheet that you want to display different
data. If you want to choose multiple cells, hold down the Ctrl key and
click multiple cells.

8. Click in the Comment text box and type any additional comments you
want to add to your scenario, such as any assumptions your scenario
made.

9. Click OK.

The Scenario Values dialog box appears, as shown in Figure 9-18.

10.
11.

Type a new value for each cell.
Click OK.

The Scenario Manager dialog box appears, as shown in Figure 9-19.
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Figure 9-18:
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12. Click Show.
Excel replaces any existing data with the data you typed in Step 10.
13. Click Close.

The data from your scenario remains in the spreadsheet.

Viewing a scenario

After you create one or more scenarios, you can view them and see how they
affect your data. To view a scenario, follow these steps:

1. Click the Data tab.

2. Click the What-If Analysis icon in the Data Tools group.
A pull-down menu appears.

3. Choose Scenario Manager.

The Scenario Manager dialog box appears (refer to Figure 9-19).



’ 92 Part lll: Playing the Numbers with Excel

4.
5.

6.

Click the name of the scenario you want to view.

Click Show.

Excel shows the values in the cells defined by your chosen scenario.
Click Close.

Editing a scenario

After you create a scenario, you can always change it later by defining new
data. To edit a scenario, follow these steps:

1.
2.

Click the Data tab.
Click the What-If Analysis icon in the Data Tools group.

A pull-down menu appears.

. Choose Scenario Manager.

The Scenario Manager dialog box appears.

. Click the name of the scenario you want to edit and click Edit.

The Edit Scenario dialog box appears.

5. (Optional) Edit the name of the scenario.

6. Click in the Changing Cells text box.

10.

Excel displays dotted lines around all the cells that the scenario will
change.

. Press Backspace to delete cells, or hold down the Ctrl key and click

additional cells to include in your scenario.

. Click OK.

The Scenario Values dialog box appears (refer to Figure 9-18).

. Type new values for your cells and click OK when you’re done.

The Scenario Manager dialog box appears again.

Click Show to view your scenario, or click Close to make the Scenario
Manager dialog box disappear.

Viewing a scenario summary

If you have multiple scenarios, it can be hard to switch back and forth
between different scenarios and still understand which numbers are chang-
ing. To help you view the numbers that change in all your scenarios, you can
create a scenario summary.
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Figure 9-20:
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A scenario summary displays your original data along with the data stored in
each scenario in a table. By viewing a scenario summary, you can see how
the values of your spreadsheet can change depending on the scenario, as
shown in Figure 9-20.
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To create a scenario summary on a separate sheet in your workbook, follow
these steps:
1. Click the Data tab.
2. Click the What-If Analysis icon in the Data Tools group.
A pull-down menu appears.
3. Choose Scenario Manager.
The Scenario Manager dialog box appears.
4. Click Summary.

The Scenario Summary dialog box appears, as shown in Figure 9-21.

Scenario Summary v Ed
Report type
2 Scenario gummary
Scenario PivotTable report
Dot cols:
= &

193
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5. Select the Scenario Summary radio button.

6. Click in the Result Cells text box and then click in a cell that contains
a formula that your scenario affects.

7. Click OK.

Auditing Your Formulas

Your spreadsheet results are only as good as the data you give it and the
formulas you create. Feed a spreadsheet the wrong data, and it will obviously
calculate the wrong result. More troublesome is when you feed a spreadsheet
the right data but your formula is incorrect, which produces a misleading
and incorrect result.

Even if Excel appears to be calculating your formulas correctly, recheck your
calculations just to make sure. Some common errors that can mess up your
formulas include:

1 Missing data: The formula isn’t using all the data necessary to calculate
the proper result.

v Incorrect data: The formula is getting data from the wrong cell (or
wrong data from the right cell).

v Incorrect calculation: Your formula is incorrectly calculating a result.

If a formula is calculating data incorrectly, you probably didn’t type the for-
mula correctly. For example, you may want a formula to add two numbers,
but you accidentally typed in the formula to multiply two numbers instead.
To check whether a formula is calculating data incorrectly, give it data that
you already know what the result should be. For example, if you typed the
numbers 4 and 7 into a formula that should add two numbers, but it returns
28 instead, you know that it’s not calculating correctly.

If your formula is correct but it’s still not calculating the right result, chances
are good it’s not getting the data it needs from the correct cells. To help you
trace whether a formula is receiving all the data it needs, Excel offers audit-
ing features that visually show you which cells supply data to which formu-
las. By using Excel’s auditing features, you can

v Make sure that your formulas are using data from the correct cells.

v Find out instantly whether a formula could go haywire if you change a
cell reference.
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Figure 9-22:
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Finding where a formula gets its data

If a formula is retrieving data from the wrong cells, it’s never going to calcu-
late the right result. By tracing a formula, you can see all the cells that a for-
mula uses to retrieve data.

Any cell that supplies data to a formula is a precedent.
To trace a formula, follow these steps:

1. Click a cell that contains the formula you want to check.
2. Click the Formulas tab.
3. Click the Trace Precedents icon in the Formula Auditing group.

Excel draws arrows that show you all the cells that feed data into the
formula you chose in Step 1, as shown in Figure 9-22.

4. Click the Remove Arrows button to make the auditing arrows go

away.
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Finding which formula (s)
a cell can change

Sometimes you may be curious how a particular cell might affect a formula
stored in your worksheet. Although you could just type a new value in that
cell and look for any changes, it’s easier (and more accurate) to identify all
formulas that are dependent on a particular cell.



’ 96 Part lll: Playing the Numbers with Excel

Figure 9-23:
Excel can
identify
which
formulas a
particular
cell can
change.
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Any formula that receives data is a dependent.

To find one or more formulas that a single cell might affect, follow these

steps:

1. Click any cell that contains data (not a formula).

2. Click the Formulas tab.
3. Click Trace Dependents.

Excel draws an arrow that points to a cell that contains a formula, as
shown in Figure 9-23. This tells you that if you change the data in the cell
you chose in Step 1, it will change the calculated result in the cell con-

taining a formula.

4. Click the Remove Arrows icon in the Formula Auditing group to make

the arrows go away.
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Checking for Errors

If you create large worksheets with data and formulas filling rows and col-
umns, it can be hard to check to make sure that there aren’t any problems
with your spreadsheet, such as a formula dividing a number with a non-exis-

tent value in another cell.

Testsheet - Microsoft Excel
Review Wiew
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B e i Farmuly =

3 Trace Precedents 4 Show Fomulas
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= W =R
ai@Peod i

2

. wiaten | Caleulation [
o Bbmowe Arraws + (f2] Laaluate Formuls  window  Optians -

Fortunately, Excel can catch many types of errors by following these steps:

1. Click the Formulas tab.

2. Click the Error Checking icon in the Formula Auditing group.
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Excel displays a dialog box and highlights any errors, as shown in
Figure 9-24.

3. Click any of the options such as Previous or Next to see any additional

€rrors.
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4. Click the close box in the dialog box to make it go away when you’re
done using it.

5. Click in a cell that contains an error.

6. Click the downward-pointing arrow that appears to the right of the
Error Checking icon.

A menu appears.
7. Click Trace Error.

Excel displays arrows to show you the cells that are causing the prob-
lem for the error you chose in Step 5, as shown in Figure 9-25.

8. Click the Remove Arrows icon in the Formula Auditing group to make
the arrows go away.
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Chapter 10
Charting and Analyzing Data

In This Chapter

Understanding the parts of a chart

Creating a chart

Editing a chart

Modifying the parts of a chart
Playing with pivot tables

l he biggest problem with looking at any Excel spreadsheet is wondering,
“What the heck do these numbers really mean?”

To help you analyze and understand what rows and columns of numbers
might mean, Excel can convert data into a variety of charts such as pie
charts, bar charts, and line charts. By letting you visualize your data, Excel
helps you quickly understand what your data means so you can spot trends
and patterns.

Understanding the Parts of a Chart

To create charts that clarify your data (rather than confuse you even more),
you need to understand the parts of a chart and their purpose, as shown in
Figure 10-1:

v Data Series: The numeric data that Excel uses to create the chart

v X-axis: Defines the width of a chart

v Y-axis: Defines the height of a chart

v Legend: Provides text to explain what each visual part of a chart means

v~ Chart Title: Explains the purpose of the entire chart



200

Part lll: Playing the Numbers with Excel

Figure 10-1:
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Excel chart
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data.
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Charts typically use two data series to create a chart. For example, one data
series may be sales made that month, while a second data series may be the
names of each salesperson.

The X-axis of such a chart would list the names of different products while
the Y-axis would list a range of numbers that represent dollar amounts. The
chart itself could display different colors that represent products sold in dif-
ferent months, and the legend would explain what each color represents.

By glancing at the column chart in Figure 10-1, you can quickly identify:

v Which products sell best

v How each product sells in each month

v Whether sales of a particular product are improving (or getting worse)
All this data came from the spreadsheet in Figure 10-1. By looking at the num-
bers in this spreadsheet, identifying the above information is nearly impos-

sible. However, by converting these numbers into a chart, identifying this
type of information is so simple even your boss could do it.
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Although Figure 10-1 shows a column chart, Excel can create a variety of
other types of charts so you can look at your data in different ways, as shown
in Figure 10-2. Some other types of charts Excel can create include

v+ Column chart: Displays quantities as vertical columns that “grow”
upward. Useful for creating charts that compare two items, such as sales
per month or sales per salesperson.

v Line chart: Displays quantities as lines. Essentially shows the tops of a
column chart.

v Area chart: Identical to a line chart except that it shades the area under-
neath each line.

v~ Bar chart: Essentially a column chart turned on its side where bars
“grow” from left to right.

v Pie chart: Compares multiple items in relation to a whole, such as which
product sales make up a percentage of a company’s overall profits.
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Excel can create both two- and three-dimensional charts. A 3-D chart can look
neat, but sometimes the 3-D visual can obscure the true purpose of the chart,
which is to simplify data and make it easy for you to understand in the first
place.
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Creating a Chart

Figure 10-3:
The Insert
tab displays
icons for
creating dif-
ferent types
of charts.
|

Before you create a chart, you need to type in some numbers and identifying
labels because Excel will use those labels to identify the parts of your chart.
(You can always edit your chart later if you don’t want Excel to display cer-
tain labels or numbers.)

To create a chart, follow these steps:

1. Select the numbers and labels that you want to use to create a chart.
2. Click the Insert tab.

A list of chart type icons appears in the Charts group, as shown in

Figure 10-3.
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3. Click a Chart icon, such as the Pie or Line icon.
The Create Chart gallery appears (refer to Figure 10-3).
4. Click a chart type.

Excel creates your chart and displays a Chart Tools tab, as shown in
Figure 10-4.
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Editing a Chart

After you create a chart, you may want to edit it. Editing a chart can mean
moving it to a new location, changing the data source (the numbers that
Excel uses to create the chart), modifying parts of the chart itself (such as
switching to a different chart type), or editing text (such as the chart title or

legend).

Moving a chart on a worksheet
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When you create a chart, Excel plops it right on your displayed spreadsheet,
which may not be exactly where you want it to appear. Excel gives you the
option of moving a chart to a different place on the current worksheet page
or on a different worksheet page altogether.

To move a chart to a different location on the same worksheet, follow these

steps:

1. Move the mouse pointer over the border of the chart until the mouse
pointer turns into a four-way pointing arrow.

2. Hold down the left mouse button and drag (move) the mouse.

The chart moves with the mouse.

3. Move the chart where you want it to appear and release the left mouse

button.
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Moving a chart to a new sheet

Rather than move a chart on the same sheet where it appears, you can also
move the chart to another worksheet. That way your data can appear on one
worksheet, and your chart can appear on another.

To move a chart to an entirely different sheet, follow these steps:

1. Click the chart you want to move to another worksheet.
The Chart Tools tab appears.
2. Click the Design tab.
3. Click the Move Chart icon in the Location group.
<P The Move Chart dialog box appears, as shown in Figure 10-5.

As an alternative to Steps 1 through 3, you can right-click a chart; then
when the pop-up menu appears, choose Move Chart.

|
Figure 10-5; | Move Chart B8]
Specify a Chuuse where you wanl Ues charl o e placed:
worksheet |_J_:,J New sheet: | chartl
where you
want to _J'_J o bt EEIETE S~
move your —
chart. o) |
|

4. Select one of the following radio buttons:

e New Sheet: Creates a new worksheet and lets you name it

e Object In: Lets you choose the name of an existing worksheet
5. Click OK.

Excel moves your chart.

Resizing a chart

You can always resize any chart to make it bigger or smaller. To resize a
chart, follow these steps:

1. Move the mouse pointer over any corner of the chart until the mouse
pointer turns into a two-way pointing arrow.
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2. Hold down the left mouse button and drag (move) the mouse to shrink
or expand your chart.

3. Release the left mouse button when you’re happy with the new size of
your chart.

Using the Chart Tools

As soon as you create a chart or click on an existing chart, Excel displays the
Chart Tools category, which displays Design, Layout, and Format tabs. If you
click on the Design tab, you’ll see tools organized into four categories:

v Type: Lets you change the chart type

v Data: Lets you change the source where the chart retrieves its data or
switch the data from appearing along the X-axis to the Y-axis and vice
versa

v+~ Chart Layouts: Lets you change the individual parts of a chart, such as
the chart title, X- or Y-axis labels, or the placement of the chart legend
(top, bottom, left, right)

v~ Chart Styles: Provides different ways to change the appearance of your
chart

Changing the chart type

After you create a chart, you can experiment with how your data may look
when displayed as a different chart, such as switching your chart from a bar
chart to a pie chart. To change chart types, follow these steps:
1. Click the chart you want to change.
The Chart Tools category appears.
2. Click the Design tab under the Chart Tools category.
3. Click the Change Chart Type icon in the Type group.
The Change Chart Type dialog box appears, as shown in Figure 10-6.
4. Click a chart type, such as Pie or Column.

The dialog box displays a list of chart designs in the right panel of the
dialog box.

5. Click the chart design you want in the right panel.
6. Click OK.

Excel displays your new chart.
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If you don’t like how your chart looks, just press Ctrl+Z to return your chart
to its original design.
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Changing the data source

Another way to change the appearance of a chart is to change its data source
(the cells that contain the actual data that the chart uses). To change a
chart’s data source, follow these steps:
1. Click the chart you want to change.
The Chart Tools category appears.
2. Click the Design tab under the Chart Tools category.
3. Click the Select Data icon in the Data group.
The Select Data Source dialog box appears, as shown in Figure 10-7.

4. (Optional) Click the Shrink Dialog Box icon to shrink the Change Data
Source dialog box so you can see more of your spreadsheet.

5. Select all the cells that contain data to create a chart, including any
cells that contain labels, numbers, and formulas.

6. Click OK.
Excel displays your chart, using the data you specify in Step 5.
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Switching rows and columns

When Excel creates a chart, it displays your data’s labels on the X- and

Y-axes. However, you can switch these around, and Excel can show you how

your chart may change.

To switch the rows and columns used to create a chart, follow these steps:

1. Click the chart you want to change.

The Chart Tools category appears.
2. Click the Design tab under the Chart Tools category.
3. Click the Switch Row/Column icon in the Data group.

Excel switches the X-axis data to appear on the Y-axis and vice versa.




208

Part lll: Playing the Numbers with Excel

Figure 10-8:
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Changing the parts of a chart

To make your charts more informative, you can add additional text, such as

v A chart title

v Alegend

v~ Data labels

v Axis labels

v Axes

v Gridlines
With each part of a chart, Excel can either hide it completely or move it to a
different location. To modify any part of a chart, follow these steps:

1. Click the chart you want to change.

The Chart Tools category appears.
2. Click the Layout tab under the Chart Tools category.

3. Click the icon that identifies the part of the chart you want to modify,
such as Chart Title or Axis Titles.

A menu of different options appears, as shown in Figure 10-8.
4. Click an option, such as None.

Excel shows your modified chart.
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Designing the layout of a chart

Although you could add and modify the individual parts of a chart yourself,
such as the location of the chart title or legend, you may find it faster to
choose a predefined layout for your chart. To choose a predefined chart
layout, follow these steps:
1. Click the chart you want to modify.
The Chart Tools category appears.
2. Click the Design tab under the Chart Tools category.

3. Click the More button in the Chart Layouts group, as shown in
Figure 10-9.

A pull-down menu appears.
4. Click a chart layout.

Excel changes your chart.
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Deleting a chart

Charts may be nice to look at, but eventually you may want to delete them.
To delete a chart, follow these steps:

1. Click the chart you want to delete.

2. Press Delete.

You can also right-click a chart; then when the pop-up menu appears,
choose Cut.

Using Sparklines

Creating a chart can help you visualize your data, but sometimes a massive
chart with legends, titles, and X/Y-axis can seem like too much trouble for
just identifying trends in your data. For a much simpler tool, Excel offers
Sparklines.

Sparklines allow you to see, at a glance, the relationship between values
stored in multiple cells. Rather than look at a row or column of numbers to
determine if the values are increasing or decreasing over time, you can create
a Sparkline that condenses this information in a single cell that you can see at
a glance. Excel offers three types of Sparklines, as shown in Figure 10-10:

v Line

v Column

v Win/Loss

Creating a Sparkline
To create and display a Sparkline in a spreadsheet, follow these steps:

1. Select the cells that contain the data you want to turn into a Sparkline.
2. Click the Insert tab.
3. Click on the Line, Column, or Win/Loss icon in the Sparklines group.

A Create Sparklines dialog box appears, as shown in Figure 10-11.
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4. Click on the cell where you want the Sparkline to appear. (You can
select two or more cells.)

The Location Range text box displays the cell reference that you chose.
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Figure 10-12:
The Marker
Coloricon
lets you
define
different
colors for
parts of your
Sparkline.

5. Click OK.

Excel displays your chosen Sparkline in the cell that you selected.

Customizing a Sparkline

After you've created one or more Sparklines, you can modify their appear-
ance. To modify a Sparkline, follow these steps:

1. Click on the cell that contains a Sparkline.

2. Click on the Design tab.

3. Click on a style in the Style group.

If you click the More button, you can view all the available styles.
4. Click the Sparkline Color icon and click on a color.
5. Click on the Marker Color icon.

A menu appears, as shown in Figure 10-12.
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6. Move the mouse over an option such as Low Point or First Point.
A color palette appears.
7. Click on a color.

Your Sparkline appears with the changes you chose.



Chapter 10: Charting and Analyzing Data 2 ’3

Deleting a Sparkline

After you've created one or more Sparklines, you may want to delete them.
To delete a Sparkline, follow these steps:

1. Click on the cell that contains a Sparkline.

2. Click on the Design tab.

3. Click the Clear icon in the Group category.

Your chosen Sparkline disappears.

Organizing Lists in Pivot Tables

Ordinary spreadsheets let you compare two sets of data such as sales versus
time or products sold versus the salesperson who sold them. Unfortunately,
if you want to know how many products each salesperson sold in a certain
month, deciphering this information from a spreadsheet may not be easy.

That’s where pivot tables come in. A pivot table lets you yank data from your
spreadsheet and organize it in different ways in a table. By rearranging (or
“pivoting”) your data from a row to a column (and vice versa), pivot tables
can help you spot trends that may not be easily identified trapped within the
confines of an ordinary spreadsheet.

Creating a pivot table

Pivot tables use the column headings of a spreadsheet to organize data in

a table. Ideally, each column in the spreadsheet should identify a different
type of data, such as the name of each salesperson, the sales region he or she
works in, and the total amount of sales made, as shown in Figure 10-13.

After you design a spreadsheet with multiple columns of data, follow these
steps to create a pivot table:

1. Select the cells (including column labels) that you want to include in
your pivot table.

2. Click the Insert tab.

3. Click the top half of the PivotTable icon in the Tables group.

The Create PivotTable dialog box appears, as shown in Figure 10-14.
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Figure 10-15:
The
PivotTable
Field List
pane lets
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which data
to display

in the pivot
table.
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4. (Optional) Select the cells that contain the data you want to use in

your pivot table.

You only need to follow Step 4 if you didn’t select any cells in Step 1, or
if you change your mind and want to select different cells than the ones
chosen in Step 1.

5. Select one of the following radio buttons:

e New Worksheet: Puts the pivot table on a new worksheet

¢ Existing Worksheet: Puts the pivot table on an existing worksheet

6. Click OK.

Excel displays a PivotTable Field List pane, as shown in Figure 10-15.

7. Mark (select) one or more check boxes inside the PivotTable Field List

pane.

Each time you select another check box, Excel modifies how data
appears in your pivot table, as shown in Figure 10-16.
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Rearranging labels in a pivot table

A pivot table organizes data according to your spreadsheet’s column head-
ings (which appear in a pivot table as row labels). The pivot table shown in
Figure 10-16 shows sales divided by salesperson. Each salesperson’s amounts
are further divided by sales region, and the names of the products sold.

However, you may be more interested in seeing the sales organized by sales
region. To do this, you can modify which column heading your pivot table
uses to organize your data first. To rearrange column headings in a pivot
table, follow these steps:

1. Click on the pivot table you want to rearrange.

The PivotTable Field List pane appears. A group called Row Labels
appears in the bottom-left corner of the PivotTable Field List pane. This
Row Labels box displays the names of your different PivotTable catego-
ries, such as Region, Product, and Sales Person.
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2. Click on a label in the Row Labels box.
A menu appears, as shown in Figure 10-17.
Select one of the following:
* Move Up: Moves the label one level closer to the beginning
* Move Down: Moves the label one level down to the end

® Move to Beginning: Makes the label the dominant criteria for sort-
ing data

e Move to End: Makes the label the last criteria for sorting data

Figure 10-18 shows different ways a pivot table can organize the same

data.
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Figure 10-19:
Displaying
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Modifying a pivot table

Row labels let you organize data according to different criteria, such as sales
per region and then by product. For greater flexibility, you can also turn a
row label into a column heading. Figure 10-19 shows a pivot table where row
labels are stacked on top of each other, and then the same pivot table where
one row label (Products) is turned into a column heading.
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To turn row labels into column headings in a pivot table (or vice versa),
follow these steps:
1. Click the pivot table you want to modify.
The PivotTable Field List pane appears.

2. Click a heading in the Row Labels box near the bottom-left corner of
the PivotTable Field List pane.

A pop-up menu appears.

3. Choose Move to Column Labels.
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Figure 10-20:
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You can also drag headings from the Row Labels box to the Column
Labels box and vice versa.

Filtering a pivot table

The more information your pivot table contains, the harder it can be to make
sense of any of the data. To help you out, Excel lets you filter your data to
view only certain information, such as sales made by each salesperson or
total sales within a region. To filter a pivot table, follow these steps:
1. Click the pivot table you want to filter.
The PivotTable Field List pane appears.

2. Click a heading in the Row Labels or Column Labels group in the
PivotTable Field List pane.

A pop-up menu appears.
3. Click Move to Report Filter.

Excel moves your chosen label into the Report Filter group in the
PivotTable Field List pane, as shown in Figure 10-20.
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Figure 10-21:
A pivot table
can count
occur-
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Summing a pivot table

A pivot table not only displays information, but it can also count the number
of occurrences of information, such as the number of sales per sales region.
To display a count of data, you need to move a heading in the Values group
inside the PivotTable Field List pane by following these steps:

1. Click the pivot table you want to modify.

The PivotTable Field List pane appears.

2. Click a heading that you want to count in the PivotTable Field List
pane.

A pop-up menu appears.
3. Click Move to Values.

Excel moves your chosen heading to the Values group inside the
PivotTable Field List pane and displays a count of items under your
chosen heading, as shown in Figure 10-21.
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Slicing up a pivot table

If your pivot table contains large amounts of data, trying to decipher this
information can be difficult. Rather than display all your pivot table data,
you can choose to slice the pivot table so it shows only the specific data you
want to view.

To slice a turn row labels into column headings in a pivot table (or vice
versa), follow these steps:
1. Click anywhere inside the pivot table you want to modify.

The PivotTable category appears and displays an Options and
Design tab.

2. Click the Options tab, click the Slicer icon in the Filter group, and
choose Insert Slicer.

An Insert Slicers dialog box appears, as shown in Figure 10-22.

BFIFEE z e o . 5 r =5 &
Home  Bnset  Pagelmwul  Formulss  Dats  Pewew  View | Optiuns | Design c@ =@ 3
A =il -3 " y
3

FivokTable Hame:  Active Figld: 3 PivotChart 2] Fierd st
Frvotiabiel Count of Froduct ; ALy e Buttons
By fiela settngs T Fieid Headers
] - 1 -
A B 0 r F G H [ "= | Pl Taile Field List v X
1 -
3 = Choosa fiskds to add to report: =
3 Ruw labuls = Sum ul Amount Count of Product Insent Slicers -7 &= 7 Sales Persun
4 =Do Katz 2r42.79 5 o Fereon 7 IReqion
5 East [ 2 Tiegion iPraduct
8 9/6/2010 an.37 1 Produst et
7 af23/2010 249.68 1 Aemeure Hiose Soid
o “south 41025 1 Date Sold
g 92342010 -’:10.1b| 1!
0 =Wt 1681.49 2
11 3/2/2010 470.25 1
12 4f17/2010 3.8 1
I |13 - Dane Hendersun 643.27 1
. 14 =Fast 64327 1
F|gu|'e 10-22; |:= 2/13/2010 683.27 1 o Atkis Eotcon abaad bokik
The Insert ii Da;::l Aoyee f;‘:z": : 7 ReportTier [ CobrmnLabels
Slicers dia- | 9/17/2010 904,26 1 T
19 =North w2y 2
|0g bOX |ets 0 9/18/2010 Y253 1
) 7 3/23/2010 ara.se 1
you define 2 -wun:err 167317 | Bl
- v | S of At =
the data |# 9/a/2010 648,19 1 Cancel - ek of Pt
ko) /2142010 £01.47 1 -
you wantto |= a/24/2010 42251 1
view 26 “Douglames 330716 6 P e
* W 4 b W[ Sheetl ~Sheet? =~ SheetS & Shesth . Shestd | Sheet? Shel] 4 [ u |
I | P LLLCH [ e = | +




Chapter 10: Charting and Analyzing Data

Figure 10-23:
Slices help
you zero in
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pivot table.
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3. Select one or more check boxes in the Insert Slicers dialog box and
click OK.

Slicer panes appear, listing the types of data. For example, a Sales
Person slicer pane would list the names of all the salespeople while a
Product slicer pane would list the names of all products sold.

4. Click on each slicer pane to select it, and then move the mouse
pointer over the slicer pane border and drag the mouse to move the
slicer pane to a more convenient location on the screen.

5. Click the item inside each slicer pane to display that data in the pivot
table. (Hold down the Ctrl key and click to choose multiple items.)

If you want to view sales results from a single salesperson, select that
salesperson’s name and select all the products you want to examine to
see how many sales that person made for each product, as shown in
Figure 10-23.
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Q“BER
S
< You can remove a slicer pane by right-clicking on the slicer pane and
when a pop-up menu appears, choose Remove Slicer.
Creating PivotCharts
Pivot tables can contain rows and columns of numbers that you might find
easier to understand by converting them into a chart, called a PivotChart.
PivotCharts are like other types of charts except you can selectively display
(or hide) different data. This lets you create a chart showing sales from all
your salespeople, and then selectively hide all data except anything sold by a
single salesperson, as shown in Figure 10-24.
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To create a PivotChart, follow these steps:

1. Click the pivot table you want to modify.

The PivotTable category appears and displays an Options and
Design tab.
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2. Click the Options tab and click the PivotChart icon in the Tools group.
An Insert Chart dialog box appears.

3. Click on a chart type (such as Pie or Line), click on a specific chart
design, and click OK.

Your PivotChart appears, displaying your categories directly on the
chart.

4. Click on the downward-pointing arrow of a category. A menu appears,
as shown in Figure 10-25.
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5. Clear the check boxes next to the items that you don’t want to display
and select the check boxes next to the items that you do want to
display.

Your PivotChart displays a chart that represents only your selected
data, as shown in Figure 10-26.
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Making
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In this part . . .

M ost people are more terrified of public speaking
than they are of dying. While Microsoft Office 2010
can’t help you overcome your fear of death, it can help
you overcome your fear of public speaking by helping you

making presentations using the number one presentation
program in the world — PowerPoint.

With the help of PowerPoint, you can organize your ideas
and present them in a visually compelling manner so you
won’t need to rely on speaking alone (or the threat of
firing someone) to captivate your audience. By using
PowerPoint, you can forever banish whiteboards, over-
head projectors, and even drawings when giving a
presentation.

The next time you need to dazzle, convince, and persuade
an audience with information (whether it’s true or not),
you can flip through this part of the book and learn how
to create slideshows, add graphics, animation, and sound,
and design interesting and informative presentations that
can keep your audience enthralled.

Using the presentation abilities of PowerPoint, you’ll
never be at a loss for words again as long as you take a
moment to think ahead, plan your presentation, and dis-
play your information through the magic of PowerPoint.




Chapter 11

Creating a PowerPoint
Presentation

In This Chapter

Designing a presentation

Creating a PowerPoint presentation

Using different views to create a presentation
Adding text

powerl’oint works as a visual aid for giving presentations. (If you never
give presentations, you probably don’t need PowerPoint.) Instead of
fumbling around creating, organizing, and displaying transparencies with an
overhead projector, you can use PowerPoint on your computer to create,
organize, and display slides that organize information as text and graphics.

Besides displaying slides on the screen, PowerPoint also lets you add notes
and turn your entire slide show presentation into printed handouts so the
audience can review your presentation with a printed copy of each slide.
The next time you need to convince or inform an audience, use PowerPoint
to create and deliver your presentation. (Just make sure that you never use
PowerPoint to propose marriage, though.)

Defining the Purpose of
Vour Presentation

PowerPoint can make creating and delivering a presentation easy, but before
you start creating fancy visuals with eye-popping graphics and colors, step
away from your computer, put down your copy of PowerPoint, and place
your hands in the open where anyone can see them.

Rushing into PowerPoint to create a presentation is likely to create a daz-
zling array of colors, fonts, and graphics that may look interesting but won’t
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convey your message effectively. The best way to create an effective presen-
tation is to take some time to think about the following:

v What is your point? Define the single most important idea of your
presentation.

+ Who is the target audience? A presentation given to engineers and sci-
entists will look different than the same presentation given to CEOs and
venture capital executives.

+ What do you want the audience to do? A speaker may present new
ideas to a conference, while a politician may present ideas designed to
sway the audience to take certain actions, such as voting a specific way.

After you understand the purpose of your presentation, your audience, and
what you hope your presentation will do, you’re ready to go through the
physical steps of creating a presentation in PowerPoint.

Creating a PowerPoint Presentation

A PowerPoint presentation consists of one or more slides where each slide
can display text and graphics. Creating a presentation means adding slides
MBER and typing text or pasting graphics on each slide.

S

Y
< When you first start PowerPoint, the program loads a blank presentation that
you can modify right away.

If you've been working on another presentation in PowerPoint and you need
to start a new, blank presentation from scratch, follow these steps:
1. Click the File tab.
The Backstage View appears.
2. Click New.
PowerPoint displays different templates you can choose.
3. Click Blank Presentation and then click Create.
PowerPoint displays a blank slide with a title and subtitle box, as shown

in Figure 11-1.

After you create a new presentation, you need to fill it with content (text and
graphics). PowerPoint gives you two ways to view, edit, and design your
presentation:

v Slide view

v Outline view
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Figure 11-1:
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Both views let you add, delete, rearrange, and edit slides. The main differ-
ence is that Slide view lets you add graphics and modify the visual appear-
ance of a slide. Outline view displays your entire presentation as an outline in
which each slide appears as an outline heading, and additional text on each
slide appears as a subheading. Outline view makes it easy to focus on the text
of your presentation without the distraction of the visual appearance of your
slides.

You can create an entire presentation in Slide view without ever using Outline
view at all (or use Outline view without ever using Slide view at all). Outline
view is most useful for creating and organizing a presentation. Slide view is
most useful for viewing the appearance of multiple slides at once.

Designing a presentation with Slide view

Slide view shows your entire slide show as thumbnails in the left pane and
the currently selected slide in full size view in the right pane, as shown in
Figure 11-2.
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Creating a new slide
To create a new slide within Slide view, follow these steps:
1. Click an existing slide in the thumbnail pane.
2. Click the Home tab.
3. Click the New Slide icon in the Slides group.
PowerPoint inserts your new slide after the slide you selected in Step 1.
S{,N\BER If you click the top half of the New Slide icon, PowerPoint creates a blank
& slide based on the slide you selected in Step 1. If you click the bottom half of

the New Slide icon, a menu appears, letting you choose from a variety of dif-

ferent slide designs.
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Rearranging slides
You can rearrange the order of your slides by following these steps:

1. In the thumbnail pane, click the slide that you want to move to a new
position in your presentation.

2. Hold down the left mouse button and drag (move) the mouse up or
down within the thumbnail pane.

PowerPoint displays a horizontal line between slides to show you where
your slide will appear. If you drag the mouse to the top or bottom of the
thumbnail pane, PowerPoint automatically scrolls up or down the list.

3. Release the left mouse button when you’re happy with the slide’s new
position.

Hiding or deleting a slide

If you have a slide that you no longer want in your presentation, you can
either hide or delete it. Hiding a slide keeps the slide but doesn’t display that
slide when you give your presentation. You may want to hide a slide in case
you need it later or so you can reference the information on this slide with
the rest of your presentation.

To hide a slide, follow these steps:

1. In the thumbnail pane, click the slide that you want to hide.
2. Click the Slide Show tab.
3. Click Hide Slide in the Set Up group.
PowerPoint dims your chosen slide and highlights the Hide Slide icon.

To unhide a slide, repeat the preceding steps.

If you're sure that you want to get rid of a slide, you can just delete it. To
delete a slide, follow these steps:
1. In the thumbnail pane, click the slide that you want to delete.
2. Click the Home tab.
3. Press the Delete key.
PowerPoint deletes your chosen slide.

If you press Ctrl+Z or click the Undo icon right away, you can recover a
deleted slide.
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Figure 11-3:
Outline view
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view just the
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your entire
presentation.
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Designing a presentation
with Outline view

In the Outline view, each slide appears with one or more of the following:

v~ Atitle (appears to the right of a slide icon)
v A subheading (appears to the right of a number in a small box)

v Text (appears without any icon next to it)

The Outline pane only displays the text on each slide. Clicking on a slide in
the Outline pane displays the entire slide, including graphics, as shown in
Figure 11-3.

The biggest advantage of Outline view is that it lets you rearrange and orga-
nize your slides by focusing on their content (title, subtitles, and text). To
switch from Slide view to Outline view, click the Outline tab. To switch from
Outline view to Slide view, click the Slides tab.
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Creating a new slide
In Outline view, each outline heading represents a slide. To create a new slide

in Outline view, follow these steps:
1. Click the Outline tab to switch to Outline view.
2. Click a slide title in the Outline pane.
3. Choose one of the following:

¢ Press Home to move the cursor to the front of the outline heading.
This creates a new slide before the currently displayed slide.

¢ Press End fo move the cursor to the end of the outline heading. This
creates a new slide after the currently displayed slide.

4. Press Enter.

PowerPoint adds a new, blank slide to your presentation.

Creating subtitles on a slide
Outline view lets you create slides and add subtitles to each slide as well. To

add a subtitle to a slide, follow these steps:
1. Click the Outline view tab to display the Outline pane.

2. Click a slide title and then press End to move the cursor to the end of
the slide title.

3. Press Enter.
PowerPoint creates a blank slide title underneath.
4. Press Tab.

PowerPoint indents your slide title and turns it into subtitle text under
the preceding outline heading.

Collapsing and expanding subtitles

A large presentation consisting of multiple slides with subtitles can be hard
to read. To simplify the appearance of your outline, PowerPoint lets you col-
lapse or expand outline headings. To collapse or expand an outline heading,
follow these steps:

1. Click the Outline tab to display the Outline pane.

2. Double-click the slide icon of a slide title in the Outline pane.

PowerPoint collapses any subtitles that appear under your chosen outline
heading and displays a gray line under your outline heading to let you
know that its subtitle text is collapsed (hidden), as shown in Figure 11-4.
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Figure 11-4:
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Collapsed outline heading

To expand a collapsed slide title, just double-click its slide icon.

Rearranging slides

Outline view makes it easy to rearrange slides just by moving slide titles up
or down. To move a slide title, follow these steps:

1. Move the mouse pointer over the slide icon that appears to the left of
the slide title (or slide subtitle) that you want to move.
The mouse turns into a four-way pointing arrow.

2. Hold down the left mouse button and drag (move) the mouse up or
down.

PowerPoint displays a horizontal gray line to show where the new posi-
tion of the slide will appear in your presentation.

3. Release the left mouse button.

PowerPoint moves your outline heading to its new position in your
presentation.

Deleting a slide
To delete a slide in Outline view, follow these steps:

1. Click the slide icon that appears to the left of the slide title (or sub-
title) you want to delete.

2. Press Delete.
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Working with Text
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Most slides contain exactly one title and one subtitle text box. The title text
box typically defines the information that the slide presents, while the sub-
title text box displays supporting information.

When you create a new slide, both the title and subtitle text boxes will be
empty, although they’ll both display the message Click here to add
titleor Click here to add subtitle. (This text won’t appear on your
slides if you don’t type anything there.)

If you delete all the text inside of a title or subtitle text box, PowerPoint auto-
matically displays the Click here to add titleorClick here to
add subtitle text in the empty text boxes.

To add text inside a title or subtitle text box, follow these steps:

1. Click in the title or subtitle text box, directly on the slide.
PowerPoint displays a cursor in your chosen text box.

2. Type your text.

You can also create title and subtitle text in Outline view as explained in the
earlier section, “Designing a presentation with Outline view.”

Typing text in a text box

A typical PowerPoint slide lets you type text in the Title text box or the Subtitle
text box. When you type text in the Title or Subtitle text box, the contents
appear as slide titles and subheadings within Outline view.

However, PowerPoint also offers you a third option for displaying text on a
slide: You can create your own text box and place it anywhere on the slide.

To create and place a text box on a slide, follow these steps:

1. Click the Insert tab.
2. Click the Text Box icon in the Text group.
The mouse pointer turns into a downward-pointing arrow.

3. Move the mouse pointer over the area on the slide where you want to
create a text box.
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4. Hold down the left mouse button and drag (move) the mouse to draw
a text box on a slide.

5. Release the left mouse button.

PowerPoint displays a text box, as shown in Figure 11-5.

Click to add title

Figure 11-5:
PowerPoint
lets you
draw text
bOXeS larersomtn 114 kom0t 134l s 10543 et s i
directly

on a slide.

6. Type your text inside the text box.

Any text you type into a text box that you create will not appear in Outline
view.

Formatting text

After you create text in a text box, you can format it by choosing different
fonts, font sizes, and colors. To change the appearance of text, follow these
steps:
1. Click the Home tab.
2. Click in a text box and select the text you want to format.
3. Click one of the following font tools, as shown in Figure 11-6:
¢ Font list box

¢ Font Size list box
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¢ Increase Font Size

¢ Decrease Font Size
e Clear All Formatting
e Bold

e [talic

e Underline

¢ Shadow

e Strikethrough

¢ Character Spacing

¢ Change Case

¢ Font Color
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Aligning text

PowerPoint can align text both horizontally and vertically inside a text box.
To align text, follow these steps:

1. Click the Home tab.
2. Click in a text box and select the text you want to align.
3. Click one of the following text alignment tools in the Paragraph group:
e Align Left
e Center
¢ Align Right
e Justify

e Align Text (Top, Middle, Bottom, Top Centered, Middle Centered,
Bottom Centered)

4. Click the Align Text icon in the Paragraph group.
A pop-up menu appears, as shown in Figure 11-7.

5. Click a vertical alignment option, such as Top or Middle.
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Adjusting line spacing
Line spacing defines the space that appears between each line in a text box.
To define the line space in a text box, follow these steps:

1. Click the text box that contains text.

2. Click the Home tab.

3. Click the Line Spacing icon in the Paragraph group.

A pull-down menu appears, as shown in Figure 11-8.
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4. Select a line spacing value, such as 1.5 or 2.

PowerPoint adjusts line spacing in your chosen text box.

Making numbered and bulleted lists

PowerPoint can display text as bulleted or numbered lists. The two ways to
create such a list are before you type any text or after you've already typed
some text.
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To create a bulleted or numbered list as you type new text, follow these steps:

1. Click in a text box.
2. Click the Home tab.

3. Click the Bullets or Numbering icon in the Paragraph group.

A pull-down menu appears, as shown in Figure 11-9.

. Click a bullet or numbering option.

PowerPoint displays a bullet or number.

. Type any text and press Enter.

As soon as you press Enter, PowerPoint displays a new bullet or number.

If you have existing text, you can convert it to a bulleted or numbered list. To
convert existing text into a list, follow these steps:

1.

Click in the text box that contains the text you want to convert into a
bulleted or numbered list.

2. Select the text you want to convert into a list.
3. Click the Home tab.

4. Click the Bullets or Numbering icon in the Paragraph group.

PowerPoint converts your text into a list.

PowerPoint displays each paragraph as a separate item in a bulleted or
numbered list. A paragraph is any amount of text that ends with a paragraph
mark (), which is an invisible character that you create when you press the
Enter key.

Making columns

You can divide a text box into multiple columns, which can be especially

useful if you need to display large lists on a slide. To divide a text box into
columns, follow these steps:

1. Click the text box that you want to divide into columns.
2. Click the Home tab.

. Click the Columns icon in the Paragraph group.

A menu appears, as shown in Figure 11-10.

. Click a column option, such as Two Columns or Three Columns.

PowerPoint divides your text box into columns.
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Moving and resizing a text box

PowerPoint lets you move text boxes anywhere on the slide. To move a text
box, follow these steps:

1. Move the mouse pointer over the edge of the text box that you want
to move.
The mouse turns into a four-way pointing arrow.

2. Hold down the left mouse button and drag (move) the mouse to move
the text box.

3. Release the left mouse button when you’re happy with the new loca-
tion of the text box.

To resize a text box, follow these steps:

1. Click the text box you want to resize.

PowerPoint displays handles around your chosen text box, as shown in
Figure 11-11.
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Handle

Figure 11-11:
Handles let
you resize a
text box.
|

2. Move the mouse pointer over a handle.
The mouse pointer turns into a two-way pointing arrow.

3. Hold down the left mouse button and drag (move) the mouse.
PowerPoint resizes your text box in the direction you move the mouse.

4. Release the left mouse button when you’re happy with the size of the
text box.

Rotating a text box

After you type text in a title or subtitle text box, you can rotate the text box
on your slide. To rotate a text box, follow these steps:
1. Click the text box you want to rotate.

PowerPoint displays a rotate handle at the top of your text box, as
shown in Figure 11-12.

2. Move the mouse pointer over the rotate handle.

The mouse pointer turns into a circular arrow.
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Rotate handle

|
Figure 11-12:
The rotate
handle lets
you rotate a
text box on
your slide.
|
3. Hold down the left mouse button and drag (move) the mouse to rotate
3 your text box.
If you hold down the Shift key while dragging the mouse, you can rotate
the text box in 15-degree increments.
4. Release the left mouse button when you’re happy with the rotated
s&N\BEIf position of your text box (or press Esc to cancel the rotation).
©
&

You can still edit and format text in a text box that appears rotated.
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Adding Color and Pictures
to a Presentation

In This Chapter

Using themes

Changing a background

Adding graphics

Showing movies on a slide

Adding sound to a presentation

T) make your presentations look more visually appealing, PowerPoint lets
you add color and graphics to your slides. Color and graphics can’t turn
a worthless presentation into an informative one, but they can enhance an
informative presentation and make it easier for people to watch.

For additional appeal, PowerPoint lets you add audio and video to a presen-
tation. That way, you can make your presentation more interesting by letting
people read, hear, and see information.

Applying a Theme
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By default, PowerPoint displays each slide with a white background. Although
you could change the colors and appearance of each slide individually, it’s
much easier to change every slide in your presentation by using a theme. A
theme provides predesigned colors and designs that are applied to each slide
to give your presentation a uniform and professional look.

To define a theme for a presentation, follow these steps:

1. Click the Design tab.

If you click on a slide in the thumbnail view and hold down the Ctrl key,
you can select which slides you’ll change. If you don’t select any slide,
PowerPoint will change all your slides.
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2. Click the More button under the Themes group.

A menu appears, as shown in Figure 12-1.
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If you move the mouse pointer over a theme, PowerPoint shows how
your presentation will look.

3. Click a theme.
PowerPoint displays your chosen theme on your slides.
4. Click the Theme Colors icon in the Themes group.

A menu appears, listing different color variations you can choose for
your presentation, as shown in Figure 12-2.

5. Click a color pattern.
PowerPoint displays your new theme colors.
6. Click the Fonts icon in the Themes group.

A menu appears listing all the default fonts for your presentation, as
shown in Figure 12-3.

7. Click a font.
8. Click the Effects icon in the Themes group.

A menu appears listing all the different effects you can give your presen-
tation, such as Metro or Clarity.

9. Click an effect.
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Changing the Background

Figure 12-4:
The
Background
Styles

menu lists
different
background
designs for
your slide.
|

Another way to change the appearance of your presentation is to modify
the background of your slides. PowerPoint provides predefined background
themes that you can choose. To choose a background theme, follow these
steps:

1. Click the Design tab.

If you click on a slide in the thumbnail view and hold down the Ctrl key,
you can select which slides you’ll change. If you don’t select any slide,
PowerPoint will change all your slides.

2. Click Background Styles under the Background group.

A menu displays different backgrounds you can choose, as shown in
Figure 12-4.

] Background Styles =

OCE

) Format Background...

3. Click a background style.

PowerPoint applies your chosen background style to every slide in your
presentation.

Choosing a solid color background

Rather than choose a theme, you may want to choose a solid color. If you
choose a solid color background, make sure that any text or graphics that
appear on your slides can still be seen. For example, if you choose a dark red
background, any text or graphics on your slides should appear in light colors
to make them visible against the dark red background.

To make sure that solid background colors don’t obscure your text and
graphics, you can also adjust its transparency to make the color appear
darker or lighter.
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Figure 12-5:
The Format
Background
dialog box
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presentation.
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To change the background to a solid color, follow these steps:

1. Click the Design tab.

If you click on a slide in the thumbnail view and hold down the Ctrl key,
you can select which slides you’ll change. If you don’t select any slide,
PowerPoint will change all your slides.

2. Click the Background Styles icon in the Background group.
A pull-down menu appears (refer to Figure 12-4).
3. Click Format Background near the bottom of the menu.

The Format Background dialog box appears, as shown in Figure 12-5.

Format Background [ ==
L Fill
Ficlure Curreclivns @ Sobd fill
Dicture Color aradient fill
R Dicture or bexbure fill
Aurlistic Effecls )
Patbern Hll
Hirds harkgronind graphies
Fill Color
Color: | 5% = |
Transparency: _,! %
Close | Apply to Al

4. Select the Solid Fill radio button.
5. Click the Color icon.
A pull-down menu appears, listing a palette of colors.
6. Click a color.
PowerPoint fills your slide background with your chosen color.
7. (Optional) Drag the Transparency slider left (0%) or right (100%).

The higher the transparency value, the lighter the background color
appears.

251
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8. (Optional) Click Apply to All to change the background of every slide

in your presentation.

If you don’t click the Apply to All button, PowerPoint changes only the
background of the currently selected slide.

If you click the Reset All Background button, you can remove any back-
ground changes you made.

9. Click Close.

Choosing a gradient background

A gradient displays one color that gradually fades into another color, such

as green to orange. To define a gradient, you can define one or more stops,
transparency, and the gradient direction. Stops define where the colors in the
gradient start and end. Transparency defines how opaque a color appears.
The gradient direction defines how the gradient appears, such as vertically or
diagonally.

To define a gradient background, follow these steps:

1.

Click the Design tab.

If you click on a slide in the thumbnail view and hold down the Ctrl key,
you can select which slides you’ll change. If you don’t select any slide,
PowerPoint will change all your slides.

. Click the Background Styles icon in the Background group.

A pull-down menu appears (refer to Figure 12-4).

. Click Format Background near the bottom of the menu.

The Format Background dialog box appears (refer to Figure 12-5).

. Select the Gradient Fill radio button.

The Format Background dialog box displays additional options for defin-
ing a gradient, as shown in Figure 12-6.

If you click the Preset Colors icon, you can choose from a variety of pre-
defined gradients.

5. Click in the Stop list box under Gradient Stops and choose Stop 1.

6. Click the Color icon.

A color palette appears.

. Click on a color.

PowerPoint displays your chosen color as a gradient on the current slide.
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8. Drag the Stop Position slider left or right.

The far left and far right positions of the stop position slider define
where the gradient begins and ends on the slide.

9. Drag the Transparency slider left or right.

The far left position (0%) displays your chosen color in full strength,
and the far right position (100%) displays your chosen color to the point
where it disappears from view completely (100% transparency).

10. Click in the Type list box above the Gradient Direction group and
choose an option, such as Radial or Linear.

11. Repeat Steps 5 through 8 to define the position of Stop 2.

12. (Optional) Click Apply to All if you want your gradient to apply to
every slide in your presentation.

If you don’t click the Apply to All button, PowerPoint displays only the
background of the currently selected slide.

13. Click Close.

Choosing a picture background

A picture, such as clip art or a photograph captured with a digital camera,
can appear in your background. After you use a picture for the background,
you can also adjust its transparency so that you can read any title or subtitle
text that appears on each slide.
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To add a picture background to slides, follow these steps:

1. Click the Design tab.
2. Click the Background Styles icon in the Background group.
A pull-down menu appears (refer to Figure 12-4).
3. Click Format Background near the bottom of the menu.
The Format Background dialog box appears (refer to Figure 12-5).
4. Select the Picture or Texture Fill radio button.

The Format Background dialog box displays options for adding a picture
to your background.

5. Click one of the following buttons:

e File: Retrieves a graphic image stored on your computer, such as a
digital photo. When the Insert Picture dialog box appears, click the
picture you want to use and then click Open.

e Clipboard: Pastes a previously cut or copied graphic image from
another program, such as Photoshop.

e ClipArt: Displays a library of clip art images you can choose. When
the Select Picture dialog box appears, click the clip art image you
want to use and then click OK.

6. Drag the Transparency slider to the left or right until you’re happy
with the way the picture appears.

7. (Optional) Click Apply to All if you want to apply your picture to
every slide in your presentation.

If you don’t click the Apply to All button, PowerPoint displays only the
background of the currently selected slide.

8. Click Close.

Adding Graphics to a Slide

Another way to spice up the appearance of your presentation is to include
graphics on one or more slides. Such graphics can be informative, such as a
chart that displays sales results; or they can be decorative, such as a cartoon
smiley face that emphasizes the presentation’s good news.

Three common types of graphics you can add to a PowerPoint slide include
v~ Picture files: Includes clip art images as well as images you may have

stored on your hard drive, such as photographs from your digital
camera
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v Charts: Displays bar, column, line, pie, and other types of charts
v WordArt: Displays text as colorful text

Placing picture files on a slide

To liven up a presentation, you can add pictures you may have already
stored on your computer. To add a picture to a slide, follow these steps:

1. Click a slide (in either Slide or Outline view) to which you want to add
a picture.

2. Click the Insert tab.

3. Click the Picture icon in the Images group.

The Insert Picture dialog box appears. You may need to change folders
or drives to find the picture file you want.

4. Choose the picture file you want and then click Open.

PowerPoint displays your chosen picture on the currently displayed
slide. You may need to resize or move your picture.

Placing clip art on a slide

Clip art consists of drawings that come with PowerPoint. To add a clip art
image to a slide, follow these steps:

1. Click a slide (in either Slide or Outline view) to which you want to add
a picture.

2. Click the Insert tab.

3. Click the Clip Art icon in the Images group.

The Clip Art pane appears on the right side of the screen, as shown in
Figure 12-7.

To access Microsoft’s massive clip art library, you need an Internet
connection.

4. Click in the Search For text box and type a word that describes the
type of image you want to find.

5. Click Go.

The Clip Art pane displays all the clip art images it could find that match
the descriptive word you typed in Step 4.
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6. Choose the clip art image you want to use.

PowerPoint displays your chosen image on the current slide. (You may
need to move or resize the image.)

7. (Optional) Click the Close box of the Clip Art pane to make it go away.

Creating WordArt

WordArt provides another way to display text. Unlike ordinary text that you
can format, WordArt lets you create graphically oriented text to use as head-
lines for added emphasis. To create WordArt, follow these steps:

1. Click the slide (in either Slide or Outline view) to which you want to
add WordArt.

2. Click the Insert tab.

3. Click the WordArt icon in the Text group.
A WordArt menu appears.
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4. Click a WordArt style to use.
PowerPoint displays a WordArt text box on the current slide.

5. Click in the WordArt text box and type text.

Capturing screenshots

Sometimes you might want to show an image of an actual computer screen to
show how a program works or show what a competitor’s Web site looks like.
If you need a screenshot, PowerPoint can import all or part of a screen.

To capture a screenshot, follow these steps:

1. Click the slide (in either Slide or Outline view) to which you want to
add a screenshot.

2. Click the Insert tab.

3. Click the Screenshot icon in the Images group.

A menu appears showing all currently open windows, as shown in

Figure 12-8.
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4. Click on a screenshot that you want to capture.
PowerPoint displays the screenshot on the current slide.

> If you choose Screen Clipping from the bottom of the menu, you can

drag the mouse to select just a portion of a screen to capture and store
on your slide.

Resizing, moving, and deleting
graphic images

When you add graphics to a slide, you may need to resize or move them to
another location. To resize a graphic image, follow these steps:

1. Click the graphic (picture, clip art, screenshot, or WordArt) that you
want to resize.
PowerPoint displays handles around your chosen object.

2. Move the mouse pointer over a handle.
The mouse pointer turns into a two-way pointing arrow.

3. Hold down the left mouse button and drag (move) the mouse.
PowerPoint resizes your chosen graphic image.

4. Release the left mouse button when you’re happy with the new size of
your graphic image.

To move a graphic image, follow these steps:

1. Move the mouse pointer over the edge of the graphic image you want
to move.
The mouse turns into a four-way pointing arrow.

2. Hold down the left mouse button and drag (move) the mouse.
PowerPoint moves your graphic image.

3. Release the left mouse button when you’re happy with the new posi-

tion of your graphic image.

After you add a graphic image to a slide, you may later decide to delete it. To
delete a graphic image, follow these steps:
1. Click the graphic image you want to delete.
PowerPoint displays handles around your chosen graphic image.
2. Press Delete.

PowerPoint deletes your chosen graphic image.
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Rotating graphics

You may want to rotate graphic images for added visual effects. To rotate
images or to flip them vertically or horizontally, follow these steps:
1. Click the graphic image you want to rotate.

PowerPoint displays handles around your image along with a green
rotate handle.

2. Move the mouse pointer over the rotate handle.
The mouse pointer turns into a circular arrow.
3. Hold down the left mouse button and move (drag) the mouse.
<P PowerPoint rotates your graphic image.

If you hold down the Shift key while dragging the mouse, you can rotate
an image at 15-degree increments.

4. Release the left mouse button when you’re happy with the rotation of
the image.

Layering objects

PowerPoint treats graphics and text boxes (see Chapter 11) as objects that
you can move around on a slide. If you move one object over another, it may
block part of another object, as shown in Figure 12-9.

When one object covers another one, PowerPoint considers the first object to
be on top and the other object (the one being obscured) to be on the bottom.
By moving objects from top to bottom (or vice versa), you can create unique
visual effects (or just cover up parts of other objects by mistake).

To move a graphic image to the top or bottom when layered over another
object, follow these steps:
1. Click the graphic image you want to move.
The Format contextual tab appears.
2. Click the Bring Forward or Send Backward icon in the Arrange group.
<P PowerPoint rearranges the layering of your graphic images.

You can also right-click on an object and choose the Bring Forward or
Send Backward command.
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Adding Movies to a Slide

Besides adding static graphic images, you can also add movies to a slide so
that they play as part of your presentation. You can add two types of movies:
simple graphic animations (animated GIF files) included with PowerPoint or
movie files that you can download off the Internet or capture with a digital
video camera.

Adding an animated cartoon to a slide

PowerPoint includes a library of simple animated cartoons that you can place
on a slide for added visual emphasis. To include one of these animated car-
toons on a slide, follow these steps:

1. Click the slide (in either Slide or Outline view) to which you want to
add an animated cartoon.

2. Click the Insert tab.
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. Click the Clip Art Pane icon in the Images group.

The Clip Art pane appears (refer to Figure 12-7).

. Click in the Results should be: list box.

A menu appears listing check boxes for you to choose the type of clip
art images to find, as shown in Figure 12-10.

5. Select the Videos check box and clear all the other check boxes.

6. Click in the Search for: text box and type the topic you want to find.

Then click the Go button.

PowerPoint lists all animated cartoons that match your search criteria.

. Double-click on the animated image you want to place on your slide.

PowerPoint displays the image on your slide. You may need to move or
resize it.

You won'’t see the animated cartoon in action until you view your presentation

by pressing F5.
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Adding a movie to a slide

PowerPoint slides can also display a movie. When you store a movie on a
slide, you can resize its size and move it anywhere on your slide. In case you
need to modify it, PowerPoint will even let you trim parts of your video.

PowerPoint can use movies stored in common video formats such as AVI,
MPEQG, ASF (streaming video), QuickTime, Flash, and WMYV files. If your movie
is stored in a different file format, such as Real Video, you must convert the
file before you add it to a PowerPoint presentation.

To add a movie to a slide, follow these steps:
1. Click the slide (in either Slide or Outline view) to which you want to
add a movie.
2. Click the Insert tab.
3. Click the top half of the Video icon in the Media group.
The Insert Video dialog box appears.

If you click the downward-pointing arrow underneath the Video icon, a
pull-down menu appears. Choose Video from File.

4. Click the movie file you want to add and then click OK.

PowerPoint displays your video on the slide. If you click on the video,
PowerPoint displays a Format tab underneath a Video Tools heading, as
shown in Figure 12-11.

If you click the Play button on the Format tab, you can view your video.

Trimming a video

Before you add a video to your PowerPoint presentation, take a moment to
edit it by using a video-editing program. However, you may still add a video
to your presentation and suddenly realize that the video is too long. To fix
this problem, PowerPoint lets you trim a video from the beginning or end.

To trim a video, follow these steps:
1. Click the slide (in either Slide or Outline view) that contains the video
you want to trim.
2. Click on the video.
The Format and Playback tabs appear.
3. Click the Playback tab and then click the Trim Video icon.

The Trim Video dialog box appears, as shown in Figure 12-12.
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4. To trim the beginning of the video, drag the Beginning Marker to the
right or click the Up/Down arrows in the Start Time box.

5. To trim the end of the video, drag the Ending Marker to the right or
click the Up/Down arrows in the End Time box.

6. Click the OK button.

PowerPoint displays your trimmed video on the slide.

Coloring a video

To spice up the appearance of a video, you can modify its brightness, con-
trast, or color. Modifying one or more of these options can correct flaws in
a video or just create unique visual effects that might make your video more
memorable.

To change the color of a video, follow these steps:
1. Click the slide (in either Slide or Outline view) that contains the video
you want to trim.
2. Click on the video that you want to format.
The Format and Playback tabs appear.
3. Click the Format tab.
4. Click the Corrections icon in the Adjust group.
A menu appears, letting you choose different brightness settings.
5. Click on the brightness and contrast option.
A menu appears, letting you choose different contrast settings.
6. Click the color icon in the Adjust group.

A menu appears, letting you choose different color settings.

Formatting the shape of a video

To make your video appear even more visually interesting, PowerPoint lets
you modify the shape of the video. Instead of appearing as a boring rectangle,
your video can now appear with shadows, in shapes like a triangle or arrow,
or with a frame around it.

To format the shape of a video, follow these steps:

1. Click the slide (in either Slide or Outline view) that contains the video
you want to trim.
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2. Click on the video that you want to format.
The Format and Playback tabs appear.
3. Click the Format tab.
4. Click the Video Shape icon in the Video Styles group.

A menu appears, letting you choose a shape to format your video, as
shown in Figure 12-13.
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5. Click the Video Border icon in the Video Styles group.
A color palette appears, letting you choose a color for your border. If
you click the Weight or Dashes option from this color palette, you can
choose a border thickness and style, such as a dotted line.
6. Click the Video Effects icon in the Video Styles group.
A menu appears, letting you choose from different effects such as
<P Shadow or Rotation, as shown in Figure 12-14.

If you click on a style in the Video Styles group, you can choose a pre-
defined appearance for your video.
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Figure 12-14:
The Video
Effectsicon
menu lets
you choose
unique
appearances.
|

Presentstionz - Microsoft PowerPoint 85 | = @ B

il _..1‘-'_;:; _;I el Nnim b
‘ Horses flee ¢ g wea . =
4 il
y =S —.
— A—"
—— — iuﬂmmmn- ; ; ;
m_ Tiwnes
E = 3
EEH 3
E = 4
Iestiee -
> o =4 =i 7|
] shedow Optans. - —
Click to add notes
Slide 2 of 3 | “Office Theme™ | o5 | Bl =0 {+) £

Adding Sound to a Slide

Sound can be as simple as a sound effect (like a gun firing to wake up people
in the middle of your presentation) or a recorded speech from the CEO,
explaining why everyone’s going to be forced to take a 25 percent pay cut
while the CEO gets a golden parachute of $500,000 a year for the rest of his
life.

PowerPoint can use audio files stored in common formats such as AIFF, MIDI,
MP3, and WAV files. If your audio file is stored in a different file format, such
as Real Audio, you have to convert the file before you add it to a PowerPoint
presentation.

Adding an audio file to a presentation

If you already have music, sound effects, or a speech stored as a file, such
as an MP3 file, you can add it to your presentation. To add an audio file to a
slide, follow these steps:
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1. Click the slide (in either Slide or Outline view) to which you want to
add an audio file.

2. Click the Insert tab.

3. Click the top half of the Audio icon in the Media group.
An Insert Audio dialog box appears.

4. Click the audio file you want to add and then click Insert.

PowerPoint adds your audio file to the currently displayed slide (repre-
sented as a horn icon). You may want to move the sound icon on your
slide so it doesn’t obscure part of your slide.

“&N\BEH
<
< To hear your audio file, click on the audio file to display a Play button under-
neath. Then click the Play button.
Recording audio
For greater flexibility, PowerPoint lets you record audio directly from your
computer’s microphone (if you have one, of course). Recorded audio lets you
or someone else (such as the CEO) make comments that you can insert and
play into your presentation.
To record audio for your presentation, follow these steps:
1. Click the slide (in either Slide or Outline view) to which you want to
add an audio file.
2. Click the Insert tab.
3. Click the bottom half of the Audio icon in the Media group.
A pull-down menu appears.
4. Choose Record Audio.
A Record Sound dialog box appears, as shown in Figure 12-15.
|
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5. Click in the Name text box and type a description for your recording.
6. Click the Record button and start talking.
7. Click the Stop button and click OK.

PowerPoint displays your recording as a horn icon on the slide. You
may want to move this horn icon to keep it from obscuring part of
MBER your slide.

S

Y
< The horn icon that represents an audio file won’t appear when you show off
your presentation.



Chapter 13
Showing Off a Presentation

In This Chapter

Spell-checking a presentation

Organizing slides

Adding visual transitions
Adding hyperlinks on a slide
Viewing a presentation
Printing handouts

rle whole point of creating a PowerPoint presentation is to show it off to
an audience. To help you keep an audience’s attention, PowerPoint pro-
vides Hollywood-style special effects to make your presentation look more
interesting.

PowerPoint also provides features for creating handouts for your audience.
Because people often want to take notes during an interesting presentation
(or just doodle during a really boring presentation), PowerPoint can create
handouts that you can print and distribute.

Spell-Checking Your Presentation

You could have the best presentation in the world, but it will look like the
worst presentation in the world if you have misspellings and typos on your
slides for everyone to snicker at. To prevent this problem from occurring,
PowerPoint can spell-check your entire presentation.
W PowerPoint automatically underlines all misspelled words with a red squiggly
line. If you right-click any word underlined with a red squiggly line, a pop-up
menu appears with a list of correctly spelled alternatives that you can choose.
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To spell-check your entire presentation, follow these steps:

1. Click the Review tab.
2. Click the Spelling icon.

PowerPoint displays the Spelling dialog box when it finds a misspelled
word, as shown in Figure 13-1.

— Stealing Offfice Supplies for Fun
Figure 13-1: and Profit
The Spelling e e O R i i
dialog box Click to add subtitle
can identify Spulling )|
potential NenOeenwy, | Offfen
misspellings I it e e
and offer
corrections. e —
3. Choose one of the following for each word that PowerPoint highlights
as misspelled:
® Change: Click the correct spelling of the word and then click
Change. (Click Change All to change all identical misspellings
throughout your presentation.)
e Ignore All: Click Ignore All to ignore all instances of that word
throughout your presentation.
e Add: Click Add to add the word to the PowerPoint dictionary so it
won'’t flag the word as misspelled again.
4. Click Close to stop spell-checking.
CMBER . . )
@“ PowerPoint won’t recognize technical terms, proper names, or correctly

< spelled words used incorrectly, such as using the word there instead of their,

so it’s important to also proofread your presentation yourself.
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Organizing Slides in Sections

Figure 13-2:
The Section
menu lets
you group
slides
together.
|

PowerPoint displays all the slides of your presentation in the Slides or
Outline view. While this makes it easy to see all the slides that make up your
presentation, such a long list of slides can make it hard for you to find any
particular slide.

To help you avoid searching for a single slide among a huge list, PowerPoint
gives you the option of organizing in groups called sections. You might group
the first slides in one section (labeled “Problems”), the next 7 slides in a
second section (labeled “Consequences™), and the last 13 slides in a third
section (labeled “My Solutions”).

After grouping slides into sections, you can selectively hide or display all
slides in a section. Sections simply help you organize a large presentation of
slides so you can find and edit particular slides at any given time.

Adding a section

By default, presentations don’t contain any sections. When you add a section,
PowerPoint groups all slides in that section, starting with the first slide you
picked all the way to the end of your presentation or the next section head-
ing, whichever comes first.

To add a section to a presentation, follow these steps:

1. Click on the slide that you want to define the beginning of a section.
2. Click the Home tab and click the Section icon under the Slides group.

A pull-down menu appears, as shown in Figure 13-2.
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3. Choose Add Section.

PowerPoint displays a section heading (named Untitled Section) above
the slide you selected in Step 1; refer to Figure 13-2.

4. Click on the selection heading, click the Section icon in the Slides
group, and choose Rename Section.

A Rename Section dialog box appears, as shown in Figure 13-3.
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5. Click in the Section name: text box and type a descriptive name for
your section. Then click Rename.
PowerPoint renames your chosen section.
CMBER . , . .
é,\“ When you add a section to a presentation, PowerPoint automatically creates

a Default Section that contains the first slide and all additional slides up to the
section heading you just created.

Expanding and collapsing a section

After you've created at least one section, you can collapse (and expand it).
Collapsing a section temporarily hides those slides in that section from view
so you can focus on the rest of your slides. Expanding a section makes the
slides in that section appear again.

To expand and collapse a section, follow these steps:
1. Click on the Collapse Section arrow that appears to the left of the sec-

tion name, as shown in Figure 13-4.

PowerPoint collapses your chosen section and displays the number of
slides(in parentheses) hidden in that collapsed section, as shown in
Figure 13-5.

2. Click the Expand Section arrow that appears to the left of the col-
lapsed section name.

The section expands, displaying all slides within that section.
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Deleting a section

Sections can help divide a large presentation into more manageable chunks,
but you might eventually decide you don’t need a section anymore. When
you delete a section, you have the option of just deleting the section (and
leaving the slides intact) or deleting both the section and all slides inside that
section.

To delete a section, follow these steps:

1. Right-click on the section name that you want to delete.
PowerPoint displays a pop-up menu, as shown in Figure 13-6.

2. Choose Remove Section (to remove your chosen section), Remove
All Sections (to remove all sections), or Remove Section & Slides (to
remove your chosen section and all the slides in that section).

PowerPoint deletes your section (or sections).
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Adding Uisual Transitions

Transitions define how slides or part of a slide (text or graphics) appear
during your presentation. By default, slides appear one at a time with all the
text and graphics displayed at once, which can get monotonous.

To spice up your presentation, PowerPoint offers two types of transitions:

v~ Slide transitions

° v Text and picture transitions
A

Use transitions sparingly. Transitions may be visually interesting, but too
many transitions can be distracting.

Adding slide transitions

Slide transitions can make a slide appear to melt or break into multiple
pieces that slip away, revealing the next slide underneath.

When creating a transition, you need to define the following:

v The actual visual appearance of the transition
v The speed of the transition (Slow, Medium, or Fast)

v Any sound effects you want to play during the transition (these can get
really annoying, so use them sparingly)

v When to display the transition (after a certain time period or when you
click the mouse)

To create a slide transition, follow these steps:

1. Click a slide (in the Slide or Outline view pane).

Any transition you choose will end by displaying the slide you choose in
this step.

2. Click the Transitions tab.

PowerPoint displays the different animation (transition) tools, as shown
in Figure 13-7.
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3. Click the More button of the Transition To This Slide group.

A pull-down menu appears, listing all the different transitions available.
4. Click the transition you want.
5. (Optional) Click in the Sound list box in the Timing group.

A pull-down menu appears, listing all the sound effects you can choose,
as shown in Figure 13-8.
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6. (Optional) Select the On Mouse Click or After check box.

If you select the After check box, you have to specify a time to wait
before running the transition.
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You can select both the On Mouse Click and Automatically After check
boxes, so the slide transition waits until you click the mouse or until a
certain amount of time passes.

7. (Optional) Click Apply to All to apply your transitions to every slide in
your presentation.
CBER . . : . ,
D Applying the same transition throughout your presentation can give your slide
<& : : . . o
show a consistent look, but it’s best for only simple, visual transitions and not

for transitions that involve noisy sound effects that get tedious after awhile.

Text and graphic transitions

Besides animating how your slides appear and disappear, you can also add
transitions to your text boxes or graphics so they fly or drop into place
across a slide.
CMBER . - . -
D Use text and graphic transitions sparingly because the transitions can get
S ; . . - : .
distracting when people just want to read your presentation without having to
watch letters zoom around the screen.

To create a simple text or graphic transition, follow these steps:

1. Click a text box or picture on a slide.
PowerPoint displays handles around your chosen item.
2. Click the Animations tab.

3. Click the More button in the Animations group to display a menu of
options, as shown in Figure 13-9.

4. Click an animation, such as Fly In or Wipe.

PowerPoint displays a number near your chosen item. These numbers
define the order that your transitions will appear.

5. Click the top half of the Preview icon to see how your animation will
(MBER look.
To remove a transition, just select that text box or graphic, click the
Animations tab, and choose No Animation from the Animation group.

277
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Using the Animation Painter

If you create a transition that you want to apply to other text boxes or

graphic objects, you could tediously re-create that transition all over again.
However, it’s much simpler to use the Animation Painter, which lets you copy
transitions from one object to another.

To use the Animation Painter, follow these steps:

1. Click on a text box or picture that contains the transition you want to
copy.

PowerPoint displays handles around your chosen item.

2. Click

the Animations tab.
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3. Click the Animation Painter icon under the Advanced Animation
group.
4. Click on a text box or picture.

PowerPoint applies the transition, from the object you selected in Step
1, to the object you selected in Step 4.

Adding Hyperlinks

For greater flexibility in presenting information, PowerPoint lets you add
hyperlinks to your slides. Hyperlinks let you open a Web page (provided you
have an Internet connection) or a file (such as a Word document). By adding
hyperlinks to your slides, you can display additional information stored out-
side of your PowerPoint file.

Creating Web page hyperlinks

A Web page hyperlink lets you convert text into a hyperlink that can load
your default browser and display any Web site. When you exit the browser
(or just switch back to PowerPoint), you can see your slide again and con-
tinue with your presentation.

By accessing a Web site, you can avoid copying data and pasting it on a slide.
For example, if you're giving a presentation about advertising, you can create
Web page hyperlinks to show how your competitors use the Internet to
advertise and sell their products.

To create a Web page hyperlink, follow these steps:
1. Highlight the text in a title or subtitle text box that you want to turn
into a Web page hyperlink.
2. Click the Insert tab.
3. Click the Hyperlink icon in the Links group.
An Insert Hyperlink dialog box appears, as shown in Figure 13-10.

4. Click in the Address text box and type a Web site address, such as
www.dummies.com.

5. Click OK.

PowerPoint underlines the text you selected in Step 1. When you view
your presentation, PowerPoint turns the mouse pointer into a hand icon
when you move the mouse over the hyperlink. Clicking on your hyper-
link loads the default browser.


www.dummies.com
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Creating hyperlinks to external files

You may have data stored in another file that you want to include in your
PowerPoint presentation. Rather than copy the data and paste it in your
presentation, it may be easier just to display the file itself. That way you can
update the file, and PowerPoint will always link to the updated file.

When you create a hyperlink to a file, PowerPoint opens that file by loading
the program that created it. For example, if you want to view a Microsoft Word
file, make sure that you have a copy of Microsoft Word installed on your
computer.

To create a hyperlink that opens an external file, follow these steps:
1. Highlight the text in a title or subtitle text box that you want to turn
into an external file hyperlink.
2. Click the Insert tab.
3. Click the Hyperlink icon in the Links group.
The Insert Hyperlink dialog box appears (refer to Figure 13-10).

4. Click in the Look In list box and choose a drive and folder that holds
the file you want to use.

You may need to click through several folders to find the file you want.

5. Click the file you want to use and then click OK.

Running a program through a hyperlink

A PowerPoint hyperlink can also run any program from within a presentation.
For example, you could create a presentation that explains how to market a
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new computer program, and then create a hyperlink to that same program so
you can demonstrate how that program actually works. When you exit that
program, you return to your PowerPoint presentation again.

Make sure that your computer has enough memory to run both PowerPoint
and any other program you want to run.

To create a hyperlink that runs a program, follow these steps:

1.

Highlight the text in a text box that you want to turn into a program
hyperlink.

2. Click the Insert tab.

. Click the Action icon in the Links group.

The Action Settings dialog box appears.

4. Select the Run Program radio button.

5. Click Browse.

The Select a Program to Run dialog box appears.

. Click in the Look In list box to choose the drive that contains the pro-

gram you want to run.

. Click in the folder and then click Open to find the program you want

to run.

You may have to repeat this step multiple times.

. Click the program you want to run and then click OK.

The Action Settings dialog box appears again.

. Click OK.

Viewing a Presentation

After you finish arranging your slides, adding transitions, and adding hyper-
links, you're ready to test how your entire presentation looks. To view your
entire presentation, follow these steps:

\\3

1. Click the Slide Show tab.
2. Click the From Beginning icon in the Start Slide Show group, as shown

in Figure 13-11.
PowerPoint displays the first slide of your presentation.

You can also choose the From Beginning command by pressing F5.

281
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3. Choose one of the following:
e Click the mouse or press the spacebar to view the next slide.
® Press Esc to exit your presentation.
If you have a large presentation consisting of 300 slides, you may not want to

view the first 290 slides just to test how your last 10 slides look. To avoid this
problem, click the From Current Slide icon in Step 2.

Creating a custom slide show

You may have a presentation organized for one audience (engineers and sci-
entists) but need to give the same presentation to a different audience (sales
executives). Although you could copy your original presentation and then
modify it, now you’ll be stuck with two copies of the same information. And,
if you modify the information in one presentation, you have to modify the
same information in the second (or third or fourth) presentation.

To avoid this problem, PowerPoint lets you create custom slide shows based
on an existing presentation. Such a custom slide show can selectively show
slides in a different order. To create a custom slide show, you need to define
the order you want to display the slides.

To arrange the order of a custom slide show, follow these steps:

1. Click the Slide Show tab.

2. Click the Custom Slide Show icon in the Start Slide Show group.
A pull-down menu appears.

3. Choose Custom Shows.

The Custom Shows dialog box appears, as shown in Figure 13-12.
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The Define Custom Show dialog box appears, as shown in Figure 13-13.

. Click in the Slide Show Name text box and type a name for your

custom slide show.

. Click a slide in the Slides in Presentation list box and then click the

Add button.

This tells PowerPoint which existing slides you want to reuse in your
custom slide show.

. Repeat Step 6 for each slide you want to include in your custom slide

show.
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10.

11.

Down arrow button to rearrange their order.

. Repeat Step 8 for each slide you want to rearrange in your custom

slide show.
Click OK.
The Custom Shows dialog box appears again.

Click the name of your custom slide show and then click Close.
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To present a custom slide show, follow these steps:

1. Click the Slide Show tab.
2. Click the Custom Slide Show icon in the Start Slide Show group.

A pull-down menu appears that lists the names of all the custom slide
shows you’ve created.

3. Click the name of the custom slide show you want to view.
4. Choose one of the following:
e Click the mouse or press the spacebar to view the next slide.

¢ Press Esc to exit your presentation.

Hiding a slide

PowerPoint can hide a slide, which lets you keep your slide but not display it
during a presentation. Hiding a slide can be especially handy when you need
to create a custom slide show and need a slide to appear only in the custom

slide show but not the original presentation (or vice versa).

To hide a slide, follow these steps:

1. Click the slide that you want to hide (in Slide or Outline view).
2. Click the Slide Show tab.
3. Click the Hide Slide icon in the Set Up group.

PowerPoint dims your selected slide.

To unhide a slide, just repeat the preceding three steps.

Organizing with Slide Sorter view

After you view your presentation, you may want to rearrange slides. To help
you organize your presentation, switch to Slide Sorter view, which numbers
each slide to show you the order that they appear, as shown in Figure 13-14.

To use Slide Sorter view, follow these steps:

1. Click the View tab.
2. Click the Slide Sorter view icon in the Presentation Views group.

You can also click the Slide Sorter icon in the bottom-right corner of the
PowerPoint window.
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3. (Optional) To delete a slide, click on a slide and press Delete.

4. (Optional) To hide a slide, click on a slide, click the Slide Show tab,
and click Hide Slide.

5. (Optional) To move a slide
a. Move the mouse pointer over a slide.
b. Hold down the left mouse button and move (drag) the mouse.
PowerPoint displays a vertical line where it will place your slide.
c. Release the left mouse button.

6. Click the Normal icon on the View tab to switch out of Slide Sorter view.

Creating Handouts

When people view a particularly interesting presentation, they often want
copies of that presentation so they can review the information later or have
a place to jot down notes during the presentation itself. For that reason,
PowerPoint lets you create handouts from your presentation.

Chapter 13: Showing Off a Presentation 285



2 8 6 Part IV: Making Presentations with PowerPoint

Handouts typically contain a thumbnail of each slide along with blank space
for jotting down notes about the information presented by that slide. To
create a handout, follow these steps:
1. Click the File tab.
The Backstage View appears.
2. Choose Print.

The middle pane displays a variety of print options, as shown in
Figure 13-15.

3. Click the Full Page Slides button in the middle pane under the
Settings heading.

A menu appears showing different ways to print slides, as shown in
Figure 13-16.

4. Choose the print option you want, and then click the Print button in
the top of the middle pane when you’re ready to start printing.
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“Tt’s gour wife My, Dinker. Shall T have

her take a seat in the closet, or do you

want to schedule a meeting in the Kitchen
for later this afternoon?”




In this part . . .

ardly anyone feels organized. After a few days on

the job, most people wind up cluttering their desks
with piles of memos, reports, books, and papers. If you'd
rather use the surface of your desk for writing rather than
a disorganized filing cabinet, then you may need the help
of Microsoft Outlook, a combination e-mail program and
personal organizer.

By using Outlook with your e-mail account, you can
search, sort, and organize your messages so you an see
what’s important (fun stuff like messages from your
friends) while ignoring the annoying messages (like notes
from your boss).

Besides helping you organize your e-mail, Outlook can
also be your personal organizer, helping you keep track of
tasks that you need to get done and appointments you
need to keep.

To help you keep track of all the people in your life,
Outlook lets you store names, addresses, e-mail
addresses, and phone numbers of all your important con-
tracts so you’ll be able to find and contact someone right
away.

By helping organize your life, Outlook gives you time to do
what you do best — working more productively or just
gathering more information to store on your computer
that can give your boss the illusion that you're actually
doing something important after all.




Chapter 14
Managing E-Mail with Qutlook

In This Chapter

Configuring e-mail account settings

Creating e-mail
Adding file attachments
Reading e-mail

Deleting e-mail

M icrosoft Outlook is the personal organizer portion of Office 2010,
able to handle information such as your appointments, names and

addresses of important people, and list of to-do tasks. However, the most
popular uses for Outlook are reading, writing, and organizing your e-mail.

Configuring E-Mail Settings

The first time you run Outlook, you need to configure your e-mail account
information. To retrieve e-mail from your account within Outlook, you may
need to know the following:

v Your name

v The username of your e-mail account, which might be JSmith (for Joe
Smith)

v Your e-mail address (such as JSmith@microsoft.com)

v Your e-mail account password

» Your e-mail account type (such as POP3 or IMAP)

v Your incoming mail server name (such as pop.microsoft.com)

v Your outgoing mail server name (such as smtp.microsoft.com)
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Outlook can often recognize many popular e-mail accounts such as Hotmail,
but if Outlook can’t set up your e-mail account automatically, you will need to
ask your Internet service provider (ISP) for all these details.

Adding an e-mail account

Before you can use Outlook to manage your e-mail, you must add your e-mail
account. To add a new e-mail account, follow these steps:
1. Load Outlook and click the File tab.
The Backstage View appears.
2. Click Info and then click the Add Account button.

An Add New Account dialog box appears, as shown in Figure 14-1.
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3. Type in the appropriate information and click Next.
You may need to wade through several sets of questions before Outlook
can properly configure your e-mail account.

To delete an e-mail account, right-click on the account name in the left panel
of the Outlook window. When a pop-up menu appears, choose Remove.

Creating E-Mail

After you set up an e-mail account, you can start sending e-mail. The three
ways to create and send e-mail are
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1 Create a message and type the recipient’s e-mail address manually.

+” Reply to a previously received message. Outlook then adds the recipi-
ent’s e-mail address automatically.

1 Create a message and use a previously stored e-mail address. Outlook
adds the e-mail address automatically.

Creating a new e-mail message

The most straightforward way to send a message is to type the recipient’s
e-mail address and then type your message. To create a new e-mail message
and type the e-mail address, follow these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.

2. Click the Home tab and click the New E-mail icon in the New category.

The message window appears, as shown in Figure 14-2. Notice that the
message window displays a Ribbon with Message, Insert, Options, and
Format Text tabs.
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3. Click in the To text box and type the e-mail address of the person you
want to receive your message.

Make sure that you type the e-mail address correctly. One incorrect
character, and your message won’t go to your intended recipient.

4. (Optional) Click in the Cc text box and type another e-mail address to
send the message to more than one person.

5. Click in the Subject text box and type a brief description of your
message.

Many people use spam filters that examine the Subject line of a mes-
sage, so it’s a good idea not to type your subject text in ALL CAPITAL
LETTERS or use multiple exclamation points!!! Otherwise, your recipi-
ent’s spam filter may inadvertently flag your message as spam and
delete it before anyone can even read it.

6. Click in the message text box and type your message.

If you click the Save icon on the Quick Access toolbar, you can store the
message in your Drafts folder so you can edit and send it at a later time.

7. Click the Send icon to send your message.

Replying to an e-mail message

Oftentimes, you may receive a message from someone else and want to send
areply to that person. When you send a reply, Outlook automatically copies
the original message as part of your e-mail; that way, the recipient can read
the original message that you’re responding to.

Even better, when you reply to a message, you won’t have to retype the
recipient’s e-mail address and risk misspelling it. To reply to an e-mail mes-
sage, follow these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.

2. Click the Inbox folder.

Outlook displays the Inbox pane that lists all the messages you've
received.

3. Click a message that you want to reply to.

Outlook displays the contents of that message in a pane on the right
side of the Outlook window.
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4. Click the Home tab and click the Reply icon in the Respond category.

Outlook displays a message window with the recipient’s e-mail address
and subject line already typed in, along with a copy of the original
message.

If you click the Forward icon instead of the Reply icon, you can send a
message to another person instead of the person who originally sent
you the message.

5. Click in the message text box and type your message.

If you click the Save icon on the Quick Access toolbar, you can store the
message in your Drafts folder so you can edit and send it at a later time.

6. Click the Send icon.

Using a stored e-mail address to
create a new e-mail message

If you send e-mail to certain people regularly, you can type that person’s
e-mail address once, store it, and then have Outlook type that e-mail address
whenever you need it again.

To store an e-mail address, follow these steps:
1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.

2. Click the Home tab and click the Address Book icon in the Find
category.

The Address Book: Contacts window appears, as shown in Figure 14-3.
3. Choose File=>New Entry.

A New Entry dialog box appears.
4. Choose New Contact and click OK.

A Contact window appears, as shown in Figure 14-4.
5. Click in the Full Name text box and type a person’s name.
6. Click in the E-mail text box and type a person’s e-mail address.
7. Click the Save & Close icon.

Your newly added name appears in the Address Book: Contacts window.
8. Choose Filew>Close.
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After you have stored at least one name and e-mail address, you can retrieve
that e-mail address to send a message by following these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))

Outlook displays the Mail pane.
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. Click the Home tab and click the New E-mail icon in the New category.

The Message window appears.

. Click the To button.

The Select Names: Contacts dialog box appears, listing all your stored
names and e-mail addresses.

4. Click a name to select it.

5. Click the To button at the bottom of the Select Names: Contacts

dialog box.

. Click OK.

Outlook automatically enters your chosen e-mail address in the To
text box.

. Click in the Subject text box and type a brief description of your

message.

. Click in the message text box and type your message.

If you click the Save icon on the Quick Access toolbar, you can store the
message in your Drafts folder so you can edit and send it at a later time.

. Click the Send icon to send your message.

Attaching Files to Messages

\NG/
g“‘“

Rather than just send plain text, you can also attach a file to your message.
This file can be anything from a picture, a song (stored as an audio file), a
program, a video file, or even another e-mail message.

Be careful when attaching files to messages because many ISPs put a limit on
the maximum size of an e-mail message, such as 10MB. Also try to keep any
file attachments small because if the recipient has a slow Internet connection,
downloading a large file attachment can take a really long time.

If you want to send someone a picture, video, audio file, compressed file, or
even an entire program, you need to attach that file to a message by following
these steps:

1. Follow the steps in the earlier section, “Creating E-Mail,” to create a

new e-mail message, type a subject, and type an e-mail address.

2. Click the Insert tab.
3. Click the Attach File icon in the Include group.

The Insert File dialog box appears.

297
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4. Click the file you want to attach to your message and then click Insert.

Outlook displays an Attach text box in the message window, as shown in
<P Figure 14-5.

If you hold down the Ctrl or Shift key while clicking a file, you can select
multiple files at once.
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5. (Optional) Click the Attach button to display the Insert File dialog box
so you can select more files.

6. (Optional) Right-click any file in the Attachment text box; when a
pop-up menu appears, choose Remove if you change your mind about
attaching a file to a message.

7. Click the Send icon.
Rather than select multiple files to attach to a message, you can compress or

zip multiple files into a single compressed file by using a separate program
like WinZip or by using the built-in Zip compression feature in Windows.
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Reading and Organizing E-Mail

One of the biggest problems with receiving e-mail is trying to sort through
all the important messages. To help you organize your e-mail, Outlook offers
several ways to group related messages together and search for specific text
in messages so you can find exactly what you need.

Figure 14-6:
Clicking the
Arrange

by column
displays

a menu of
other ways
to organize
e-mail.
|

Grouping messages into categories

Outlook can display messages with the newest message on top and the oldest
message at the bottom (or vice versa). In addition, Outlook can also group
messages according to Date, Subject, Size, or even by e-mail accounts.

To view and sort your e-mail messages, follow these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press

Ctrl+1)

Outlook displays the Mail pane.

2. Click the Arrange by column heading in the middle pane.

A pop-up menu appears, as shown in Figure 14-6.
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3. Click on a category such as Date or Conversation.
4. Click in the Newest on top column heading.

Each time you click this heading, it toggles to display Newest on top or
Oldest on top.

Viewing messages in the conversation view

By default, Outlook organizes received messages by Conversation. This
essentially keeps all messages that you reply to and get a response back
grouped together so you can review the flow of the conversation from each
message.

To view a conversation, follow these steps:
1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.

2. Click the Arrange by column heading in the middle pane and choose
Conversation.

3. Click on a message.

If you have replied to this message and received replies before, Outlook
displays a list of related messages received, as shown in Figure 14-7.
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4. Click on any message underneath the message you selected in Step 3.

Outlook displays your chosen message so you can review the trail of
messages that led up to the latest message.

Retrieving a file attachment
from a message

Rather than just send text, people might send you pictures, word processor
documents, or databases as file attachments. When you receive a message
with a file attachment, Outlook displays a paper clip icon next to the message.

Never open a file attachment unless you absolutely trust its contents. Many
malicious hackers send viruses, worms, spyware, and Trojan Horses as file
attachments, so if you aren’t careful, you could accidentally infect your com-
puter and lose your data.

To open a file attachment, follow these steps:

1. Click a message that displays a paper clip icon.

Outlook displays the message’s contents in the right pane of the Outlook
window, as shown in Figure 14-8.
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2. Double-click the file (paper clip) icon displayed in the message.

Your chosen files appear.
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If you right-click on the paper clip icon in Step 2, a pop-up menu appears. Then
you can click Preview and see a preview of the file contents without opening it.

Deleting E-Mail Messages

To keep your Inbox folder from getting too cluttered, you can always delete
messages that you're sure you'll never need to read again. To delete a mes-

sage, follow these steps:
1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.
2. Click a message in the Mail pane that you want to delete.

3. Press Delete or click the Home tab and click the Delete icon in the

Delet .
o elete group

If you accidentally delete the wrong e-mail message, you can undelete it by
pressing Ctrl+Z or clicking the Undo icon in the Quick Access toolbar.

When you delete messages, Outlook stores them in the Deleted Items folder
so you can always retrieve them later. To retrieve a deleted message, follow
these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))
Outlook displays the Mail pane.

2. Click on the Deleted Items icon in the Mail Folders pane.
A list of deleted e-mail messages appears.

3. Right-click on a deleted message and choose Mover>Other Folder.

The Move Items dialog box appears, as shown in Figure 14-9.

Move tems

Maove the selected items to the flder:
Fl 3:-,:1 bothecat@prodigy.net - 0K
| Inbox (172)
=1 Sent Items
— = Deleted Items (1)
3 Drafts

Figure 14-9; ) Calendar

8] Contarts
Move an & Joumal
item to @ Junke E-mail (20)
News leed
another i
folder. L Outbux

E3) BSS Feeds
|




WING/
&

A\

4. Click a folder (such as Inbox) to store your message and then click OK.

Outlook removes your message from the Deleted Items folder and stores
it in the folder you chose.

If you delete a message from the Deleted Items folder, that message will be
gone forever. To clean out your Deleted Items folder (to save space or to

destroy incriminating e-mail messages), follow these steps:

1. Click Mail in the left pane of the Outlook window. (You can also press
Ctrl+1))

Outlook displays the Mail pane.
2. Choose one of the following:
¢ Click a message.
¢ Hold down the Ctrl key and click each message you want to delete.

¢ Hold down the Shift key, click the first message you want to delete,
and then click the last message you want to delete.

Outlook selects all the messages in between the first and last mes-
sages you selected.

3. Press Delete or click the Home tab and click the Delete icon in the
Delete group.

A dialog box appears, asking whether you’re sure that you want to
delete your selected messages.

If you delete any messages from the Deleted Items folder, you will not be
able to retrieve them ever again for the rest of eternity.

4. Click Yes (or No).

To help avoid unwanted e-mail messages, give out your e-mail address
sparingly. To find how to filter out unwanted messages, see Chapter 19
for tips on configuring Outlook to detect and block spam.

Chapter 14: Managing E-Mail with Outlook 303
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Chapter 15
Calendars, Contacts, and Tasks

In This Chapter

Setting an appointment

Storing names and addresses

Tracking your tasks

Outlook 2010 is more than just an e-mail program; it’s also a complete
personal organizer to help you keep track of appointments, names and
addresses, and to-do tasks. With Outlook helping keep your life organized,
you no longer have an excuse not to get anything done on time — unless, of
course, you really don’t want to do it.

Setting Appointments

Everyone can get busy and miss deadlines and appointments. To avoid this
problem, let Outlook keep track of your schedule. That way, you’ll know what
days and times you’ll be busy and when you'’ll be free to do anything else.

Making an appointment

Before you can add an appointment to Outlook, you need to decide which
day that appointment will occur and what time it will start. You can also add
details like how long it should last and where it takes place, but the impor-
tant part is to define the date and time. To do this, you need to look at the
Outlook calendar.

Outlook offers several ways to display its calendar:

v Day: Displays a single time divided into 24 hours
v Week: Displays a single week divided into five or seven days

v Month: Displays a single month divided into days
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Outlook lets you define starting and ending times of an appointment in half-
hour increments such as 1:30 or 11:00 whether you’re using the day, week, or
month calendar. To set an appointment, follow these steps:

1. Click the Calendar button in the left pane of the Outlook window (or
press Ctrl+2).
Outlook displays the Calendar view.

2. Click the Home tab and then click the Day, Work Week (5 days), Week
(7 days), or Month icon in the Arrange category.

Outlook displays the Calendar based on the time frame you chose, such
3 as Work Week or Month, as shown in Figure 15-1.

You can also click the New Appointment icon on the Home tab to define
an appointment.

3. Double-click the day (or time if you’re in the Day calendar) where you
want to schedule an appointment.

Outlook displays the Appointment window, as shown in Figure 15-2.
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. Click in the Subject text box and type a brief description of your

appointment, such as Another boring meeting with Mike or Meet with
reluctant client.

. (Optional) Click in the Location text box and type the location of your

appointment, such as Break Room 10 or Back alley near the dumpster.

If you often set appointments for specific locations, Outlook will remem-

ber the

se locations. In the future, just click the downward-pointing

arrow in the Location text box and then click a previously used location
in the list that appears.

. Click in the Start Time list box and choose a time.

You can also type a time directly in the Start time list box, such as 9:53,
or even choose a different date.

. Click in the End Time list box and choose a time.

You can also type a time directly in the End time list box, such as 2:23,
or even choose a different date.

. Click in the big text box and type any additional information you want

to store about your appointment, such as items you need to bring or
information you want to remind yourself about the person you're

meetin

g.
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9. Click the Save & Close icon in the Actions group.

Outlook displays your appointment in Day, Week, or Month view of the
calendar, as shown in Figure 15-3.

If you need to edit an appointment, just double-click on it to display the
Appointment window again. You can also drag an appointment from one loca-
tion on the calendar to another to switch it to a different time or date.

Viewing appointments

If you store several appointments, you might find it hard to keep track of
them all. To help you out, Outlook can display your appointments as a pic-
ture so you can see the times and dates when you have something planned.

To visually see your appointments, click the Home tab and then click the
Schedule View icon in the Arrange group. Outlook displays your appoint-
ments so you can quickly spot your free and busy times, as shown in
Figure 15-4.
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Deleting an appointment

After an appointment has passed or been canceled, you can delete it to make

room for other appointments. To delete an appointment, follow these steps:

1. Double-click on an appointment to open the Appointment window.
2. Click Delete (or press Ctrl+D).

Outlook deletes your appointment.

If you delete an appointment by mistake, press Ctrl+Z to recover it.

Storing Names and Addresses

Everyone has important names, addresses, e-mail addresses, and phone num-
bers that need to be saved. Rather than use Access or another complicated
database program to store this type of information, it’s much easier to use
Outlook.
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Adding a name

To store a name in Outlook, follow these steps:
1. Click the Contacts button in the left pane of the Outlook window (or
press Ctrl+3).
Outlook displays the Contacts view.
2. Click the Home tab and click the New Contact icon in the New group.

Outlook displays a Contact window, as shown in Figure 15-5.
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3. Type the information you want to store about each person, such as the
name in the Full Name text box.

You can store as much or as little data about a person as you want. For
example, you may not want to store someone’s home phone number or
IM (instant messaging) address.

4. Click the Save & Close button.

Outlook saves your information.
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Viewing names

After you've stored one or more names in Outlook, you’ll probably need to
find it again. If you just want to browse through your list of names, follow

these steps:

1. Click the Contacts button in the left pane of the Outlook window (or

press Ctrl+3).

Outlook displays the Contacts view.

2. Click the Home tab and click the Business Card or Card icon in the
Current View group.

The Business Card displays names and additional information as large
windows, as shown in Figure 15-6. The Card view displays names as
smaller windows, allowing you to see more names on the screen.

Search Contacts text box

Gates, Bill

billgates@microsatt.com

Steve Jobs

Apple b
CEQ

[408) SE5-1234Wnr
Tammed@appie.cam

ia

If you click on a name, you can delete it by clicking the Delete icon on

the Home tab.

3. Double-click on a name to open the Contact window.

The Contact window opens, allowing you to edit or add new information
to your chosen contact.
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Searching names

If you know all or part of a name or other information about a person,
you can exhaustively browse through your entire list of stored contacts.
However, it’s much easier to just search for that information instead.

That way, if you know you want to find a person named Bill, you just have to
search for “Bill.” Likewise, if you know you need to call someone located in
the 408 area code, you could just search for “408” and Outlook will show you
all contacts with a phone number in that particular area code.

Searching makes it easier to find a particular name. To search for a name,
follow these steps:

1. Click the Contacts button in the left pane of the Outlook window (or
press Ctrl+3).
Outlook displays the Contacts view.

2. Click the Home tab and click in the Search Contacts text box (or press
Curl+ E).

The cursor appears in the Search Contacts text box.

3. Type as much data as you can about the person you want to find, such
as typing all or part of a name or phone number.

4. Press Enter.

Outlook displays all contacts that match your search criteria that you
typed in Step 3.

5. Click the Close Search icon that appears at the far right of the Search
Contacts text box.

Outlook displays all your contacts once more.

Managing Tasks

Everyone’s busy. However, the big difference between busy, efficient people
and overwhelmed people is that busy people simply know how to manage
their tasks so they get things done.

To help you manage your tasks, Outlook lets you store your most impor-
tant tasks and assign due dates and priorities. Now at a glance, you can see
what’s most important for you to focus on. By spending more of your time on
important tasks and less of your time on trivial matters, you’ll become more
efficient (provided you actually do the work you’re supposed to be doing).
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Microsoft OneNote 2010

If you need to take notes in meetings, you're
probably dragging your laptop around and
typing notes in a Microsoft Word document.
There's nothing wrong with that, except by the
end of the meeting, your notes will appear in
one long document and you'll need to edit those
notes so you can keep track of everything you
wrote.

While you can use Microsoft Word to jot down
notes, you may prefer using a more specialized
note-taking program called Microsoft OneNote
2010. Like Microsoft Word, Microsoft OneNote
lets you type and store notes. However, the pro-
gram goes much farther than that.

OneNote lets you divide your notes into sec-
tions to help you find what you need. Instead
of typing everything on a single page like
Microsoft Word forces you to do, OneNote lets
you create one section for action items and
another section for upcoming meetings to keep
the project on track.

Now when you want to read your notes, you
don't have to scroll through endless pages like
in Microsoft Word. Instead, you can just flip to
the section that contains the information you
want to find. Think of the difference between
trying to find information printed on a scroll of
paper (Microsoft Word) or information orga-
nized in separate sections like tabs in a note-
book (OneNote).

Storing a task

If you have a microphone and a webhcam, you
can even capture audio and video to store in
your notes. That way you can capture an entire
classroom lecture or meeting in audio or video,
and then jot down notes at the same time. To
review, you can study your written notes as
well as replay the audio or video to catch some-
thing you might have missed earlier.

Because notes don't always rely on words,
OneNote also lets you draw pictures, which can
be handy for capturing ideas visually. Now you
can use both your left brain (words) and right
brain (pictures) to capture notes during any
classroom lecture or meeting.

More important, OneNote can link to Outlook
to share data. If you're in a meeting, you might
need to write down a task for yourself and a
future appointment. Now you could retype all
that information into Outlook later, or just trans-
fer that data from OneNote to Outlook with the
click of the mouse. By working with Outlook,
OneNote lets you capture information and store
itin Outlook so you can keep track of your busy
schedule.

OneNote can be a great note-taking program
by itself, but when combined with Qutlook, the
two programs make an efficient information-
gathering system.

A goal is simply a dream with a deadline. When storing tasks in Outlook, you
need to define what it is that you want to do and set a date for when you

want to complete it.
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To store a task in Outlook, follow these steps:
1. Click the Tasks button in the left pane of the Outlook window (or
press Ctrl+4).
Outlook displays the Tasks view.
2. Click the Home tab and click the New Tasks icon in the New group.

Outlook displays a Task window, as shown in Figure 15-7.
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Figure 15-7:
The Task
window
lets you
jot down
information
about your
important
tasks.
|
W If you just need to store a quick task, click in the Type a new task text
box in the middle pane, type a brief description of your task, and press
Enter.
3. Click in the Subject text box and type a brief description of your task,
such as Sell tainted meat to my neighbor or Meet with police informant.
4. (Optional) Click in the Start date list box and click on a date to start
your task. Then click in the Due date list box and click on a date when
<P you want to complete that task.

You don’t have to add a start and end date, but it’s a good idea to do so
to help you measure your progress (or lack of progress) on your task.

5. (Optional) Click in the Status list box and choose an option such as In
Progress or Waiting on someone else.
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6. (Optional) Click in the Priority list box and choose an option such as
Low or High.

7. (Optional) Click in the % Complete box and click the up/down arrows
to define what percentage you’ve completed of the task.

8. Click in the big text box to describe more details about your task.
9. Click the Save & Close icon.

Outlook displays your task, as shown in Figure 15-8.

S
If you double-click on a task, you can open the Tasks window so you can edit
or add information to your chosen task.
Searching tasks
If you have a lot of tasks, you may want to find a particular one. To find a par-
ticular task, you can search for it. That way, if you know you want to find a
task involving “Toxic chemicals,” you could just search for “Toxic chemicals”
and Outlook will display that task right away.
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To search for a task, follow these steps:
1. Click the Tasks button in the left pane of the Outlook window (or
press Ctrl+4).
Outlook displays the Tasks view.

2. Click the Home tab and click in the Search To-Do List text box (or
press Ctrl+ E).

The cursor appears in the Search To-Do text box.
3. Type as much data as you can about the task you want to find.
4. Press Enter.

Outlook displays all tasks that match your search criteria that you typed
in Step 3.

5. Click the Close Search icon that appears at the far right of the Search
To-Do List text box.

Outlook displays all your tasks once more.
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“Omnce T told Mona that Access was an ‘argument’
based program, she seemed to warm vp to it.”




In this part . . .

n the old days, people wrote important information on

paper and then stored these important papers in filing
cabinets where they would never be able to find this
important information again even if their lives depended
on it. To avoid this problem, Microsoft Office 2010 pro-
vides Access, a program specially designed to help you
store important information that you can’t afford to lose.

You can use Access to store names and addresses, or you
can use it to store, sort, and organize names and
addresses of your most important customers so you’ll
know who has a birthday, who hasn’t spent money with
you lately, who has spent money with you lately, and who
your best customers might be.

Information is more than just storage - it involves analyz-
ing and manipulating that data as well. Using Access,
you’ll be able to search through your data in a slit second,
even if you have thousands of names stored in your data-
base. Access also lets you filter through your data to find
just the best customers who live in Alaska, earn more
than $75,000 a year, and own two boats and a cat.

Best of all, Access can slice and dice your information to
create reports so you can print out your information and
use it to decipher what your information might mean.
Who are your best customers and what are their charac-
teristics? Once you known this information through
Access’s filtering and analyzing capabilities, you'll be able
to pinpoint the best potential customers to spend your
marketing dollars wisely by going after the customers
most likely to give you the greatest amount of money.

If all this sounds like a miracle, it’s not. With a database
like Access, you can store, manipulate, and analyze any
type of data for whatever purpose you need. By browsing
through this part of the book, you’ll learn how to tame
Access for your needs and turn your computer into a tool
for understanding your information (or at least pretending
that you do).




Chapter 16
Using a Database

In This Chapter

Understanding how databases work
Designing a database

Editing a database

Typing information into a database
Closing a database

A database is a program that stores information such as names, addresses,
and phone numbers, or inventory part numbers, shipping dates, cus-
tomer codes, and any other type of information that you think is worth saving.

To help you store information in a database, Office 2010 comes with the
database program, Access. Access provides two huge advantages over stor-
ing information on paper. First, Access can store literally billions of chunks
of information (try doing that with a filing cabinet). Second, Access makes it
&@ABE}; easy to search and sort through your information in the blink of an eye.
&

The three main advantages of a computer database over a paper database are

1 Massive storage: The largest computer database can fit on a hard drive,
but a paper database might take a roomful of file cabinets.

v Fast retrieval: Searching for a single name in a computer database is
fast and easy. Doing the same thing in a paper database is difficult, error
prone, and nearly impossible with a large database.

v Reporting: A report can help you make sense out of your data, such as
showing a list of customers who earn a certain amount of money and
live in a specific area. Trying to find this information in a paper database
is time consuming and error prone.
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Understanding the Basics of a Database

A database is nothing more than a file that contains useful information that
you need to save and retrieve in the future. A database can consist of a single
name and address, or several million names and addresses.

A typical Access database file consists of several parts:

v Fields: A field contains a single chunk of information, such as name,
street address, or phone number.

v Records: A record consists of one or more fields. A business card is a
paper version of a database record that stores fields (name, address,
phone number, and so on) about a single person (record).

v Tables: A table displays records in rows and columns, much like a
spreadsheet. Tables group related records, such as records of all your
customers or records of all your invoices.

v Forms: A form displays all the fields of a single record on-screen, mim-
icking a paper form, so that you can add, edit, or view a single record at
a time.

v Queries: A guery lets you retrieve certain information based on your cri-
teria, such as only retrieving names and addresses of people who earn
more than $50,000 a year and have children.

v Reports: A report arranges your data in a certain way, such as showing
all customers who placed more than 1,000 orders last year or all custom-
ers who live within a certain zip code.

Access is known as a relational database. Basically, this means that you can
store data in separate tables and link or “relate” them together to avoid dupli-
cating data in multiple tables. One table might contain customer names and
addresses while a separate, related table might contain those same custom-
ers’ purchase orders.

Here are the two basic steps to using a database. First, you need to design
your database, which means deciding what type of information your data-
base will hold, such as names, addresses, e-mail addresses, telephone num-
bers, and so on.

After you design a database, the second step is filling it with actual data,
such as typing the name Bob Jones in the Name field or the e-mail address
BJones@somecompany.com in the E-mail field.

When you first create a database, you’ll probably start out with a single table
that contains customer information. Inside the Customer Information table
will be multiple records where each record represents a single customer.
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Each record will consist of multiple fields, such as Last Name, Company
Name, Phone Number, and E-mail Address.

To help you edit and view your database table information, you might even-
tually want to create a form that displays your fields on the screen mimicking
a paper form that’s easy to read.

If you find yourself searching for the same type of information on a regular
basis, such as looking for the names of your best customers (say, those who
order more than $1,000 worth of products from you a week), you can store
this search criteria as a query. Then you can just click on the query name
and make Access show you exactly what you want to find.

Finally, you may want to print your data in a way that makes sense to you,
such as printing a quarterly sales report. By saving your printing criteria in a
report, you can make Access print selected data on a page that’s easy for you
to read and understand.

Features like forms, queries, and reports are optional but handy. Features like
tables, records, and fields are necessary to store your information in your
database.

Designing a Database

Figure 16-1:
You can
divide an
Access file
into sepa-
rate tables
that contain
different
fields.

To design a database, you need to first create a database table and then
define the names of all the fields you want to store in that particular table.
Database tables let you divide a file into separate parts. For example, one
database table may hold the names and addresses of all your customers, a
second database table may hold the names and addresses of all your employ-
ees, and a third database table may hold the names and addresses of your
suppliers. Access stores all this related information in a single Access file
that’s saved on your hard drive, as illustrated in Figure 16-1.

Access database file

Customer table Employee table Supplier table
Name field Name field Name field
Address field Employee ID field Invoice Number field
Phone Number field Salary field Amount Due field

321



322 Part VI: Storing Stuff in Access

\\J

\\J

To design your database, you can create a database from scratch or use an
existing template, which you can modify. Designing a database means defin-
ing both the number of fields to use for storing information and the maximum
amount of data each field can hold.

If you have a field that stores numbers, what are the maximum and minimum
limits on the numbers you want to save in that field? If you're storing some-
one’s age, you probably don’t want the field to contain negative numbers or
numbers beyond 200. If your field needs to hold salaries, the field may need
to hold large numbers but no negative numbers.

In general, store information in separate fields. So rather than create a single
field to hold someone’s full name, create two separate fields: One field holds
a first name and the second field holds the last name. By storing last names in
a separate field, you can easily yank last names out of your database to create
form letters that state, “The Smith family has just won $200,000 dollars in the
Publisher’s Sales Pitch Sweepstakes!”

Access can create a blank database or a special database by using one of
many templates available from the Microsoft Web site. No matter how you
create a database, you will likely need to modify it to customize it for the type
of data you want to store.

To create a database, follow these steps:

1. Click the File tab.
The Backstage View appears.
2. Choose New.
Access displays a variety of options, as shown in Figure 16-2.
3. Click on an icon such as Blank Database or a database template.

If you click on a template, the right pane shows a preview of your
template.

4. Click in the File Name text box and type a descriptive name for your
database.

If you click on the folder icon that appears to the right of the File Name
text box, you can open a dialog box that will let you define a specific
drive and folder to store your database file.

5. Click the Create button to create your database file.

Access displays your database.
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Editing and Modifying a Database

After you create a database from scratch or from a template, you need to
modify it by giving each field a descriptive name, defining the size of each
field, or adding and deleting a field.

Naming a field

If you create a database from scratch, Access displays generic field names
such as Fieldl. If you create a database from a template, you'll see the
descriptive field names, but you may still want to rename the fields to some-
thing else.

To rename a field, follow these steps:

1. In the All Tables pane on the left of the screen, double-click the table
that contains the fields you want to rename.

Access displays the Datasheet view of your database.

323
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2. Double-click the field (column head) that you want to rename.
Access highlights the column.

3. Type a new name for your field and then press Enter when you’re
done.

Adding and deleting a field

Sometimes you may need to add a field to make room to store new informa-
tion. Other times, you may want to delete a field that you don’t really want
after all. To add a field to a database table, follow these steps:

1. Click on the downward-pointing arrow that appears to the right of the
Click to Add heading.

A menu appears, as shown in Figure 16-3.
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2. Choose the type of field you want to add, such as Currency or Text.

Access inserts your field and gives it a generic name like Field3.
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To delete a field from a database table, follow these steps:

1. Click the field (column head) you want to delete.
Access highlights the entire column in your database table.
2. Click the Delete button in the Add & Delete group.

If you have stored data in that field, a dialog box appears, asking

whether you want to permanently delete all the data in the field.
\NG/
$§‘“ If you delete a field, you also delete any data that may be stored in that

field. Depending on how much data you have stored, you could wipe out
a lot of information by deleting a single field, so be careful.

3. Click Yes (or No).

If you click Yes, Access deletes your chosen field.

Defining the type and size of a field

The type of a field defines the type of data the field can hold (numbers, text,
dates, and so on), and the size of a field defines the amount of data the field
can hold (no numbers larger than 250 digits, any text string fewer than 120
characters, and so on).

The purpose of defining the type and size of a field is to make sure that you
store only valid data in a particular field. If a field is meant to store names,
you don’t want someone typing in a number. If a field is meant to store a per-
son’s age, you don’t want the field to accept negative numbers.

To define the type and amount of a data a field can store, follow these steps:

1. Click the Home tab.

2. In the All Tables pane on the left of the screen, double-click the table
that contains the fields you want to define.

Access displays the Datasheet view of your table.

3. Click the bottom half of the View icon (that displays a downward-
pointing arrow), which appears in the Views group.

A pull-down menu appears.
4. Click Design View.

Access displays the Design view of your database table.
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5. Click in the Field Name column and edit an existing field name.
If you click in a blank row, you can add a field to a database table.
6. Click in the Data Type column.
A downward-pointing arrow appears.
7. Click the downward-pointing arrow.

A pull-down menu appears, listing all the different types of data you can
define to store in a field, as shown in Figure 16-4.
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8. Choose a data type, such as Number, Text, or Date/Time.

Access displays a General tab at the bottom of the screen, which con-
tains different options for modifying your chosen data type.

9. Click one of the data type options, such as Format or Input Mask,
listed under the General tab.

Sometimes you have to type a value directly into a data type option.
Other times a pull-down menu appears, from which you can choose an
option.

10. Repeat Step 9 for each data type option you want to modify.

You do not need to modify every data type option.
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Typing Data into a Database

After you create a database table and define fields within that table to hold
chunks of information, you're ready to type in actual names, phone numbers,
and e-mail addresses into each field. Access gives you two ways to enter data:
v Through Datasheet view
v Through Form view
Datasheet view displays information in rows and columns, where each row
represents a single record and each column defines a specific field name.

Datasheet view can be especially handy for examining multiple records at
once.

Form view displays all the fields of a single record on-screen. Form view is
most useful when you just need to view or edit a single record, such as typing
in the phone number of your cousin or boss.

Using Datasheet view

Datasheet view is the default view for entering data. To view and enter data
in Datasheet view, follow these steps:
1. In the All Tables pane on the left of the screen, double-click a table.
Access displays the Datasheet view of your table.
2. Click in a field defined by the column and row.

Each column defines a field, such as a name or address. Each row repre-
sents a single record.

If you click in a field that already contains data, you can edit or delete
that data.

3. Press Tab to select the next field (or Shift+Tab to select the preceding
field).

4. Type or edit the data in the field.

Using Form view

The biggest problem with Datasheet view is that it can be confusing to find a
field for a specific record. Because most people are familiar with paper forms
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or index cards that arrange related data (fields) on a page, Access offers you
Form view.

Form view simply displays the fields of a single record on-screen. To use
Form view, you must first create a form and arrange your fields on that form.
After you create a form, you can add, edit, and view data through that form.

Creating a form

The simplest way to create a form is to let Access design one for you, which
you can modify. To create a form quickly, follow these steps:
1. In the All Tables pane on the left of the screen, double-click a table.
Access displays the Datasheet view of your database.
2. Click the Create tab.
3. Click the Form icon in the Forms group.

Access creates a form, as shown in Figure 16-5. Notice that the form
name automatically uses the name of the database table you chose in
Step 3.
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4. Click the Save icon on the Quick Access toolbar (or press Ctrl+S).
The Save As dialog box appears, asking you to type a name for your form.

5. Type a descriptive name for your form in the Form Name text box and
then click OK.

Access displays your form’s name underneath the All Tables pane. The
next time you open this database and want to view the form, you can
double-click the form’s name in the left pane.

Viewing and editing data in a form

After you create a form, you can use it to edit and add data at any time. To
view a form, follow these steps:

1. In the All Tables pane on the left of the screen, double-click the name
of the form you want to use.

Access displays the Form view of your database.

2. Click one of the following icons (they appear near the bottom of the
screen) to display a record:

e First Record: Displays the first record stored in your file

¢ Previous Record: Displays the preceding record in the file
e Next Record: Displays the next record in the file

e Last Record: Displays the last record that contains data

e New (Blank) Record: Displays a blank form so you can type in data
that will create a new record in your file

3. Click in a field and type the information you want to store, such as a
name or phone number.
$ You don’t need to use the Save command to save your changes because
Access automatically saves any data you add or edit in your file as soon as
you type or edit the data and move the cursor to a new field or record.

Editing a form

A form can be a convenient way to view all the fields of a single record.
However, you can always rearrange the position of certain fields on-screen
(to make them easier to find), or you can delete one or more fields alto-
gether. This can be handy to create a form that shows only a filtered view

of your data, such as a form that shows you only employee names, phone
numbers, and e-mail addresses instead of also showing you their salaries and
employee ID numbers at the same time.
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Deleting a field
If you delete a field from a form, you simply prevent the form from displaying

any data stored in that field. For example, if you don’t want to see each per-
son’s hire date, you can delete the Hire Date field from your form.

Deleting a field on a form doesn’t erase any data; it just keeps you from seeing
that data on a particular form.

To delete a field from a form, follow these steps:

1.

In the All Tables pane on the left of the screen, double-click the name
of the form you want to use.

Access displays the Form view of your database.

2. Click the Home tab.

3. Click the downward-pointing arrow underneath the View icon in the
Views group.
A pull-down menu appears.

4. Choose Design View.
Access shows your chosen form in Design view, which displays a back-
ground grid to help you align fields on your form.

5. Click a field you want to delete.
Access highlights your chosen field.
Each field consists of a field label and the actual field itself. The field
label contains descriptive text that defines the data, such as Name, Age,
or Sales. The field contains the actual data, such as “Fred,” 47, or $34.08.

6. Click the Delete icon in the Records group.
Access deletes your chosen field.
If you press Ctrl+Z right away, you can undelete any field that you just
deleted.

7. Click the downward-pointing arrow underneath the View icon in the
Views group.
A pull-down menu appears.

8. Choose Form View.
Access shows your form with the deleted field missing.

Adding a field

Before you can add a field to a form, you must make sure that the field
already exists in your database table. For example, if you want to add a field
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on a form that displays phone numbers, you must first create that field in
your database table and then stuff it with actual data.

To add a field to a form, follow these steps:
1. In the All Tables pane on the left of the screen, double-click the name
of the form you want to use.
Access displays the Form view of your database.
2. Click the Home tab.

3. Click the downward-pointing arrow underneath the View icon in the
Views group.

A pull-down menu appears.
4. Choose Design View.
Access displays your form in Design view.
5. Click the Design tab.
6. Click the Add Existing Fields icon in the Tools group.

The Field List window appears, as shown in Figure 16-6.
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7. Double-click a field.
Access displays the field label and a field on your form.

8. (Optional) Move the mouse pointer over the upper-right corner of the
field label and drag the mouse (hold down the left mouse button and
move the mouse) to move the field label on your form.

9. (Optional) Repeat Step 8, except move the field instead of the field
label.

10. Click the downward-pointing arrow underneath the View icon in the
Views group and choose Form View.

Access displays the Form view. Notice that the form displays both your
newly added field and any data stored in that field.

Closing and Saving a Database

<\

When you’re done using a database file, you can either close it or exit Access
altogether. Access gives you two options for closing a database:
v Close a single database table.

v Close the entire Access database file.

Closing a database table

Closing a single database table simply removes the data from view. After you
close a database table, you can open another one. (You don’t have to close a
database table to open another one, but if you know you won’t need to view a
particular database table, you might as well close it to get it out of the way.)

To close a database table, follow these steps:

1. Right-click the database table tab that you want to close.
A pop-up menu appears.

2. Choose Close.
Access closes your chosen database table.

If you choose Close All, you can close all open database tables so you won'’t
have to right-click each tab and close the tables one at a time.
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Closing a database file

Closing a database file keeps Access running so you can open another data-
base file. To close a database file but keep Access running, follow these steps:

1. Click the File tab and when the Backstage View appears, choose Close
Database.
To exit Access, choose Exit Access instead.

If you haven’t saved any changes to the design of your database, a dialog
box appears, asking whether you want to save your changes.

2. Click Yes (or No).

Access remains running so you can load another database file.

SMBER When you save an Access database, you're saving only the changes you made
to the database table or form. Access automatically saves any data you type
or edit in your database file. (When you type or edit data, Access saves it as
soon as you move the cursor to a new field or record.)
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Chapter 17

Searching, Sorting, and
Querying a Database

In This Chapter

Searching and filtering a database
Sorting databases

Creating and using queries

f you need to find a specific name in your database, searching through

the database alphabetically may be tedious but possible. However, if you
need to find the names of everyone who ordered more than $50,000 worth
of supplies in the past three months, trying to find this information yourself
would prove tedious and time consuming. Yet, Access can search for this
information at the blink of an eye.

If you search for specific types of data on a regular basis, you probably
don’t want to keep telling Access what to search for over and over again. To
simplify this, you can create a query. A query lets you define specific ways
to search your data and save those parameters so you can retrieve data
instantly the next time you need it.

Besides searching through data, Access can also sort data. Sorting can be as
simple as organizing names alphabetically, or it can be more complicated,
such as sorting names according to zip code, annual salary, and alphabeti-
cally by last name. Sorting simply rearranges your data so you can study it
from a new point of view.

By searching, sorting, and querying your data, you can extract useful infor-
mation about your data.
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Searching a Database

A paper database is useful for storing information, but not so useful for find-
ing it again. If you have a thousand business cards stored in a Rolodex file,
how much time do you want to waste trying to find the phone number of a
single person?

Searching a database is crucial to make your data useful, so Access provides
two ways to search a database:
v Search for a specific record.

v Use a filter to show one or more records that meet a specific criterion.

Searching for a specific record

The simplest type of search looks for a specific record. To search for a
record, you need to know the data stored in at least one of its fields, such as
a phone number or e-mail address.

The more information you already know, the more likely Access will find the
one record you want. If you search for all records that contain the first name
Bill, Access could find dozens of records. If you just search for all records
that contain the first name Bill, the last name Johnson, and a state address of
Alaska, Access will likely find just the record you want.

To search for a specific record in a database table, follow these steps:
1. In the All Tables pane on the left of the screen, double-click the name
of the database table you want to search.
Access displays the Datasheet view of your database.
2. Click the Home tab.
3. Click the Find icon in the Find group.
The Find and Replace dialog box appears, as shown in Figure 17-1.

4. Click in the Find What text box and type in the data you know is
stored in the record you want to find.

For example, if you want to find the phone number of a person but you
know only that person’s last name, you type that person’s last name in
the Find What text box.

5. Click the Look In list box and choose Current field or Current
document.
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6. (Optional) Click in the Match list box and choose one of the following:

e Any Fart of Field: The Find What text can appear in any part of a
field.

e Whole Field: The Find What text is the only text stored in a field.

e Start of Field: The Find What text can be only at the beginning of a
field.

7. (Optional) Click in the Search list box and choose one of the following:

e Up: Searches from the record where the cursor appears, up to the
beginning of the database table

e Down: Searches from the record where the cursor appears, down
to the end of the database table

e All: Searches the entire database table
8. Click Find Next.
Access highlights the field where it finds the text you typed in Step 4.

9. Repeat Step 8 to search for more records that might contain the text
you typed in Step 4.

10. Click Cancel or the Close button.

Filtering a database

Searching a database is easy but somewhat limited because you can retrieve
only a record that matches any text that you want to find. If you want to find
multiple records, you can use a filter.

A filter lets you tell Access to display only those records that meet certain cri-
teria, such all records that contain people who earn more than $200,000 a year,
are currently married, live in Las Vegas, Nevada, and own two or more cats.
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To filter a database table, you must tell Access which field to use as a filter,
and then you must define the criteria for that filter. For example, if you want
to filter your database table to see only those records listing the names of
people who are at least 65, you filter the Age field and set the criterion to

(MBER Greater than or equal to 65.
é,é‘

Filtering simply hides all records in a database table that don’t match your cri-
teria. Filtering doesn’t delete or erase any records.

Using an exact match for a filter

The simplest filtering criterion searches for an exact match. When you filter
a field by an exact match, you're telling Access, “I want to see only those
records that contain this specific chunk of data in this particular field.” By
using an exact match filter, you could display only those records that contain
CA in the State field.

To filter a database table, follow these steps:
1. In the All Tables pane on the left of the screen, double-click the name
of the database table you want to filter.
Access displays the Datasheet view of your database.
2. Click the Home tab.
3. Click in the field (column) that you want to use as a filter.
4. Click the Filter icon in the Sort & Filter group.

A pop-up menu appears, as shown in Figure 17-2.
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Figure 17-3:
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5. (Optional) Clear one or more of the check boxes that appear to the left
of the list of data that appears in the field you chose in Step 3.

6. Click OK.

Access displays the filtered view of your database table of only those
items that appeared selected in Step 5.

7. Repeat Steps 3 through 6 for each additional field you want to filter.

Filtering by form

One problem with defining filters in Datasheet view is that you have all your
database table records cluttering the screen. To avoid this problem, Access
lets you define filters by using a form, which basically displays an empty
record so you can click the fields that you want to use to filter your database
table.

To define a filter by form, follow these steps:

1. In the All Tables pane on the left of the screen, double-click the name
of the database table that you want to filter.
Access displays the Datasheet view of your database.

2. Click the Home tab.

3. Click the Advanced icon in the Sort & Filter group.
A pull-down menu appears.

4. Choose Filter By Form, as shown in Figure 17-3.

Access displays a blank record.
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5. Click in any field.

A downward-pointing arrow appears.
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Figure 17-4:
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6. Click the downward-pointing arrow.

A pull-down menu appears, listing all the data currently stored in that
field, as shown in Figure 17-4.
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7. Click the data you want.
You can only click on one entry in the list.
8. Click the Toggle Filter icon in the Sort & Filter group.

Access displays a filtered view of your database table.

Using a filter criteria

Searching for an exact match in a field can be handy, but sometimes you may
want to see records that meet certain criteria, such as finding the names of
everyone whose salary is greater than $50,000 a year. Instead of filtering by
an exact match, you have to define the filter criteria.

The type of data stored in each field determines the type of criteria you can
create. Three common types of data stored in fields include Text, Numbers,
and Dates, which you can filter in different ways, as shown in Table 17-1.



Chapter 17: Searching, Sorting, and Querying a Database 34 ’

Table 17-1 Common Criteria for Filtering
Different Types of Data
Field Data Type Filtering Criteria Description
Text Equals Field must match filter text
exactly.
Does Not Equal Field must not match filter text.
Begins With Field must start with the filter
text.
Does Not Begin Field must not begin with the
With filter text.
Contains Field must contain the filter text.
Does Not Contain Field must not contain any part of
the filter text.
Ends With Field ends with the filter text.
Does Not End With Field does not end with the filter
text.
Numbers Equals Field must equal filter number.
Does Not Equal Field must not equal filter
number.
Less Than or Field must contain a number less
Equal To than or equal to the filter number.
Greater Than or Field must contain a number
Equal To greater than or equal to the filter
number.
Between Field must contain a number that
falls between two filter numbers.
Dates Equals Field must equal the filter date.

Does Not Equal

Field must not equal the filter
date.

On or Before

Field date must be equal or ear-
lier than the filter date.

On or After

Field date must be equal or later
than the filter date.

To create the filter criteria, follow these steps:

1. In the All Tables pane on the left of the screen, double-click the name

of the database table you want to filter.

Access displays the Datasheet view of your database.
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Figure 17-5:
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2. Click the Home tab.
3. Click in the field (column) that you want to use as a filter.
4. Click the Filter icon in the Sort & Filter group.
A pop-up menu appears (refer to Figure 17-2).
5. Select the Filters option, such as Text Filters or Number Filters.

A submenu of filter options appears, as shown in Figure 17-5.

7] Tabled | 5] Tailen % | Field List ®
] - FirstName - Last Name - Agn ~ |E-mall addre - Reg
18 McPHerson 85 Losergd.com East :::ela; available to be sdded to the current
2 Bobby Lee 40 Thicf@coomed, West
1 Patrick DoGuire 39 Utar@whitchol North
4 Bo Katz |.l? Queeng@cat.co North
5 Ed Jones 4] o smatiestto targest
6 Doug lames %1 soriargestto smatiest
* (New)]
. &
Humber Ellters Eauali..,
] [setect am Does Mok Equal..,
| [Blariks) Less Than..,
2 1 Grester Than
R
7 3 Hetwren,.
4 a0
7 4
4| 85
ok | Cangzl
Hecord: M 4 dofe b M F seartn 1 »

6. Click a filter option, such as Between or Less Than.

The Custom Filter dialog box appears, as shown in Figure 17-6. The
Custom Filter dialog box contains the name of your filter option, such as
Between Numbers or Less Than.

Custom Filter [VEd

Age is less than or equal to |

0K | Cancel

7. Type in one or more values in each text box displayed in the Custom
Filter dialog box and then click OK.
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Access filters your database table according to your criteria.

8. Repeat Steps 5 through 7 for each additional filter you want to add.

Clearing a filter

When you apply a filter to a database table, you see only those records that
match that filter. Access displays a Filtered message at the bottom of the
screen to let you know when you’re looking at a filtered database table.

To remove a filter so you can see all the records, choose one of the following:

v Click the Toggle Filter icon in the Sort & Filter group.

v Click the Filtered or Unfiltered button on the status bar near the bottom
of the screen.

Access temporarily turns off any filters so you can see all the information
stored in your database table.

<MBER When you choose the Save command (Ctrl+S) to save a database table, Access
also saves your last filter. The next time you open that database table, you’ll
be able to use the last filter you created. If you want to save multiple filters,
you’ll have to save them as a query (see the section “Querying a Database”
later in this chapter).

Sorting a Database

Sorting simply rearranges how Access displays your information. Sorting can
be especially handy for rearranging your records alphabetically by last name,
by state, or by country. You can also sort data numerically so that customers
who buy the most from you appear at the top of your database table, while
customers who don’t buy as much appear near the bottom.

To sort a database table, follow these steps:
1. In the All Tables pane on the left of the screen, double-click the name
of the database table you want to sort.
Access displays the Datasheet view of your database.
2. Click the Home tab.
3. Click in a field (column) that you want to use for sorting.
4. Click the Ascending or Descending icon in the Sort & Filter group.

Access sorts your records and displays an Ascending or Descending
icon in the field name so you know you’re looking at a sorted list, as
shown in Figure 17-7.
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5. Click the Remove Sorts icon in the Sort & Filter group when you don’t
want to view your sorted database table any more.

Ouerying a Database

One problem with sorting or filtering a database table is that you must con-
stantly define what you want to sort or filter. In case you sort or filter your
data a certain way on a regular basis, you can use a query instead.

A query is nothing more than a saved version of your sort or filter criteria.
By saving the particular sort or filter criteria as a query, you can select that
query by name later.

Creating a simple query

If your database table contains dozens of different fields, you may find it con-
fusing to make sense of all your information. As an aid, a simple query strips
away fields so you see only the fields containing data you want to see, such as
a person’s name and phone number but not her hire date or employee number.

To create a query, follow these steps:

1. Click the Create tab.
2. Click the Query Wizard icon in the Macros & Code group.

The New Query dialog box appears, as shown in Figure 17-8.
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3. Click Simple Query Wizard and then click OK.
The Simple Query Wizard dialog box appears, as shown in Figure 17-9.
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4. Click a field name listed in the Available Fields box and then click
the > button.

Access displays your chosen field in the Selected Fields box.

5. Repeat Step 4 for each field you want to use in your query.

6. Click Next.
Another dialog box appears, as shown in Figure 17-10. This dialog box
asks whether you want to display a Detail (shows every record) or
Summary (shows numerical information such as the total number of

records found, the average value, and the minimum/maximum value)
view of your data.
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7. Select the Detail or Summary radio button and then click Next.

Another dialog box appears, asking you to type a descriptive name for
your query.

8. Click in the text box, type a descriptive name for your query, and then
click Finish.

Access displays the results of your query as a separate tab.

9. Click the File tab and then choose Save to save your query.

Creating a crosstab query

A crosstab query lets you combine two or more fields to calculate and display
a calculation based on a third field. For example, if your database contains
the names of salespeople and the products they sold, you can use those two
fields to create a crosstab that tells you how much each salesperson sold of
each product, as shown in Figure 17-11.

To create a crosstab query, you need to identify three types of fields:

»* One to three fields to identify each record (such as the First Name and
Last Name fields)

v A single field to display specific data from each record (such as the
Product field, which displays the actual product names like Purses,
Unicorn meat, or Missiles)

v A crosstab field that displays a calculated result (such as Sales)
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To create a crosstab query, follow these steps:

1. Click the Create tab.

2. Click the Query Wizard icon in the Macros & Code group.
The New Query dialog box appears (refer to Figure 17-8).

3. Click Crosstab Query Wizard and then click OK.

The Crosstab Query Wizard dialog box appears, as shown in
Figure 17-12.

4. Click a database table and then click Next.

Another Crosstab Query Wizard dialog box appears that asks for
between one and three fields to identify each row (record), as shown in
Figure 17-13.

5. Click a field in the Available Fields box and then click the > button to
move your chosen field to the Selected Fields box.

6. Repeat Step 5 for each additional field you want to include.
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7. Click Next.

Another dialog box appears, asking for a single field to use to cross-
tabulate data with the fields you chose in Steps 5 and 6, as shown in
Figure 17-14.

8. Click a field name and then click Next.

Ideally, this field should consist of text information that lists different
data, such as sales regions (East, West, North, or South) or products
(Missiles, Unicorn meat, and so on). If you choose a field that contains
numerical data, your crosstab query displays only those numbers in the
column headings, which will appear meaningless. Another dialog box
appears, as shown in Figure 17-15.
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9. Click on a field from the Fields box and then click on a mathematical
function that you want Access to calculate, such as Sum, Avg, or Count.

10. Click Next.

Another dialog box appears, asking for a name for your query.

11. Type a descriptive name for your query in the text box at the top of

the dialog box and then click Finish.

Access displays your crosstab query (refer to Figure 17-11).

12. Click the File tab and choose Save to save your query.
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Creating a query that finds
duplicate field data

Suppose you sell a hundred different products. How can you tell which prod-
ucts customers are buying the most? To find the answer to this type of ques-
tion, you could search your database manually to find a Products Sold field
and then count how many times each product appears.

As a simpler solution, you can create a query that finds and counts how
many times duplicate data appears. To create a query to find duplicate field
data, follow these steps:

1. Click the Create tab.

10.

. Click the Query Wizard icon in the Other group.

The New Query dialog box appears (refer to Figure 17-8).

. Click Find Duplicates Query Wizard and then click OK.

The Find Duplicates Query Wizard dialog box appears, asking you to
choose the database table to search.

. Click a database table and then click Next.

Another dialog box appears, asking you to choose the fields to examine
for duplicate data.

. Click a field name and then click the > button. Repeat this step for

each additional field you want to search.

. Click Next.

Another dialog box appears, asking whether you want to display any
additional fields. If you choose to look for duplicate data in a Product
field (Step 5) to see which products are most popular, you can display
additional fields such as each salesperson’s name so you can also see
who is responsible for selling the most products.

. Click a field and click the > button. Repeat this step for each addi-

tional field you want to display.

. Click Next.

A dialog box appears, asking whether you want to give your query a
descriptive name.

. Type a descriptive name in the top text box and then click Finish.

Access displays your query as a separate tab.

Click the File tab and then choose Save to save your query.
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Creating an unmatched query

Access can store huge amounts of data, but the more data you store, the
harder it can be to view your data. To help you organize your data, you can
divide data into separate tables. One table may contain a list of customers,
and a second table may contain a list of salespeople.

When you store data in separate tables, each table may share one or more
common fields. For example, a table containing customers may contain a
SalesPerson field that shows which salesperson deals exclusively with which
customer. A second table listing salespeople could contain the Customer
field (along with additional information such as each salesperson’s phone
number, address, sales region, and so on).

An unmatched query examines two (or more) database tables to look for
missing information. For example, you could also use an unmatched query to
find customers who haven’t ordered anything in the past six months, sales
regions that haven’t ordered certain products, or salespeople who have not
been assigned to a sales region. Basically, an unmatched query can help you
find missing pieces or holes in your entire database file.

To create an unmatched query, follow these steps:

1. Click the Create tab.
2. Click the Query Wizard icon in the Other group.

The New Query dialog box appears (refer to Figure 17-8).
3. Click Find Unmatched Query Wizard and then click OK.

The Find Unmatched Query Wizard dialog box appears, asking you to
choose a database table that contains the unmatched records you want
to find.

4. Click a database table and then click Next.

Another dialog box appears, asking you to choose a database table that
contains at least one field that also appears in the table you chose in
Step 3.

5. Click a second database table and then click Next.

Another dialog box appears, asking you to identify the field that both
database tables have in common.

6. Click the common field that both database tables share.

7. Click on the gray <=> button that appears between the two fields and
then click Next.
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A dialog box appears, asking you to identify the fields you want to dis-
play from the database table you chose in Step 4.

8. Click a field and then click the > button. Repeat this step for each
additional field you want to display.

9. Click Next.
A dialog box appears, asking you to give your query a descriptive name.
10. Type a descriptive name in the text box and then click Finish.

Access displays your query results, which show you only the data in
fields you selected in Step 8.

11. Click the File tab and choose Save to save your query.

Viewing, renaming, closing,
and deleting queries

Each time you create and save a query, Access stores it for future use. After
you create and save a query, you can add or delete data from your tables and
then apply your queries on the newly modified data.

To view a query, just double-click on the query name in the left pane. In case
you need to rename your query to give it a better descriptive name, follow
these steps:
1. Right-click on the query name in the left pane.
A pull-down menu appears.
2. Choose Rename.
Access highlights the query name.
3. Type a new name and then press Enter.
Each time you view a query, it displays a tab. Eventually, you'll probably
want to get rid of a query, so to close a query, follow these steps:
1. Right-click on the query name that appears in the tab.
A pull-down menu appears.
2. Choose Close.

Access closes your chosen query and removes its tab from view.
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Eventually, you may no longer need a query. To delete it, follow these steps:
1. Right-click a query name; when a pop-up menu appears, choose
Delete.

A dialog box appears, asking whether you really want to delete your
query.
2. Click Yes (or No).
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Chapter 18
Creating a Database Report

In This Chapter
Creating a report with the Report Wizard

Displaying and printing reports
Modifying the appearance of a report

Erasing a report

Data is useless if you can’t understand what it means, so that’s why
Access lets you create reports. A report simply provides a printed ver-
sion of your data arranged in some useful way.

A report could dig through your data and print a list of your top ten sales-
people. Another report may print out the top ten products you sold last year.
Reports simply provide a way to make sense of your data and print it so you
can examine your data on paper.

Using the Report Wizard

The easiest way to create a report is to use the Report Wizard, which guides
you step by step through arranging and selecting which data to print on a
report, along with sorting your data at the same time. To use the Report
Wizard, follow these steps:

1. Click the Create tab.

2. Click the Report Wizard icon in the Reports group.

The Report Wizard dialog box appears, as shown in Figure 18-1.



356 Part VI: Storing Stuff in Access

Figure 18-1:
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Areport can
group data
under
categories
so you

can see all
your data
arranged by
a specific
field.

Reworl Wizard
| Which fields do you want on your report?
You can dhoose from more than one table or query.
Tables/Queries
Tahle: |15t of Ensers =]
Available Felds: Selected Felds:
First Name =]
Last Name =
Sales |
Product
Region
| cancel Mext > Finish

3. Click in the Tables/Queries list box and choose the table or query that
contains the data you want to print in a report.

4. Click in a field in the Available Fields box and then click the > button.
Repeat this step for each additional field you want to display in your
report.

5. Click Next.

Another dialog box appears, asking whether you want to group your
data by a specific field, such as by Last Name or Employee Number, as
shown in Figure 18-2.

Renorl Wizard

[0yl want tn Add any groumpng

levels? First Name, Last Name, Sales, Product,

Hegqon

Last Name 2]

Sales

Product

Region

Priority
Cancel | | «Back Neut > Finish

6. Click a field name displayed in the box and then click the > button.
Repeat this step for each additional field you want to use to group
your data on the report.
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7. Click Next.

Another dialog box appears, asking you to choose up to four fields to
use for sorting your data in your report, as shown in Figure 18-3.

Renorl Wizard
What sort order do you want for your records?

You can gort records by up to four fielde, in either
or order.

' 5 (i)
2
|
3
Figure 18-3:
You can sort 1
the data in
your report,
using up to
four fields. R e
|
8. Click in a list box and choose a field to sort your data.
Data will be sorted by the order chosen here for each additional field
you sort on.
9. (Optional) Click the Ascending button to change the sorting criteria
from Ascending to Descending and vice versa.
10. Click Next.
Another dialog box appears, asking you how to lay out your report, as
shown in Figure 18-4.
[ Reporl Wizard
How would you like to lay out your report?
Crientation
| & Portrait
Figure 18-4: L
The Report Al
Wizard
offers
different
options for E 7] Adgst the fickd width 50 allfelds fit on
making your e e
report look
readable. cancel || <Back Mext> Fiish |
|
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11. Select a radio button under the Layout group, such as Columnar or
Justified.

12. (Optional) Select a radio button in the Orientation group, such as
Portrait or Landscape.

13. Click Next.

Another dialog box appears, asking for a descriptive name for your
report.

14. Type a descriptive name for your report and then click Finish.

Access displays your report, as shown in Figure 18-5.
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|
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ACCGSS McPherson Bl 128 Missiles East
displavys sterling Jack 430 Bombs south
your TEPOVrt Vale Halle 528 Missiles West
on-screen. -
L. U A ¥
SMBER
O
&

To view your report again, double-click on the report name in the left pane of
the Access window.

If you change any data, you can see those updated changes in your report by
following these steps:
1. Right-click on the tab that represents your currently displayed report.
A pop-up menu appears.
2. Choose Close.
3. Double-click the report name in the left pane of the Access window.

Your chosen report appears again, displaying any data you updated or
modified since the last time you viewed the report.
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< Access won’t automatically update your reports just because you modified
any data that the report displays.

Manipulating the Data in a Report

After you create a report, you can manipulate the data displayed in that
report, such as sorting data in ascending or descending order, or applying a
filter that only displays data that meets a certain criteria.

By using a report, you get a different view of your data. By manipulating

the data in a report, you create alternate views of the same report. Some
common ways to extract information from a report include counting, sorting,
and filtering.

Switching a report to Layout view

To manipulate data in a report, you must first display your report in Layout
view, which you can do by following these steps:

1. Double-click on the report name in the left pane of the Access
window.
Access displays your chosen report.

2. Click the Home tab and click the downward-pointing arrow under-
neath the View icon in the Views group.

A pull-down menu appears.
3. Choose Layout View.

Access displays your report in Layout view, which highlights an entire
column (field) at a time, as shown in Figure 18-6.

Counting records or values

To make reports more useful, you can have Access count and display
information, such as which products are selling the best or the total dollar
amount of each sale so you can tell exactly how much money your company
made during March. By counting records or adding up values stored in fields,
Access can help you better interpret the data displayed in a report.
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< You can count values only of fields that contain numbers; you cannot count
values of a field that contains text, such as names.
To count the number of records or values in a report, follow these steps:
1. Switch to the Layout view of your report by following the steps in the
preceding section, “Switching a report to Layout view.”
2. Right-click in the column (field) that you want to count.
Access highlights your chosen column and displays a pop-up menu, as
shown in Figure 18-7.
3. Click Total.
The menu command displays the Total command along with the field
name you right-clicked, such as Total Last Name or Total Sales.
Access displays a submenu that displays Count Records or Count
Values.
4. Choose either Count Records or Count Values.
&N\BE” Access displays the total count in your report.
&
<

If you choose the Count Records or Count Values command again, you can

hide the total count in your report.
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Sorting a field

Access can sort each field in ascending or descending order. Sorting a field
simply rearranges the data in your report for your convenience. To sort a
column (field) in a report, follow these steps:

1. Switch to the Layout view of your report by following the steps in the

preceding section, “Switching a report to Layout view.”

2. Right-click in the column (field) that you want to sort.

Access highlights your chosen column and displays a pop-up menu
(refer to Figure 18-7).

3. Choose one of the following:

e Sort A to Z (or Sort Smallest to Largest): Sorts in ascending order

e Sort Z to A (or Sort Largest to Smallest): Sorts in descending order

Access sorts your chosen data in your report.

361
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Figure 18-8:
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Filtering a field

Filtering can tell Access to only display data that meets certain criterion, such
as a fixed amount. For example, if you have a report that lists all the sales of
products, you could filter your report to show only those products that sold
over a fixed amount, such as $1,000.

To filter data in a field, follow these steps:
1. Switch to the Layout view of your report by following Steps 1 through
in the previous section, “Manipulating the Data in a Report.”
. Right-click in the column (field) that you want to filter.

Access highlights your chosen column and displays a pop-up menu
(refer to Figure 18-7).

. Choose Filters.

Depending on the type of data your column contains, the Filter com-
mand may appear as Text Filters or Number Filters.

A submenu appears, as shown in Figure 18-8.
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4. Choose a filter criteria, such as Equals or Less Than.

Depending on the criteria you choose, a Custom Filter dialog box
appears.

5. Type your criteria in the Custom Filter dialog box and then click OK.
Access applies your filter to your report.

You can always turn off your filter by clicking the Home tab and then clicking
the Toggle Filter icon in the Sort & Filter group.

Editing a Report

\\J

After you create a report, you may want to modify it later to expand the
space used to display data or eliminate fields altogether.

To edit a report, you must switch to the Design view of your report, as shown
in the sidebar “Switching to Design view.” You can modify your report while
you view it in Design view.

Resizing fields

When the Report Wizard creates a report, it doesn’t always leave enough
room to display your actual data. If a field is too small, Access may display
data as a series of x’s, such as xxxxx. If this occurs, resize a field to make it
wider. (If your data turns out to be smaller than the field, you may need to
shrink the field.) To resize a field, follow these steps:
1. Display your report in Design view.
Follow the steps in the sidebar “Switching to Design view.”
2. Choose the field you want to resize.
Access highlights your chosen field.

3. Move the mouse pointer over the left or right edge of the field until
the mouse pointer turns into a two-way pointing arrow.

4. Drag the mouse to resize and expand or shrink the field.

Access displays your report with your modified field size.



Part VI: Storing Stuff in Access

364

steps:

the left pane of the Access window.
2. Click the Home tah.

1. Double-click on the name of the report in

Switching to Design view

To see the Design view of a report, follow these

3. Click the downward-pointing arrow under-
neath the View icon that appears in the
Views group.

A pull-down menu appears.
4. Choose Design View.

Access displays your reportin Design view,
as shown here.

2l e .

ﬂ ‘,_q g coes - |j: Group & Sort

Wirar | Themes (2] Fonts -

External Data

Ly |[abl Ag l==]

g Dersas

Database Tools Dresigr Amange

| Databasel: Datsbase (Access 2007) - M. = B 2

Farmat  Page Telup 7 ]
= 9 L ——
VT, - I o L i
| " &) e * &
nstt | Page oy & fapety  Tah ..
= image | Mumbe e and lime der W

=
Sewrche i
Erades== = =aau| _
T ik ot tasers |
Queries =
Forms ||
Reports % ||| || % Page Header
W titorion B | (e i e [
- it i | et Pt :
€ Drtas
Last Name First Name sales |[Product Region |
# Fage Foater ' )
I I
° |[=Now() ="Page © & [Page] & "ol " & [Pages]
€ Report Fantre
4 b
Deesign View =E=Nel

At this point, you can move, resize, add, or
delete fields on your report:

v Text is bold for labels that print identifying
text, such as First Name or Sales Region.

v~ Textin normal typeface (not in bold) repre-
sents fields that display data in your report.
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Deleting fields

If a report displays data that you no longer want to see, you can delete that
field from your report by following these steps:

W 1. Display your report in Design view.

Follow the steps in the sidebar “Switching to Design view.”
2. Right-click the field you want to delete.
Access highlights your chosen field and displays a pop-up menu.
3. Click Delete.
3 Access deletes your chosen field.

You can press Ctrl+Z right away to retrieve any fields you may have
deleted accidentally.

Making Reports Look Pretty

Reports can be useful for displaying data, but go one step farther and make
your reports look visually pleasing as well. One way to change the appear-
ance of a report is to use a predefined theme, which can instantly add color
to make even the dullest report look interesting.

Applying themes

A theme simply rearranges the appearance of your entire report so it doesn’t
look like a boring list of text and numbers. To apply a theme to a report,
follow these steps:

W 1. Display your report in Design view.

Follow the steps in the sidebar “Switching to Design view.”
2. Click the Design tab.
3. Click the Themes icon in the Themes group.

A menu appears, listing all the available themes (see Figure 18-9).
4. Move the mouse pointer over a theme.

Access shows how your report will look with the selected theme.
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5. Select a theme to choose it for your report.

Access displays your report with your selected theme.

Creating conditional formatting

A report can display data, but sometimes you may want help in identifying
certain types of data. For example, you might want Access to highlight sales
figures that are greater than $250,000 so you can spot this information easier.
While you could manually examine a report and highlight such information
yourself, it’s faster and more accurate to let Access do it instead.

Formatting data based on certain criteria is known as conditional formatting.
The idea is that Access formats data only when certain conditions are met,
such as a value greater than $250,000 or less than $10,000.

To use conditional formatting, you need to define the field to format, define
a rule to trigger the formatting, and then the type of formatting you want to
apply, such as highlighting the field in red or yellow.

To apply conditional formatting to data in a report, follow these steps:

W 1. Display your report in Design view.

Follow the steps in the sidebar “Switching to Design view.”
2. Select the field to which you want apply conditional formatting.

You can apply conditional formatting to a numeric or text field.
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3. Click the Format tab.
4. Click the Conditional Formatting icon in the Control Formatting group.

A Conditional Formatting Rules Manager dialog box appears, as shown
in Figure 18-10.
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5. Click the New Rule button.
A New Formatting Rule dialog box appears, as shown in Figure 18-11.

You can click the Edit Rule or Delete Rule button here to edit or delete a
rule that you've created.
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6. Select a rule type:

e Check values in the current record or use an expression (you can
create a rule that only considers the value of a single field).

e Compare to other records (you can create a rule that examines the
value of the same field stored in other records).
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7. Define your rule under the Edit the rule description category.

Depending on the option you chose in Step 6, the Edit the rule descrip-
tion category may display different options.

8. Choose the type of formatting to display if the data in a field matches
your rule that you defined in Step 7.

9. Click OK.

The Conditional Formatting Rules Manager dialog box appears again,
displaying your newly created rule.

10. Click OK.

Access now displays your formatting changes in the field if it matches
your defined rule.

Deleting a Report

Eventually, you may find that you no longer need a report, so you might as
well delete it. To delete a report, follow these steps:
1. Right-click the Report tab.
A pull-down menu appears.
2. Choose Close.
3. In the left pane, right-click on the report that you want to delete.
A pull-down menu appears.
4. Click Delete.
§?~“\NG! A dialog box asks whether you really want to delete your report.
Make sure that you really want to delete a report. You won’t be able to
retrieve it afterwards.

5. Click Yes (or No).
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In this part . . .

A lthough Microsoft Office 2010 isn’t something that
you can pick up and learn right away just by goofing
around with it, you will find that Microsoft Office isn’t nec-
essarily as difficult to learn and use as you might have
thought initially. In this part of the book, you’ll learn vari-
ous shortcuts and tips for getting the most out of
Microsoft Office.

This is where you'll learn how to block unwanted e-mail
(spam) through Outlook, protecting yourself from macro
viruses that could infect your Word and PowerPoint docu-
ments, and how to save files to share with people who
may not be as enlightened as you in using Microsoft Office
2010.

Browse through these pages and pick up some tips and
shortcuts to making yourself more productive with
Microsoft Office 2010. Soon you may become known as
the Microsoft Office guru in your office, and that’s when
you can either demand a raise or pass around this copy of
the book to your fellow o-workers so they an learn what
you know and leave you alone so you can get some work
done for a change.
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Ten Tips for Using Office 2010

M icrosoft Office is famous for burying tons of useful features that most
people never know about, so this chapter is about exposing some of
Office 2010’s features so you can take advantage of them and make Office
2010 more convenient (and safer) for you to use.

Saving Office 2010 Files

SMBER
S

Most people dump their documents inside a folder in the Documents folder.
However, store too many documents in this folder and you’ll find it’s nearly
impossible to find anything. To make retrieving files easier, it's a good idea to
store different data in its own folders, such as storing tax-related information
in a special Tax Returns folder or invoices in a special 2010 Invoices folder.

Of course, Office 2010 will cheerfully save all your files in the Documents
folder, so you’ll need to tell Office 2010 where you want it to save files.

In addition to defining a default folder to store files, you can also define a
default file format for your Office 2010 programs. This can be especially
useful if you need to share files with others, such as people still stuck using
an older version of Microsoft Office (97/2000/XP/2003).

Finally, to protect your data (as much as possible) from inevitable com-

puter crashes and hard drive failures, Office 2010 programs include a special
AutoRecover feature, which saves a temporary copy of your file at fixed inter-
vals, such as every ten minutes. That way, if the power goes out, you lose only
those changes you made in the last ten minutes and not all your changes.

Access doesn’t offer an AutoRecover feature because it automatically saves
any changes to your data anyway.

To customize the location, format, and AutoRecover feature of an Office 2010
program, follow these steps:

1. Load the Office 2010 program you want to customize (such as Word or
PowerPoint).
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2. Click the File tab.
The Backstage View appears.
3. Click Options.

An Options dialog box appears, as shown in Figure 19-1.
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4. Click Save in the left pane.
The Options dialog box displays various Save options.

5. (Optional) Click in the Save Files in This Format list box and choose a
file format, such as the 97-2003 format to save files that are compat-
ible with previous versions of Office.

6. (Optional) Click in the Default File Location text box and type the
drive and folder that you want to define as your default folder. (Or
click the Browse button and then choose a folder.)

7. (Optional) Select the Save AutoRecover Information Every check box,
click in the Minutes text box, and type a value or click the up/down
arrows to define a value, such as 7 minutes.

8. Click OK.
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To prevent prying eyes from peeking at your Word, Excel, or PowerPoint
files, you can password-protect them. That way, if someone wants to open,
view, or edit your files, she must use your password. If someone doesn’t
know your password, she won’t be able to view — let alone edit — your files.

You can buy programs off the Internet that can crack an Office 2010 password-
protected file. For real security, don’t rely on Office 2010’s password-protection
feature.

To password-protect a file, follow these steps:

1. Load Word, Excel, or PowerPoint.
2. Click the File tab.
The Backstage View appears.
3. Choose Save As.
The Save As dialog box appears.
4. Click the Tools button.

A pull-down menu appears, as shown in Figure 19-2.
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5. Choose General Options.
The General Options dialog box appears.
6. (Optional) Click in the Password to Open text box and type a password.

Another dialog box appears and asks you to confirm the password by
typing it again.

7. Type the password again and then click OK.

8. (Optional) Click in the Password to Modify text box and type a
password.

This password can be different than the password you typed in Step 6.
Another dialog box appears and asks you to confirm the password by
typing it again.

9. Type the password again and then click OK.
10. Click Save.

WMBER
e“" You can create a password or remove passwords altogether by repeating
& ; . :
the preceding steps and retyping a new password or deleting the password
completely.

Guarding Against Macro Viruses

Macro viruses are malicious programs designed to attach themselves to
Word, Excel, and PowerPoint files. When an unsuspecting victim opens an
infected file, the virus can spread and do something nasty, such as deleting
your files or your entire hard drive.

To stop these pests from wrecking your files, get an antivirus program, avoid
downloading or accepting any files from unknown people, and turn on Office
2010’s built-in macro protection feature, which can disable macros or restrict
what macro viruses and worms can do even if they do infect your computer.

To turn on macro protection, follow these steps:

1. Load Word or PowerPoint.
2. Click the File tab.
A pull-down menu appears.
3. Click Options.
The Options dialog box appears.
4. Click Trust Center.

The Trust Center options appear in the right pane.
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5. Click the Trust Center Settings button.

The Trust Center dialog box appears with the Macro Settings options
displayed.

6. Select one of the following radio buttons:

¢ Disable All Macros without Notification: The safest but most restric-
tive setting, this prevents any macros (valid or viruses) from run-
ning when you open the file.

¢ Disable All Macros with Notification: This is the default setting and
displays a dialog box that lets you turn on macros if you trust that
the file isn’t infected.

¢ Disable All Macros except Digitally Signed Macros: Blocks all
macros except for the ones “authenticated” (previously defined as
“trusted”) by the user.

e Enable All Macros: This setting runs all macros, which is the most
dangerous setting.

7. Click OK until you return to the Save As dialog box.
8. Click Save.

Customize the Ribbon

Some people love the Ribbon interface of Office 2010, while others only toler-
ate it. No matter what your feelings toward the Ribbon interface may be, you
can customize which icons appear on it so it only displays those features you
need (and use) most often.

To customize the Ribbon interface, follow these steps:

1. Load an Office 2010 program, such as Word or Access.
2. Click the File tab.
The Backstage View appears.
3. Click Options.
The Options dialog box appears.
4. Click Customize Ribbon in the left pane.

The Options dialog box displays two columns. The left column displays
all additional commands you can place on the Ribbon, while the right
column lists all currently displayed tabs and commands, as shown in
Figure 19-3.
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5. (Optional) Clear a check box in the right column to hide an entire tab
from view.

Hiding tabs can be handy when you never use a particular group of com-
mands and you want to simplify the Ribbon interface.

6. (Optional) Click the New Tab button to create a new tab. Then you
can click on a command in the left column and click the Add button to
place commands on a new tab of your own design.

7. (Optional) Click the Restore Defaults button.

The Restore Defaults button lets you restore the default settings of a
single tab or the entire Ribbon. Use this feature to make your copy of
Office 2010 look like everyone else’s.

8. Click OK.

&,N\BEH Customizing the Ribbon can make your copy of Office 2010 work exactly the
©

way you want. However, if other people need to use your copy of Office 2010
or if you need to use someone else’s copy of Office 2010, you may find that
using different Ribbon interfaces can get confusing.
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Zooming In (And Out)
to Avoid Eyestrain

For many people, Word, Excel, and PowerPoint may display text too tiny to
see comfortably. To overcome this problem, you can increase the magnifica-
tion in Word, Excel, or PowerPoint so that text appears bigger without physi-
cally altering the file itself.

Here are three ways to zoom in (or out) the magnification:

v Drag the Zoom slider that appears in the bottom-right corner.

v Hold down the Ctrl button and scroll the wheel of your mouse (assum-
ing your mouse has a wheel).

v Click the View tab and then click the Zoom icon in the Zoom group.
When a dialog box appears, click a magnification percentage (such as
MNBER 125%) or type your own magnification percentage (such as 138%).

Changing the magnification only changes the way your text appears. Zooming
in (or out) doesn’t physically alter the text itself.

When in Doubt, Right-Click the Mouse

As a shortcut to giving commands to Office 2010, remember this simple
guideline: First select, and then right-click.

So if you want to change text or a picture, first select it to tell Office 2010
what you want to modify. Then right-click the mouse to display a pop-up
menu of the commands. These pop-up menus display a list of only relevant
commands for the item you just selected.

Freezing Row and Column
Headings in Excel

One problem with creating large spreadsheets in Excel is that your identify-
ing row and column headings may scroll out of sight if you scroll down or to
the right of your worksheet.
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To prevent this from happening, you can “freeze” a row or column that con-
tains identifying labels. That way, when you scroll through your worksheet,
your frozen row or column always remains visible.

To freeze a row or column in an Excel worksheet, follow these steps:

1. Click the View tab.

2. Click the downward-pointing arrow that appears to the right of the
Freeze Panes icon in the Window group.

3. Click one of the following:
e Freeze Panes: Divides a worksheet into multiple panes

e Freeze Top Row: Always displays the top row no matter how far
down you scroll

e Freeze First Column: Always displays the first column no matter
SMBER how far to the right you scroll

To unfreeze a row or column, repeat Steps 1 through 3 but click Unfreeze
Panes.

Displaying Slides Out of
Order in PowerPoint

When you display a PowerPoint presentation, your slides typically appear in
the order that you arranged them, starting with the first slide. If you want to

display your slides in a different order in the middle of a presentation, follow
these steps:

1. Load your presentation in PowerPoint and press F5.
The first slide of your presentation appears.
2. Type the number of the slide you want to view and press Enter.

If you want to jump to the fifth slide in your presentation, type 5 and
press Enter. If you jump to the fifth slide, clicking the mouse or pressing
the spacebar next displays the sixth slide, and then the seventh, and
so on.
\\3
Print a list of your slide titles and slide numbers on a sheet of paper so that
you know which slide number to type to view a particular slide.
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Reduce Spam in Outlook

If you have an e-mail account, you will get spam, that unwanted e-mail that
clogs millions of Inboxes every day with obnoxious offers for mortgage refi-
nancing, low-cost prescription drugs, or celebrity pornography. Unless you
actually enjoy deleting these messages manually, you can use Outlook to
filter your e-mail for you.

Setting up Outlook’s junk e-mail filter

Outlook can move suspected spam to a special junk e-mail folder automati-
cally. Because Outlook looks for keywords in spam, be aware that it will
never be 100 percent effective in identifying spam, but it can identify the
more blatant spam and save you the time and effort of deleting the messages
yourself.

To define Outlook’s spam filter, follow these steps:

1. Click on your Inbox folder.
2. Click the Home tab.

3. Click the downward-pointing arrow that appears to the right of the
Junk icon.

A menu appears, as shown in Figure 19-4.
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4. Click Junk E-mail Options.

The Junk E-mail Options dialog box appears, as shown in Figure 19-5.
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5. Select one of the following radio buttons:
® No Automatic Filtering: Turns off the Outlook spam filter.

¢ Low: Identifies and moves most obvious spam to the Junk E-mail
folder.

¢ High: Identifies and moves nearly all spam into the Junk E-mail
folder along with some regular e-mail messages, too, so check the
Junk E-mail folder periodically to look for valid messages.

e Safe Lists Only: Identifies and moves e-mail messages into the Junk
E-mail folder, except for those messages sent from addresses listed
in your Safe Senders List or Safe Recipients List.

6. Click OK.
The Options dialog box appears again.
7. Click OK.

Creating a Safe Senders list

A Safe Senders list lets you define all the e-mail addresses you want to accept
messages from, and Outlook routes all e-mail from other e-mail addresses
directly to your Junk E-mail folder.



The advantage of a Safe Senders list is that it guarantees you will never
receive spam. On the downside, though, it also guarantees that if some-
one tries to contact you whose e-mail address doesn’t appear on your Safe
Senders list, you will never get that valid message, either.

To create a Safe Senders list, follow Steps 1 through 4 in the preceding sec-
tion, “Setting up Outlook’s junk e-mail filter,” to display the Junk E-mail
Options dialog box. Then follow these steps:

1. In the Junk E-mail Options dialog box (refer to Figure 19-5), click the
Safe Senders tab.
The Safe Sender’s tab of the Junk E-mail Options dialog box appears.

2. (Optional) Select (or clear) the Also Trust E-mail from My Contacts
check box.

Selecting this check box tells Outlook that if you store someone’s e-mail
address in your Contacts list, you will also accept e-mail from that
person, too.

3. (Optional) Select (or clear) the Automatically Add People I E-mail to
the Safe Senders List check box.

This tells Outlook that if you send e-mail to someone, you’ll accept his
or her messages in return.

4. (Optional) Click the Add button.
The Add Address or Domain dialog box appears.

5. Type a complete e-mail address. (Or type a domain name — for exam-
ple, if you trust everyone from Microsoft.com to send you valid e-mail,
type @microsoft.com in this dialog box.)

6. Click OK.

7. Repeat Steps 4 through 6 for each additional e-mail address or domain
you want to add.

8. Click OK until all the dialog boxes disappear.

If you click on the Safe Recipients tab, you can repeat these steps to define
another list of e-mail addresses that you’ll accept as valid.

Creating a Blocked Senders list

If a particular e-mail address persists in sending you spam, you can choose
to selectively block that single e-mail address or domain. To create a Blocked
Senders list, follow Steps 1 through 4 in the earlier section, “Setting up

Chapter 19: Ten Tips for Using Office 2010 38 ’
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Outlook’s junk e-mail filter,” to display the Junk E-mail Options dialog box.
Then follow these steps:

1. In the Junk E-mail Options dialog box (refer to Figure 19-5), click the
Blocked Senders tab.

The Blocked Senders tab of the Junk E-mail Options dialog box appears.
2. Click the Add button.

The Add Address or Domain dialog box appears.
3. Type an e-mail address or domain name and then click OK.

The Options dialog box appears again.
4. Click OK until all the dialog boxes disappear.

Using Office Web

Office 2010 gobbles up a huge chunk of hard drive space and bombards you
with waves of features that you’ll probably never need (or use) in a million
years. In case you want to use Microsoft Office but find it too complicated,
try the free Office Web version instead.

Office Web provides simplified versions of Word, Excel, and PowerPoint

that you use over the Internet. As long as you have an Internet connection, a
browser, and a free Windows Live account, you can use Office Web to create,
edit, and share files with others.

Perhaps the greatest advantage of Office Web is that multiple people can col-
laborate on a single document from anywhere in the world. Instead of swap-
ping files back and forth (and risk losing track which file might be the latest
one), Office Web lets you store a single copy of your document online for
everyone to access.

Of course, the biggest drawback of Office Web is that you need an Internet
connection to use it. However, as Internet access becomes cheaper and more
accessible, this disadvantage shouldn’t be a problem for most people.

Even better, anyone with a browser can use Office Web, including Windows,
Mac OS X, and Linux users. Office Web is basically Microsoft’s answer to
Google Docs, so if the idea of using a word processor, spreadsheet, or presen-
tation program over the Internet appeals to you, then give Office Web a try.



Chapter 20
Ten Keystroke Shortcuts

0r1e common theme of Office 2010 is that all programs look and work alike.
After you learn how to use Word, you'll find it isn’t much harder to learn
Excel or PowerPoint because the Ribbon tabs all work in similar ways.

Even better, the same keystroke commands work alike in all Office 2010 pro-

grams. By memorizing the keystroke shortcuts in this chapter, you’ll be able

to work faster and more efficiently with Office 2010, no matter which particu-
lar program you may be using at the time.

Protecting Vourself with Undo
(Ctrl+Z) and Redo (Ctrl+V)

Many people are terrified of making a mistake, so they wind up never

trying anything new that could save them time and make their lives easier.
Fortunately, Office 2010 lets you freely experiment with different commands
because if you do anything, such as delete or modify text or add a picture or
page, you can immediately reverse what you just did by using the Undo com-
mand (Ctrl+Z) right away.

With the Undo command protecting you, you can try out different commands
to see what they do. If things don’t work the way you thought, press Ctrl+Z
and undo your last changes.

If you wind up undoing a change and then suddenly realize you didn’t want to
undo that change after all, you can redo a command you previously reversed.
To redo a command that you had undone, choose the Redo command (Ctrl+Y).

To undo multiple commands, follow these steps:

1. Click the downward-pointing arrow to the right of the Undo icon on
the Quick Access toolbar.

A pull-down menu appears of all the latest commands you’ve chosen.
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2. Highlight one or more commands on the Undo menu and click the last
command you want to undo.

3. (Optional) If you undo a command and suddenly want to redo it,
choose the Redo command by choosing one of the following:

e Click the Redo icon on the Quick Access toolbar.

¢ Press Ctrl+Y.

Cut (Ctrl+X), Copy (Ctrl+C),
and Paste (Ctrl+V)

SMBER

WING/

Editing any file often means moving or copying data from one place to
another. Understandably, three of the most common commands are the Cut,
Copy, and Paste commands.

To use the Cut or Copy command, just select an item (text or picture) and
choose the Cut or Copy icon on the Home tab (or press Ctrl+X to cut or
Ctrl+C to copy).

Both the Cut and Copy commands are most often used with the Paste com-
mand. However, the Cut command, without the Paste command, is essentially
equivalent to deleting selected text or objects.

Each time you choose the Cut or Copy command, Office 2010 stores that
selected data (text or pictures) on the Office Clipboard, which can hold up to
24 items. After you cut or copy items to the Office Clipboard, you can always
retrieve them.

If you turn off your computer or exit Office 2010, any items on the Office
Clipboard are lost.

To retrieve a cut or copied item from the Office Clipboard and paste it into a
document, follow these steps:

1. Click the Home tab.

2. Click the Clipboard icon in the Clipboard group.

3. Move the cursor to where you want to paste an item.

4. Click an item displayed on the Office Clipboard.

Office 2010 pastes your chosen item in your file.
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Saving a File (Ctrl+S)

MBER
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Never trust that your computer, operating system, or Office 2010 will work
when you need it. That’s why you should save your file periodically while
you’re working: If you don’t, and the power suddenly goes out, you'll lose
all the changes you made to your file since the last time you saved it. If the
last time you saved a file was 20 minutes ago, you'll lose all the changes you
made in the past 20 minutes.

It’s a good idea to save your file periodically, such as after you make a lot of
changes to a file. To save a file, choose one of the following:

v Press Ctrl+S.
v Click the Save icon on the Quick Access toolbar.
The first time you save a file, Office 2010 asks you for a descriptive name. After

you have saved a file at least once, you can choose the Save command, and
Office 2010 will save your file without bothering you with a dialog box.

Printing a File (Ctrl+P)

Despite all the promises of a paperless office, more people are printing and
using paper than ever before. As a result, one of the most common com-
mands you’ll use is the Print command.

To choose the Print command, press Ctrl+P or click the Print icon on the
Quick Access toolbar.

Checking Your Spelling (F7)

WMBER
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Before you allow anyone to see your file, run a spell-check first. Just press
F7, and Office 2010 diligently checks the spelling of your text. When the spell
checker finds a suspicious word, it displays a dialog box that lets you choose
a correct spelling, ignore the currently highlighted word, or store the high-
lighted word in the Office 2010 dictionary so it won'’t flag that word as mis-
spelled again.

Spell checkers are handy and useful, but they can be fooled easily. You might
spell a word correctly (such as their) but use that word incorrectly, such as
You knead two move over their. Spell-checking won’t always recognize gram-
matical errors, so you still need to proofread your file manually just to make
sure that you don’t have any misspelled or incorrect words in your file.

385
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If you don’t want Office 2010 to spell-check your entire file, just highlight the
text you want to spell-check and then press F7.

Opening a File (Ctrl+0)

Generally, you'll spend more time working with existing files than creating
new ones. Rather than force you to click the Office Button each time and find
the Open command buried on the Backstage View, just press Ctrl+O instead.
This immediately displays an Open dialog box so you can click the file you
want to open.

Creating a New File (Ctrl+N)

MBER
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Normally, if you want to create a new file in Office 2010, you have to click the
Office Button and click New. Then you have to decide if you want to create a
blank document or use a template.

Here’s a quick way to create a blank document: Just press Ctrl+N. Office
2010 immediately creates a blank file without making you wade through the
Backstage View.

Pressing Ctrl+N in Outlook 2010 creates a different item, such as creating a
new e-mail message or task, depending on what you’re doing with Outlook at
the time.

Finding Text (Ctrl+F)

The Find command lets you search for a word or phrase buried somewhere
within your file. To use the Find command, just press Ctrl+F. This opens a
dialog box that lets you type the text you want to find.

Finding and Replacing Text (Ctrl+H)

Sometimes you may need to find and replace text with something else, such
as replacing your cousin’s name with your own name (especially useful for
changing a will in a rich inheritance). To find and replace text, press Ctrl+H.
When a dialog box appears, type in the text you want to find and the text you
want to replace it.
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When replacing text, you have a choice of using the Replace or the Replace

All command. The Replace command lets you review each word before you
replace it to make sure that’s what you really want to do. The Replace All com-
mand replaces text without giving you a chance to see whether it’s correct.
When using the Replace All command, be aware that Office 2010 may replace
words incorrectly. For example, in addition to replacing Bob with Frank, Office
2010 might also replace all occurrences of Bobcat with Frankcat, which is prob-
ably something you don’t want to do.

Closing a Window (Ctrl+W )

To close a window, you can either click on that window’s Close box or click
the File tab and then click Close. For a faster alternative, just press Ctrl+W to
close the current window right away.

If you haven’t saved the contents of the current window, Office 2010 displays a
dialog box asking if you want to save your data before it closes the window.
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Chapter 21

Almost Ten Ways to Make Office
2010 Easier to Use

f you haven’t noticed by now, there are plenty of features buried in Office

2010 that you probably don’t need most of the time. However, if you're a
die-hard Office 2010 power user, you may want to peek at some of the more
advanced features buried inside the operating system.

Although these advanced features may take time to learn and master, you
may find the effort worth it to make Office 2010 behave exactly the way you
want it to. Best of all, you can learn these new features by playing with them
at work — so that way, you can learn something new and get paid for doing it
at the same time.

Learning Visual Basic for
Applications (VBA)

If you're like most people, you probably just want to use a program, make it
do what you need it to do, and then go home afterwards. However, if you find
yourself wishing Office 2010 could do something more, then you might want
to take some time to learn Visual Basic for Applications (VBA) programming.

The VBA programming language is what Office 2010 uses every time you
create a macro in Word, Excel, PowerPoint, or Access. While VBA might look
a bit strange at first, it’s based on the BASIC programming language, which
was specifically designed to make programming easy for beginners. Unlike
other programming languages like C++ that resemble chicken scratchings,
VBA actually looks like normal English commands.

The simplest way to learn how VBA works is to create your own macros and
then see how Office 2010 created a VBA program to make your macro work.
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To view the VBA code that makes up a macro in Word, Excel, or PowerPoint,
follow these steps:

1. Click the View tab.
2. Click the Macros icon that appears in the far-right side of the Ribbon.
If a menu appears, click View Macros. The Macros dialog box appears.

3. Click the macro name that you want to examine and click the Edit
button.

The Visual Basic for Applications window appears. In this window, you
can edit and create VBA code.

WMBER
Q“Q’ To take advantage of VBA programming, you’ll need to learn more about
the VBA language, such as from a book like VBA For Dummies, by John

Paul Mueller (Wiley).
4. Choose Filec>Close and Return.

Collaborating with the Review Tab

If you're the only person who needs to edit, view, and use your Office 2010
documents, you can safely skip over this section. However, if you're like
many people, you need to collaborate with others.

The old-fashioned way of collaborating meant printing paper copies, sending
them to others, and writing directly on them, but with Office, you can high-
light, mark up, and edit documents electronically so that you can distribute
files by e-mail or through a network. Each time someone makes a change to
a document, Office 2010 tracks these changes with a different color and even
identifies the contributor by name. Now you can see who wrote what, and
you can selectively keep those comments that are most valuable and ignore
the ones you don’t like.

Some of the more useful commands hidden on the Review tab include:

1+ New Comment: Lets you insert a comment directly into a document
without affecting the existing text.

v Track Changes: Highlights any new text or data that someone adds to an
existing document.

v Compare: Examines two files and highlights the differences between
the two. This tool also gives you the option of selectively merging the
changes into a single document.

By using the features stored on the Review tab, you can send multiple copies of a
file to others, let everyone make comments, mark up the text, move data around,
and then merge everyone’s comments and changes into a single, final version.
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Using Word’s References Tab

Most people use Word just to write letters or short reports. If you need to
create longer documents, then you might be interested in using the features
buried on Word’s References tab, such as:

v~ Insert Footnote: Creates a footnote at the bottom of the page.

v+~ Insert Endnote: Creates a list of notes at the end of a document.

v Table of Contents: Creates a table of contents based on the header
styles used in a document.

v~ Insert Caption: Automatically numbers figures, tables, or equations.

v+~ Insert Table of Figures: Creates a list of figures, tables, or equations that
you created using the Insert Caption command.

v Mark Entry: Tags words or phrases to appear in an index.

v~ Insert Index: Creates an index based on words or phrases tagged with
the Mark Entry command.

Using Excel’s Data Tab

Most people type data directly into an Excel worksheet and then manipu-
late that data through formulas or other commands. However, you can also
design a worksheet and then import data from another location (such as
stock quotes that you retrieve from a Web site), from a text file, from an
Access database, or even from a database file created by another program
(such as an ancient dBASE database).

Some of the features available on Excel’s Data tab include:

v From Access: Retrieves data from an Access database.
v From Web: Retrieves data stored in a table on a Web page.
v From Text: Retrieves data stored as an ASCII text file.

v From Other Sources: Retrieves data stored in other sources, such as an
SQL Server or XML file.

Saving and Sending Files

The traditional way to send a file to someone is to save your file, load your
e-mail program (such as Outlook), create a new message, attach your file (if
you can remember where you stored it), and send it over the Internet.



392 Partvil: The Part of Tens

Here’s a faster way to send a file:

1. In the file that you want to send, click the File tab.
Backstage View appears.

2. Click Save & Send.

3. Click Send Using E-mail and click one of the following:

e Send as Attachment: Attaches the Office 2010 file. Recipients will be
able to view and edit this file only if they also have Office 2010.

e Send as PDF: Converts the file to PDF format before attaching it to
the message. Recipients who don’t have special PDF-editing soft-
ware will be able to view the file only, but not edit it.

Password-Protecting a File

After creating a file, you may want to show it to others, but not let anyone
else modify it. You could trust that nobody will mess up your file, but a better
option is to password protect it so nobody can modify it without your per-
mission.

To password protect a file, follow these steps:

1. Click the File tab.
Backstage View appears.

2. Click Info and then click the Protect button (such as Protect Document
or Protect Presentation).

A menu appears.
3. Click Encrypt with Password.
An Encrypt Document dialog box appears.
gg\“\NG! 4. Type a password and click OK.

If you forget your password, you won'’t be able to access your own file, so
make sure you remember your password.
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Checking File Compatibility

Not everyone may be using Office 2010, so if you need to share files with
people stuck with older versions of Microsoft Office, you need to make sure
your files can be opened by others. Otherwise, you risk creating a great docu-
ment, but nobody else can see what you did.

To check your file’s compatibility with previous versions of Office, follow
these steps:

1. Click the File tab.
Backstage View appears.

2. Click Info and then click the Check for Issues button.
A menu appears.

3. Click Check Compatibility.

A Compatibility Checker dialog box appears, listing any parts of your file
that may not be compatible with older versions of Office.

Ignoring the Silly Office Ribbon

Although the Office Ribbon represents a more visual way to use Microsoft
Office, some people still prefer the classic pull-down menu interface of previ-
ous versions of Microsoft Office. For those who don’t want to give up their
familiarity with pull-down menus, you can buy an add-on program dubbed
Classic Menu for Office (which is available at www.addintools.com).

This program essentially gives back your pull-down menus so you can
choose between the Office Ribbon or the traditional pull-down menus. Now
you can have the best of both worlds without giving up either one.

The main drawback with this add-on program is that if you have to use
someone else’s copy of Office 2010 that doesn’t have this add-on installed,
you may feel lost trying to use the Ribbon alone. For this reason, it’s a good
idea to become familiar with the Office Ribbon and use this Classic Menu for
Office add-on program to help you make the transition from an older version
of Office to Office 2010.
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? (question mark) character, search
wildcard, 82

97-2003 file format, saving a file for older
versions of Office, 17-18

o/ o

Access
closing a database table without exiting,
333
closing a file when exiting, 333
conditional formatting, 366-368
database design, 321-323
Datasheet view, 327
deleting a report, 368
Design view, 364
electronic database, 319
filters, 337-343
Form view, 327-328
Layout view, 359
queries, 344-353
record searches, 336-337
relational database, 320
report themes, 365-366
Report Wizard, 355-359
sorts, 343-344
account passwords, e-mail configuration,
291
account type, 291
actions, undoing/redoing, 19-20, 43-44
Add New Account dialog box, e-mail
account, 292
addresses, e-mail, 291

alignments
presentation text, 240
table text, 121-122
text formatting, 95-96
animated cartoons, presentation slides,
260-261
Animation Painter, presentations, 278-279
appointments
defining start/end times, 305-308
deleting, 309
viewing, 308-309
area, chart type, 201
arrow keys
cursor positioning, 34-35
data selections, 37
document navigation, 76-77
Artistic Effects icon, picture
enhancements, 52-53
asterisk (*) character, search wildcard, 82
audio files, adding, 266-267
AutoFill, cell data entry, 142-143
AutoRecover, configuration settings,
371-372
AutoSum command, SUM function, 178-179
Available Templates window, Word
templates, 105-106
axes, chart element, 208
axis labels, chart element, 208

ol e

backgrounds
presentation styles, 250-254
presentation themes, 247-249
Backspace key
cell data editing, 157
deleting data, 39
Backstage View
closing a file, 18
common command display, 11-12
database creation, 322-323
default file format settings, 30-31
e-mail account setup, 292
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Backstage View (continued)
File menu/Office Button replacement, 10
file properties display, 11-12
File tab, 13-18
new file creation, 13-14
opening a recently used file, 15-16
opening an existing file, 14-15
opening/exiting, 12
optional feature display, 11-12
password-protecting files, 373-374
presentation creation, 230-231
presentation handouts, 286-287
Print Preview, 136
Ribbon customization, 31-32
saving a file for older version of Office,
17-18
saving files, 16-18
spreadsheet printing, 170
bar, chart type, 201
best-case scenarios, spreadsheets, 189-194
Blank Page icon, inserting pages into an
existing document, 110
Blocked Senders list, Outlook, 381-382
boldface
presentation text, 239
text appearance enhancement, 92
borders
cell formatting, 150
picture enhancements, 55-56
Break menu, inserting/removing page
breaks, 166-167
built-in styles, cell formatting, 148
bulleted lists
documents, 97-100
presentations, 241-243
Bullets icon, list creation, 98
Business Card view, Contacts, 311

oo

calendars

appointment creation, 305-308

viewing appointments, 308-309
cell borders, deleting, 128-129
cell formatting

borders, 150

built-in styles, 148

colors, 149-150

fonts, 148-149
text styles, 148-149
cell references
formula element, 171-172
functions, 176
Cell Size group, table row/column resizing,
124-125
Cell Styles menu, cell formatting, 148
cells
clearing contents, 162-163
copying/pasting formulas between,
175-176
data editing, 157
data entry conventions, 141-142
data selections, 142
deleting, 128, 154
deleting cell borders, 128-129
formula editing conventions, 180
formula search, 156-157
naming conventions, 153-154
renaming, 154
spreadsheet element, 140
spreadsheet number formatting, 143-147
text searches, 155-156
center alignment
presentation text, 240
text formatting, 95-96
Change Chart Type dialog box, 205-206
Change Font Size icon, Help window text
sizing, 61-62
character spacing, presentation text, 239
Chart Tools
Change Chart Type icon, 205-206
chart editing, 202-210
Move Chart icon, 204
Select Data icon, 206-207
Switch Row/Column icon, 207
charts
area, 201
axes, 208
axis labels, 208
bar, 201
column, 201
creating, 202-203
data labels, 208
data series, 199-200
data source selections, 206207
deleting, 210
editing, 202-210
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gridlines, 208
legends, 199-200, 208
line, 201
moving to a new worksheet, 203-204
pie, 201
PivotCharts, 224-226
predefined layouts, 209
presentation graphics, 255
resizing, 204-205
row/column switching, 207
titles, 199-200, 208
type switching, 205-206
x-axis, 199-200
y-axis, 199-200
Charts group, chart creation, 202-203
Clear Formatting command, 106-107
Clear menu, clearing cell contents, 162-163
clip art, presentation graphics, 253-255
Clipboard. See also Office Clipboard
copying/pasting data, 41
cutting/pasting data, 39-41
Close command (Ctrl+W)
Backstage View, 13, 18
closing a window, 387
Color icon, picture enhancements, 52-53
Color Scales, conditional formatting,
181-182
colors
cell formatting, 149-150
gradient background, 252-253
picture borders, 55-56
presentation backgrounds, 250-252
presentation text, 239
presentation themes, 247-249
Sparklines, 212
text appearance enhancement, 92-95
video enhancement, 264
column headings
freezing, 377-378
pivot table arrangements, 216-218
row label conversion, 219-220
columns
adding/deleting, 159
chart axis point setting, 207
creating from existing text, 132
deleting from a table, 127
editing, 132-133
presentation text layouts, 242-244
printing headings, 167-168

removing, 134
resizing, 158-159
Sparkline type, 210
spreadsheet element, 139-140
table creation, 115
table resizing, 123-125
combo boxes, Ribbon group, 23, 25
comma (,) character, table text separator,
119
commands. See also icons
adding to the Quick Access toolbar, 20-21
Backstage View display, 11-12
contextual tabs, 22-23
Live Preview display, 28
pop-up toolbar display, 38-39
Ribbon icons, 23-25
ScreenTips, 25-26
conditional formatting
data value comparison, 181-182
database reports, 366-368
rules, 182-184
Conservation view, e-mail messages,
300-301
Contacts
adding a name, 310
name searches, 312
viewing names, 311
contextual tabs, Ribbon command
organization, 22-23
contiguous cell ranges, cell references, 176
Copy command (Ctrl+C)
copying/pasting data, 41
copying/pasting formulas, 175-176
moving data, 384
one-click icon, 23-24
Corrections icon, picture enhancements,
52-53
Cover Page icon, 110-111
cover pages, adding/removing, 110-111
Create Chart gallery, chart type selection,
202-203
Create PivotTable dialog box, data
selections, 213-216
Create Sparklines dialog box, Sparkline
type selection, 210-211
Crosstab Query Wizard, crosstab query
347-349
crosstab query, databases, 346-349
Ctrl key, cursor positioning, 34
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currency, spreadsheet number formatting,
144-145
cursors
keyboard positioning techniques, 69
mouse positioning techniques, 67-68
positioning methods, 33-35
Customize Quick Access toolbar menu,
adding/removing command icons,
20-21
Cut command (Ctrl+X)
cutting/pasting data, 40-41
moving data, 384
one-click icon, 23-24

o) e

Daily calendar, Outlook, 305
data
cell content editing, 157
deleting, 39
mouse cut/copy/paste techniques, 43
moving, 39-41
Paste Options menu, 41-43
selection methods, 37-38
Data Bars, conditional formatting, 181-182
data labels, chart element, 208
data retrieval, electronic database, 319
data series, chart element, 199-200
data slicing, pivot tables, 222-224
data source, chart selections, 206-207
data storage, electronic database, 319
data summing, pivot tables, 221
data trace, formula auditing, 195
data types, database field definitions,
325-326
data validation, spreadsheets, 184-187
data values, conditional formatting, 181-182
database tables, unmatched query,
351-352
databases
adding form fields, 331-332
adding/deleting fields, 324-325
clearing a filter, 343
closing, 333
closing queries, 352-353
crosstab query, 346-349
data entry conventions, 327-328

Datasheet view, 327
defining filter criteria, 340-343
deleting a report, 368
deleting form fields, 330
deleting queries, 352-353
design guidelines, 321-323
duplicate field data query, 350
editing form data, 329
electronic advantages, 319
exact match filter, 338-339
field sizing, 325-326
field type definitions, 325-326
fields, 320
filter by form, 339-340
filters, 337-343
form creation, 328-329
form editing, 329-332
Form view, 327
forms, 320
naming fields, 323-324
queries, 320
records, 320
renaming queries, 352-353
Report Wizard, 355-359
reports, 320
simple query, 344-346
sorts, 343-344
specific record search, 336-337
tables, 320
unmatched query, 351-352
viewing form data, 329
viewing queries, 352-353
Datasheet view, 327
Date & Time functions, spreadsheets, 177
decimals, spreadsheet number formatting,
146-147
Delete icon
cells, 128
columns/rows, 127
entire tables, 126-127
Delete key
cell data editing, 157
deleting data, 39
dependents, formula auditing, 195-196
Design tab
spreadsheet headers/footers, 164-165
unique header/footer creation, 112-114



Design view, report editing, 364
dialog boxes, Ribbon display, 26-27
documents
application startup method, 10
changing fonts, 90-91
columns, 132-134
cover pages, 110-111
deleting tables, 126-128
Draft view, 70
drop caps, 129-130
footers, 111-114
Format Painter, 103-104
Full Screen Reading view, 69, 71
Go To command navigation, 77-78
grammar checking, 87
headers, 111-114
indentation definitions, 103
line spacing, 96-97
list creation, 97-100
margin settings, 102
mouse navigation techniques, 76-77
mouse scroll wheel navigation, 77
new page insertion, 109-110
orientation settings, 134-135
Outline view, 70, 72-76
page breaks, 111
page browsing, 83-84
page size settings, 134-135
previewing before printing, 134-136
Print Layout view, 69
Print Preview, 136
removing text formatting, 106-107
resizing fonts, 91
spell checking, 85-86
table data sorting, 125-126
table formatting, 121-125
table text, 114-120
templates, 105-106
text alignments, 95-96
text colors, 92-95
text styles, 92, 104-105
Web Layout view, 70
WordArt, 130-131
Draft view, Word, 70
drop caps, text appearance, 129-130
duplicate field query, databases, 350

oF o

effects, presentation themes, 247-249
e-mail. See also Mail
Blocked Senders list, 381-382
configuration settings, 291-292
creating from a stored address, 295-297
deleting messages, 302-303
file attachments, 297-298
junk e-mail filter, 379-380
message creation, 292-294
message groupings, 299-300
message replies, 294-295
retrieving a file attachment, 301-302
Safe Senders list, 380-381
e-mail addresses
e-mail configuration element, 291
new e-mail message creation, 295-297
End key
cursor positioning, 34-35
data selections, 37
Enter key, cell data entry conventions, 141
equal sign (=) character, formula indicator,
171
error checking, formulas, 196-198
Excel
adding/deleting pictures, 49-50
AutoFill, 142-143
AutoSum command, 178-179
built-in styles, 148
cell data entry conventions, 141-142
cell formatting, 147-150
cell naming conventions, 153-154
chart creation, 202-203
chart types, 201
clearing cell contents, 162-163
conditional formatting, 181-184
data editing, 157-162
data validation, 184-187
deleting worksheets, 161-162
editing charts, 202-210
error checking, 196-198
footers, 164-165
formula auditing, 194-196
formula editing conventions, 180
freezing column/row headings, 377-378
functions, 176-180
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Excel (continued) presentation audio, 266
Goal Seeking, 187-189 presentation videos, 262
gridline printing, 165 saving a file for older versions of Office,
headers, 164-165 17-18
inserting worksheets, 160 File menu. See Backstage View
navigation techniques, 151-152 File tab
number formatting, 143-147 Backstage View, 13-18
page breaks, 166-167 Word templates, 105-106
Page Layout view, 163-164 files. See also databases; documents;
paper orientation settings, 169-170 presentations; worksheets
paper size settings, 169-170 adding/deleting pictures, 49-50
print area definition, 165-166 application startup method, 10
print margin definitions, 169 Backstage View properties display, 11-12
printing column/row headings, 167-168 closing, 18
printing workbooks, 163-170 creating new, 13-14
rearranging worksheets, 161 default folder settings, 30-31
recently used function listing, 179-180 default format settings, 30-31
renaming worksheets, 161 descriptive names, 16
scenarios, 189-194 macro viruses, 374-375
search techniques, 155-157 opening existing, 14-15

Exit command, Backstage View, 13 opening recently used, 15-16

external files, presentation hyperlinks, 280 password-protecting, 373-374
saving, 16-18, 371-372

Y F Y fill colors, cell formatting, 149-150
filters
fields clearing, 343
adding, 331-332 database, 337-343
adding/deleting, 324-325 junk e-mail, 379-380
crosstab queries, 346-349 pivot tables, 220
database design, 321-323 report fields, 362-363
database element, 320 Financial functions, spreadsheets, 177
deleting, 330 Find and Replace command (Ctrl+H), text
deleting in a report, 365 ~ search, 84-85, 386-387
duplicate field data query, 350 Find and Replac'e dl‘alog box
naming conventions, 323-324 document navigation, 78
report filtering, 362-363 spreadsheet text search, 155-156
resizing in report, 363 text searches, 84-85
simple query, 344-346 Find command, text searches, 79-84, 386
sizing, 325-326 Find Duplicates Query Wizard, duplicate
sorting in a report, 361 field data query, 350
type definitions, 325-326 Find Options dialog box, search criteria,
file attachments 81-82
e-mail, 297-298 Find Unmatched Query Wizard, unmatched
retrieving from a message, 301-302 query, 351-352
file formats First Line Indent icon, Ruler, 103
97-2003, 17 folders, default path settings, 30-31

changing default, 30-31
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Font Color command, split-menu icon,
24-25
Font Color icon, text colors, 93
font colors, cell formatting, 149-150
Font command, combo box, 25
Font list box, changing fonts, 90-91
Font Size command, combo box, 25
Font Size list box, resizing fonts, 91
fonts
cell formatting, 148-149
changing, 90-91
Help window text sizing, 61-62
presentation themes, 247-249
presentations, 238-239
resizing, 91
footers
adding to a worksheet, 164-165
inserting/removing, 111-114
Form view, data entry conventions, 327
Format icon, spreadsheet column/row
sizing, 158-159
Format Painter, text formatting, 103-104
Format tab, picture height/width
settings, 51
forms
adding fields, 331-332
creating, 328-329
data editing, 329
data viewing, 329
database element, 320
deleting fields, 330
Formula bar, formula editing, 180
formulas
auditing, 194-196
calculation operations, 171-172
cell references, 171-172
conditional formatting, 181-184
copying/pasting, 175-176
data validation, 184-187
editing conventions, 180
entry conventions, 172-173
equal sign (=) character, 171
error checking, 196-198
functions, 176-180
Goal Seeking, 187-189
mathematical operators, 172

operator precedence, 174
parentheses ( and ) characters, 174
spreadsheet cell data, 140
spreadsheet searches, 156-157
Full Screen Reading view, Word, 69, 71
Function Arguments dialog box, cell
reference data, 178
Function Library group, function listings,
177
functions
Excel, 176-180
recently used listing, 179-180

oG o

Go To command
document navigation, 77-78
spreadsheet navigation, 152-153
Goal Seeking, spreadsheet use, 187-189
gradients, presentation backgrounds,
252-253
grammar checking, Word documents, 87
graphic transitions, presentation slides,
277-278
graphics
adding to a slide, 254-260
deleting, 258
moving, 258
object layering, 259-260
resizing, 258
rotating, 259
gridlines
chart element, 208
printing, 165
groups
Ribbon icons, 23-25
Show Dialog box icon, 26-27
Grow Font command, resizing fonts, 91

oH o

handles
moving/resizing/rotating pictures, 50-51
picture selections, 36-37

handouts, presentation, 285-287

Hanging Indent icon, Ruler, 103
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headers hyperlinks

adding to a worksheet, 164-165 external files, 280

inserting/removing, 111-114 presentation program startup, 280-281
headings Web page definition, 279-280

collapsing/expanding, 75-76
freezing column/row headings, 377-378 ° I ®

moving, 74-75
Outline view, 72-76 Icon Sets, conditional formatting, 181-182
printing, 167-168 icons. See also commands
promoting/demoting levels, 74 adding/removing Quick Access toolbar
search method, 82-83 commands, 20-21
text entry, 75 combo boxes, 23, 25
Help system menu, 23-24
browsing for help, 58-59 one-click, 23-24
keywords, 59-60 pop-up toolbar display, 38-39
ScreenTips, 25-26 Ribbon customization, 31-32
Help window Ribbon groups, 23-25
browsing for help, 58-59 ScreenTips, 25-26
Keep on Top, 62 Show Dialog box, 26-27
keyword searches, 59-60 split-menu, 23-25
minimizing/maximizing, 61 indents
opening/closing, 58 list items, 98
printing displayed text, 62 Ruler settings, 103
resizing, 60-61 Insert Picture dialog box, 49-50
table of contents display, 62-63 Insert Slicers dialog box, pivot tables,
text sizing, 61-62 222-224
highlighting, text, 93-94 Insert tab
Home key adding/deleting pictures, 49-50
cursor positioning, 34-35 chart creation, 202-203
data selections, 37 cover pages, 110-111
Home tab headers/footers, 112-114
Font list box, 90-91 inserting pages into an existing
Font Size list box, 91 document, 110
Format Painter, 103-104 page breaks, 111
Go To command, 77-78 Insert Table dialog box, table creation,
line spacing, 96-97 115-116
lists, 98-100 italics
removing text formatting, 106-107 presentation text, 239
spreadsheet number formatting, 144-147 text appearance, 92
text alignments, 95-96 items, indenting lists, 98
text colors, 92-94
text effects, 94-95 Y ] Py
text formatting tools, 89-96
text styles, 92, 104-105 junk e-mail filter, Outlook, 379-380

justified alignment
presentation text, 240
text formatting, 95-96
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Keep on Top, Help window display, 62
keyboards
cursor positioning, 33-35, 69
data selections, 37-38
document navigation techniques, 76-77
moving/resizing/rotating pictures, 50-51
spreadsheet navigation, 151-152
keywords, Help window searches, 59-60

o/ o

labels

chart element, 208

column heading conversion, 219-220

pivot table arrangements, 216-218
landscape orientation

document settings, 135

spreadsheet settings, 169-170
Layout view, viewing a report, 359
layouts, charts, 209
left alignment

presentation text, 240

text formatting, 95-96
legends, chart element, 199-200, 208
line spacing

presentation text, 241

text formatting, 96-97
Line Spacing command, menu icon, 24
Line Spacing icon, text formatting, 96-97
lines

chart type, 201

picture borders, 55-56

Sparkline type, 210
links

external files, 280

presentation program startup, 280-281

Web page definition, 279-280
lists

Blocked Senders, 381-382

bulleted, 241-243

creating in Word, 97-100

custom styles, 99

indenting items, 98

numbered, 241-243

pivot tables, 213-224
renumbering, 99-100
Safe Senders, 380-381
text conversions, 98-99
Live Preview, file change display, 28
Logical functions, spreadsheets, 177
Lookup & Reference functions,
spreadsheets, 177
loss/win, Sparkline type, 210

oM o

macro viruses, protection methods,
374-375
Mail. See also e-mail
Blocked Senders list, 381-382
Conservation view, 300-301
creating a message from a stored e-mail
address, 295-297
deleting messages, 302-303
file attachments, 297-298
junk e-mail filter, 379-380
message categories, 299-300
message creation, 292-294
message replies, 294-295
retrieving a file attachment, 301-302
Safe Senders list, 380-381
mail servers, e-mail configuration, 291
margins
Ruler settings, 102
spreadsheet printing definitions, 169
Margins icon, spreadsheet margin
definitions, 169
Marker Color icon, Sparkline, 212
match case, search criteria, 81
Math & Trig functions, spreadsheets, 177
mathematical operators, formulas, 172
menu icons, Ribbon group, 23-24
Microsoft OneNote 2010, 313
mistakes
error checking, 196-198
formula auditing, 194-196
undoing/redoing actions, 19-20, 43-44
Monthly calendar, Outlook, 305
More functions, spreadsheets, 177
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mouse
cell reference conventions, 173
cursor positioning, 33-35, 67-68
cut/copy/paste techniques, 43
deleting cell borders, 128-129
document navigation techniques, 76-77
moving a chart, 203
moving/resizing/rotating pictures, 50-51
picture selection handles, 36-37
point-and-drag data selections, 35-37, 38
pop-up toolbar display, 38-39
resizing a chart, 204-205
resizing columns/rows, 158
right-click menu display, 377
scroll wheel navigation, 77, 151
spreadsheet column/row sizing, 158
spreadsheet navigation, 151
table creation method, 116-118
table row/column resizing, 123-124
text selections, 36
Move Chart dialog box, 204
movies. See also videos
adding to a slide, 262-264
animated cartons, 260-261
presentation addition, 260-266
supported file formats, 262
Multilevel List icon, list creation, 98
multilevel lists, creating, 97-100

o\ o

Name Manager dialog box, cell editing, 154
names, e-mail configuration element, 291
negative numbers, spreadsheet number
formatting, 145-146
New command (Ctrl+N)
Backstage View, 13, 14
new file creation, 386
New Query dialog box
crosstab query, 347
duplicate field data query, 350
simple query, 344-345
unmatched query, 351
Next Page, document navigation, 76-77
noncontiguous cell ranges, cell
references, 176

Number Format list box, spreadsheet
number formatting, 144-147

number formatting

currency, 143-145

decimals, 146-147

negative numbers, 145-146

percentages, 143-145

spreadsheet conventions, 143-147
numbered lists

creating, 97-100

presentations, 241-243

renumbering, 99-100
Numbering icon, list creation, 98
numbers, spreadsheet cell data, 140

o () o

object layering, presentation graphics,
259-260
Office 2010
application startup, 10
AutoRecover, 371-372
Backstage View, 10-18
command consistency across
applications, 9
data manipulation processes, 9
default file formats, 30-31
exiting properly, 32
Live Preview, 28
pop-up toolbar display, 38-39
Quick Access toolbar, 19-22
Ribbon, 22-29
Ribbon customization, 31-32
saving files, 371-372
Office Button. See Backstage View
Office Clipboard. See also Clipboard
closing, 47
deleting items, 46-47
sharing data between applications, 45-47
viewing/pasting items, 45-46
Office Web, pros/cons, 382
one-click icons, Ribbon group, 23-24
Open command (Ctrl+O)
Backstage View, 13, 14-15
opening a file, 386
Open dialog box, 14-15



operator precedence, Excel formulas, 174
Options command, Backstage View, 13
Options dialog box
AutoRecover settings, 372
default file format settings, 30-31
Ribbon customization, 31-32, 375-376
orientation
document settings, 134-135
spreadsheet settings, 169-170
Outline Numbering icon, list creation, 98
Outline view
presentation design method, 234-236
Word, 70, 72-76
outlines
collapsing/expanding headings, 75-76
heading levels, 73-76
heading text, 75
moving headings, 74-75
promoting/demoting heading levels, 74
Outlook
appointments, 305-309
Blocked Senders list, 381-382
Contacts, 310-312
Conversation view, 300-301
deleting messages, 302-303
e-mail account addition, 292
e-mail configuration settings, 291-292
file attachments, 297-298
junk e-mail filter, 379-380
message categories, 299-300
message creation, 292-294
message replies, 294-295
Microsoft OneNote 2010, 313
retrieving a file attachment, 301-302
Safe Senders list, 380-381
task management, 312-316

oo

page breaks, inserting/removing, 111,
166-167
Page Down key
cursor positioning, 34-35
data selections, 37
Page Layout tab, columns, 132-134
Page Layout view, print settings, 163-164

Page Setup dialog box, printing column/
row headings, 168
page size, document settings, 134-135
Page Up key
cursor positioning, 34-35
data selections, 37
pages
header/footer display, 111-114
inserting into an existing document,
109-110
paper size, spreadsheet settings, 169-170
paragraphs
mouse selections, 36-37
table text separator, 118
parentheses ( and ) characters, formulas,
174
passwords
e-mail configuration element, 291
file protections, 373-374
Paste command (Ctrl+V)
copying/pasting formulas, 175-176
cutting/pasting data, 41
moving data, 384
split-menu icon, 25
Paste Options menu, formatted data, 41-43
patterns, presentation themes, 247-249
percentages, spreadsheet number
formatting, 144-145
phonetic pronunciation, search criteria, 82
Picture Border icon, enhancements, 55-56
Picture Effects icon, 52-54
Picture Styles group, picture
enhancements, 54-55
pictures
adding/deleting, 49-50
borders, 55-56
moving, 50-51
presentation backgrounds, 253-254
presentation graphics, 254-255
resizing, 51
rotating, 51
selection handles, 36-37
styles, 54-55
visual enhancements, 52-54
pie, chart type, 201
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pivot tables
column heading selections, 213-216
filters, 220
label arrangements, 216-218
PivotCharts, 224-226
row label to column heading conversion,
219-220
slicing, 222-224
summing, 221
PivotCharts, creating from a pivot table,
224-226
point-and-drag, data selections, 35-37
pop-up toolbar, text editing, 38-39
portrait orientation
document settings, 135
spreadsheet settings, 169-170
PowerPoint
adding/deleting pictures, 49-50
Animation Painter, 278-279
background styles, 250-254
graphic addition, 254-260
handouts, 285-287
hyperlinks, 279-281
movie addition, 260-266
moving between slides, 378
object layering, 259-260
Outline view, 234-236
presentation creation, 230-231
presentation purpose, 229-230
sections, 271-274
Slide Sorter view, 284-285
Slide view, 231-233
sound files, 266-268
sound recordings, 267-268
supported audio formats, 266
supported video formats, 262
text boxes, 237-246
themes, 247-249
viewing presentations, 281-285
visual transitions, 275-279
precedents, formula auditing, 195
prefixes, search criteria, 82
presentations
adding a section, 271-272
animated cartoons, 260-261
Animation Painter, 278-279
background styles, 250-254

bulleted lists, 241-243
clip art, 255-256
coloring a video, 264
column layouts, 242-244
creating in Backstage View, 230-231
deleting graphics, 258
deleting sections, 274
deleting slides, 233
expanding/collapsing a section, 272-273
external file hyperlink, 280
gradient background, 252-253
graphic addition, 254-260
handouts, 285-287
hiding/displaying slides, 284
hiding/unhiding slides, 233
hyperlinks, 279-281
launching a program through a hyperlink,
280-281
line spacing, 241
movie addition, 260-266
moving a text box, 244-245
moving between slides, 378
moving graphics, 258
new slide insertion, 232
numbered lists, 241-243
object layering, 259-260
Outline view, 234-236
picture backgrounds, 253-254
picture files, 254-255
purpose definitions, 229-230
rearranging slides, 233
reshaping a video, 264-266
resizing a text box, 244-245
resizing graphics, 258
rotating a text box, 245-246
rotating graphics, 259
screenshots, 257-258
slide sections, 271-274
Slide Sorter view, 284-285
Slide view, 231-233
solid color backgrounds, 250-252
sound files, 266-268
sound recordings, 267-268
spell checking, 269-270
supported audio formats, 266
supported video formats, 262
target audience, 230



text alignments, 240
text boxes, 237-246
text formatting, 238-239
themes, 247-249
viewing, 281-285
visual transitions, 275-279
Web page hyperlinks, 279-280
WordArt, 256-257
Previous Page, document navigation, 76-77
print area, defining, 165-166
Print command (Ctrl+P)
Backstage View, 13
files, 385
Print dialog box, printing Help window
text, 62
Print Layout view, Word, 69
Print Preview, chcking documents before
printing, 136
printing
column headings, 167-168
gridlines, 165
Help window text, 62
presentation handouts, 286-287
previewing documents before printing,
134-136
print area definition, 165-166
Print Preview, 136
row headings, 167-168
spreadsheet margin definitions, 169
workbooks, 163-170
programs, running through a hyperlinks,
280-281
properties, Backstage View display, 11-12
protections
file passwords, 373-374
macro viruses, 374-375
punctuation, search criteria, 82
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queries
closing, 352-353
crosstab, 346-349
database element, 320
deleting, 352-353
duplicate field data, 350
renaming, 352-353

simple, 344-346
unmatched, 351-352
viewing, 352-353

question mark (?) character, search

wildcard, 82

Quick Access toolbar
adding/removing command icons, 20-21
icon selections, 19-20
moving, 22
Redo command, 19-20, 43-44
Undo command, 19-20, 43-44
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Recent command, Backstage View, 13,
15-16
Recently Used menu, spreadsheet
functions, 179-180
Record Sound dialog box, 267-268
records
clearing a filter, 343
database element, 320
exact match filter, 338-339
filter criteria, 340-343
report counting, 359-361
specific record search, 336-337
Redo command (Ctrl+Y), 19-20, 43-44,
383-384
Report Wizard, database reports, 355-359
reports
conditional formatting, 366-368
database element, 320
deleting, 368
deleting fields, 365
electronic database advantage, 319
field filtering, 362-363
field sorting, 361
record counting, 359-361
Report Wizard, 355-359
resizing fields, 363
themes, 365-366
value counting, 359-361
viewing in Layout view, 359
Ribbon
combo boxes, 23, 25
configuration settings, 375-376
contextual tabs, 22-23
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dialog box display, 26-27
icon customization, 31-32
icon groups, 23-25
icon ScreenTips, 25-26
Live Preview, 28
menu icons, 23-24
minimizing/maximizing, 28-29
moving the Quick Access toolbar, 22
one-click icons, 23-24
Show Dialog Box icon, 26-27
split-menu icons, 23-25
right alignment
presentation text, 240
text formatting, 95-96
right-click menus, displaying, 377
row headings, freezing, 377-378
row labels, column heading conversion,
219-220
rows
adding/deleting, 159
chart axis point setting, 207
deleting from a table, 127
printing headings, 167-168
resizing, 158-159
spreadsheet element, 139-140
table creation, 115
table resizing, 123-125
Ruler
hiding/displaying, 101
indentation definitions, 103
left/right margin settings, 102
text formatting tool, 101-103
rules, conditional formatting, 182-184

oS e

Safe Senders list, Outlook, 380-381
Save & Send command, Backstage View,
13,17-18
Save As command, Backstage View, 13,
16-18
Save As dialog box, password-protecting
files, 373-374
Save command (Ctrl+S)
Backstage View, 13, 16-18
default file format settings, 30-31
saving a file, 385

Scenario Manager
creating, 190-191
editing, 192
viewing, 191-192
viewing a scenario summary, 192-194
scenarios
creating, 189-191
editing, 192
summary views, 192-194
viewing, 191-192
scientific format, spreadsheet number
formatting, 145
screenshots, presentation graphics,
257-258
ScreenTips, Ribbon icon information,
25-26
scroll area
document navigation, 76-77
spreadsheet navigation, 151
scroll bars
document navigation, 76-77
spreadsheet navigation, 151
scroll box, document navigation, 76-77
scroll wheel
document navigation, 77
spreadsheet navigation, 151
searches
by heading, 82-83
Contact names, 312
criteria selections, 81-82
database filters, 337-343
database record, 336-337
find and replace text, 78-85
Help window, 59-60
Outlook tasks, 315-316
page browsing, 83-84
spreadsheet formulas, 156-157
spreadsheet text, 155-156
sections
adding to a presentation, 271-272
deleting, 274
expanding/collapsing, 272-273
presentation slides, 271-274
Select Browse Object, document
navigation, 76-77

Select Data Source dialog box, chart data

source selection, 206-207



Select icon, table data selections, 121
selection handles
moving/resizing/rotating pictures, 50-51
pictures, 36-37
selections
cell data, 142
copying/pasting data, 41
cutting/pasting data, 39-41
deleting data, 39
keyboard techniques, 37-38
mouse cut/copy/paste techniques, 43
mouse techniques, 35-37, 38
picture selection handles, 36-37
pivot table data, 213-216
pop-up toolbar display, 38-39
table data, 121
shadows, presentation text, 239
shared files
saving a file for older versions of Office,
17-18
sharing data between applications, 45-47
Shift key, data selections, 37
Shift+Enter keys, cell data entry
conventions, 141
Shift+Tab keys
cell data entry conventions, 141
indenting list items, 98
Show Dialog Box icon, dialog box display,
26-27
Shrink Font command, resizing fonts, 91
Simple Query Wizard, simple query
creation, 345-346
simple query, databases, 344-346
slicers, pivot tables, 222-224
slide shows, viewing presentations,
281-285
Slide Sorter view, viewing presentations,
284-285
Slide view, presentation design method,
231-233
slides
adding a transition, 275-277
animated cartoon placement, 260-261
clip art placement, 255-256
collapsing/expanding subtitles, 235-236
coloring a video, 264
deleting, 233, 236
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deleting graphics, 258
graphic transitions, 277-278
hiding/displaying, 284
hiding/unhiding, 233
inserting new, 232, 235
movie addition, 262-264
moving between, 378
moving graphics, 258
picture placement, 255
presentation handouts, 285-287
rearranging, 233, 236
reshaping a video, 264-266
resizing graphics, 258
rotating graphics, 259
screenshots, 257-258
section organization, 271-274
sound addition, 266-268
sound recordings, 267-268
subheadings, 234
subtitles, 235-236
text, 234, 237-246
text transitions, 277-278
titles, 234
WordArt, 256-257
Sort dialog box, table data sorting, 125-126
sorts
databases, 343-344
report fields, 361
table data, 125-126
sounds, presentation addition, 266-268
Sparklines
appearance enhancements, 212
deleting, 213
displaying, 210-212
location ranges, 211
Spell Checker command (F7), spell
checking, 385-386
spell checking
PowerPoint presentations, 269-270
Word documents, 85-86
Spelling dialog boxs, 270
split-menu icons, Ribbon group, 23-25
spreadsheets. See also workbooks;
worksheets
adding/deleting rows and columns, 159
AutoFill, 142-143
AutoSum command, 178-179
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spreadsheets (continued)
cell components, 140
cell data editing, 157
cell data entry, 141-142
cell formatting, 147-150
column/row sizing, 158-159
conditional formatting, 181-184
data tracking tool, 139-140
data validation, 184-187
error checking, 196-198
footers, 164-165
formula auditing, 194-196
formula editing conventions, 180
Goal Seeking, 187-189
gridline printing, 165
headers, 164-165
inserting worksheets, 160
keyboard navigation, 151-152
mouse navigation techniques, 151
number formatting, 143-147
page breaks, 166-167
paper orientation settings, 169-170
paper size settings, 169-170
pivot tables, 213-224
PivotCharts, 224-226
print area definition, 165-166
print margin definitions, 169
printing column/row headings, 167-168
printing workbooks, 163-170
recently used function listing, 179-180
scenarios, 189-194
search methods, 155-157
Sparklines, 210-213
what-if scenarios, 140
Start menu, application startup method, 10
strikethrough, text, 92
strikethroughs, presentation text, 239
styles
cell formatting, 148
picture enhancements, 54-55
presentation backgrounds, 250-254
table formatting, 122-123
text formatting, 104-105
subheadings
collapsing/expanding, 75-76
slide element, 234
subscript, text appearance enhancement, 92

subtitles, slides, 235-236

suffixes, search criteria, 82

SUM function, AutoSum command, 178-179

summing, pivot tables, 221

superscript, text appearance
enhancement, 92

Switch Row/Column icon, chart row/
column switching, 207
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Tab key
cell data entry conventions, 141
indenting list items, 98
table of contents, Help window display,
62-63
Table Properties dialog box, table row/
column resizing, 124-125
tables
adding form fields, 331
cell borders, 128-129
cells, 128
closing a database, 333
column/row resizing, 123-125
columns/rows, deleting, 127
creating from existing text, 118-120
creating from rows/columns, 115
creating with the mouse, 116-118
data selection methods, 121
data sorting, 125-126
database design, 321-323
database element, 320
deleting, 126-128
deleting entire, 126-127
Insert Table dialog box, 115-116
styles, 122-123
text alignments, 121-122
unmatched query, 351-352
tabs, table text separator, 118
target audience, presentation element, 230
tasks
searches, 315-316
storing, 313-315
templates
new file creation, 13-14
preformatted Word documents, 105-106



text
find and replace searches, 78-85
heading entry conventions, 75
list item conversion, 98-99
mouse selection methods, 36
slide element, 234, 237-246
spreadsheet cell data, 140
spreadsheet search, 155-156
table creation, 114-120

text alignments, presentations, 240

text boxes
moving, 244-245

presentation entry conventions, 237-238

resizing, 244-245

rotating, 245-246
text editing

deleting data, 39

moving data, 39-41

pop-up toolbar display, 38-39
Text Effects icon, text appearance, 94-95
text effects, enhancement, 94-95
text formatting

alignments, 95-96

colors, 92-95

columns, 132-134

drop caps, 129-130

font style, 90-91

Format Painter, 103-104

line spacing, 96-97

presentations, 283-239

removing, 106-107

resizing fonts, 92

Ruler, 101-103

styles, 104-105

templates, 105-106

text effects, 94-95

text styles, 92

WordArt, 130-131
Text functions, spreadsheets, 177
Text Highlight Color icon, text colors,

93-94

text styles

appearance enhancements, 92

cell formatting, 148-149

text formatting, 104-105
text transitions, presentation slides,

277-278

themes
database reports, 365-366
presentation design method, 247-249

thumbnail images, multiple page document

browsing, 83-84
titles
chart element, 199-200, 208
slide element, 234
topics
browsing for help, 58-59
keyword searches, 59-60
transitions, presentation slides, 275-279
transparencies, gradient backgrounds,
252-253
Trust Center, macro virus protection,
374-375

olf o

underline
presentation text, 239
text appearance enhancement, 92
Undo command (Ctrl+Z), 19-20, 43-44,
383-384
unique header/footer, page display
selections, 112-114
unmatched query, databases, 351-352
username, e-mail configuration element,
291

oo

values
pivot table summing, 221
report counting, 359-361
videos. See also movies
coloring, 264
reshaping, 264-266
supported file formats, 262
trimming, 262-264
views, switching between, 70
viruses, macro, 374-375

visual effects, picture enhancements, 52-54

visual transitions, presentation slides,
275-279
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Web Layout view, Word, 70
Web pages, presentation hyperlink
definition, 279-280
Weekly calendar, Outlook, 305
what-if analysis, Goal Seeking, 187-189
what-if scenarios, spreadsheets, 140
white space, 82
whole words, search criteria, 81
wildcards, searches, 82
win/loss, Sparkline type, 210
Word
adding/deleting pictures, 49-50
changing fonts, 90-91
cover pages, 110-111
deleting tables, 126-128
document navigation techniques, 76-77
Draft view, 70
drop caps, 129-130
find and replace text, 78-85
footers, 111-114
Format Painter, 103-104
Full Screen Reading view, 69, 71
Go To command navigation, 77-78
grammar checking documents, 87
headers, 111-114
heading levels, 73-76
line spacing, 96-97
lists, 97-100
mouse navigation techniques, 76-77
multiple page document browsing, 83-84
new page insertion, 109-110
orientation settings, 134-135
Outline view, 70, 72-76
page breaks, 111
page size settings, 134-135
previewing documents before printing,
134-136
Print Layout view, 69
Print Preview, 136
removing text formatting, 106-107

Ruler, 101-103
spell checking documents, 85-86
styles, 104-105
switching between views, 70
table data sorting, 125-126
table formatting, 121-125
table text, 114-120
templates, 105-106
text alignments, 95-96
text colors, 92-95
text styles, 92
Web Layout view, 70
WordArt, 130-131
word forms
mouse selections, 36
search criteria, 82
WordArt
presentation graphics, 255-257
text appearance enhancements, 130-131
workbooks, printing, 163-170
worksheets
deleting, 161-162
inserting, 160
moving a chart to a new location, 203
moving a chart to a new worksheet, 204
rearranging, 161
renaming, 161
worst-case scenarios, spreadsheet use,
189-194

o X o

x-axis, chart element, 199-200

oyo

y-axis, chart element, 199-200
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zooms, magnification methods, 377
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